• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 378
  • Last Modified:

Windows 2000 not connecting or seeing two XP Machines,

This may have been answered, but I really haven't found the answer to my particular situation.

I have three computers connecting to a DSL router. Two XP machines, and one Windows 2000 machine. All machines are connected to a DSL router and hub. All three machines can connect to the internet.

The Problem:
The Win2000 machine cannot see the two other XP machines. The XP machines can see the shared folder on the Win2000 machine, but when clicked within My Shared Network Places, the prompt comes up that XP cannot connect and "you may not have permission, contact the administrator".

The Details: A shortcut made on one of the XP machines to the particular I.P. address of the Win2000 machine and that connation works fine, the folder that is shared is seen on the XP machine and can be accessed. But on the same XP machine when one goes to: Computers near me > the error mentioned about occurs. The Win2000 machine has NetBeui installed for some reason.. When browsing the network, only the 2000 machine is listed (itself). When I removed NetBeui the machine seems to see nothing at all in WORKGROUP.

* The XP machines are set to "Obtain IP address Automatically*
* The Win2000 machine is set to Use an IP Address 192.168.2.** Subnet 255.255.255.0 DG: 192.168.2.1
*** WHEN set to "Obtain IP Address Automatically" as are the XP boxes, the 2000 machine does not see the Workgroup or anything.

Steps so far taken:
* All three machines have the same network name: WORKGROUP.  
* The firewall was turned off on one of the XP machines, (with no change)
* Obtain Address Automatically was enabled on the 2000 box didn't seem to work unless I needed to do something else..
* Again, all three machines can connect to the internet, but the two XPs do not connect to the 2000 and visa-versa.
* I renamed the 2000 box and that didn't help, changed it back and sometimes I see the old names I created in the "Computers near me" area.

What can I do to get these all working together?

Thanks for the help in advance.

MrSlate
0
mrslate1
Asked:
mrslate1
  • 5
  • 3
  • 2
2 Solutions
 
rindiCommented:
First you need to create the same user accounts on the w2k machine as you are using to connect to that machine on the XP boxes and allow those accounts the necessary rights to connect to the shared resources.

In order to connect to the other machine using "clear text" names, you should create a "hosts" file on all the PCs in the system32\drivers\etc directory. This hosts file must contain the names and ip addresses of all the connected PCs.

hosts

192.168.0.2           pc1
192.168.0.3           pc2
192.168.0.4           pc3
127.0.0.1               localhost

you can use the same hosts file for all PCs.

Also make a "lmhosts" file in the same location with the same info.

The hosts file acts like a simple dns server so that the local names are resolved correctly, and the lmhosts file acts like a simple wins server.
0
 
mrslate1Author Commented:
Thank you rindi,

What is the alternative to "Clear Text" name? I assume you are refering to the name of the computer I created? Also shouldn't I be able to just specify ALL for permissions? There are only three machines in this small network.
0
 
mrslate1Author Commented:
By the way I havn't tried your suggestions as of yet.
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
rindiCommented:
The alternative to a clear text name is the ip address. You could map a shared resource to a local drive letter on the PC. You can use windows explorer to map drives.

If you logon to the PCs as administrator you won't have to create separate user accounts on all PCs in order to connect to them, but that again is a big security hole.

Also make sure you have disabled "Simple file sharing" on the XP boxes. If that is enabled it makes file sharing everything but simple.
0
 
mrslate1Author Commented:
Thank you, I will try it and let you know if this all works..

MS
0
 
nedvisCommented:
     "The XP machines are set to "Obtain IP address Automatically*  "
       Does your router acts as a DHCP server ?
       It would be much better to assign static IP addresses to the computer ethernet cards and select Class C network ( host address range 192.0.0.0 - 223.255.255.255 , subnet mask 255.255.255.0 )
      Choosing "WORKGROUP" as a name for the workgroup  is at least bad choice as well as workgroupnames like MSHOME , MSLAN , MYLAN , MYNET , HOMENET etc . It would be much better to select for instance SLATE1NET or MRSLATENET for workgroup name for your LAN. It's more personalised, and much harder for intruders to guess and obtain  the workgroup name.
            Also , assuming that all your computers have unique computernames (  since no two computers with the same computername can exist on the same subnet - in this case  192.168.0.x/255.255.255.0  ) and same user account (besides Administrator and Guest accounts- for instance mrslate1 ) exists on all three computers, make sure at least one folder on each PC is shared ( It's bad practice to share whole drives/volumes e.g. c:\  or d:\ ) .
          One more thing : in Services section of Administrative tools on two of your computers disable Browser Master service which " Maintains an up-to-date list of computers on your network and supplies the list to programs that request it ". This way your three PC wont compete over the master browser role in your LAN.

       You dont really need help from HOSTS file as long as each and every PC on your LAN has :
         unique computername
         same IP address/subnetmask class  assigned to their network cards ( e.g.   192.168.0.X/255.255.255.0 and default gateway 192.168.0.1 )
        disabled WINS protocol
        enabled NetBIOS over TCP/IP
        computer belongs to the same workgroup ( e.g.  MRSLATENET )
        same user account/password profile exists on each of computers hoocked to your LAN .

     good luck
     nedvis
     

       
     
         
         
           

 
0
 
mrslate1Author Commented:
Great Information nedvis! The router is acting as the DHCP server I belive. I am going back to the site on Friday 4-29-05 and I will let all know what worked.

I am going to impliment a lof of your suggestions nedvis. Great tips.
0
 
nedvisCommented:
All right - keep us updated
good luck
nedvis
0
 
mrslate1Author Commented:
Okay here is the solution.

I had to give the machines static IP addresses and create LMHost files on two of the machnies. Once that was done, Everyone could see each other on the small network. I also gave the workgroup a unique name as suggested by ndvis, and created accounts on each machine for all users.

I am keeping a record of all the suggestions I received as I know I am going to see this issue again.

Thanks for all the great help.

MrSlate1
0
 
rindiCommented:
Thanx, too.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 5
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now