• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 346
  • Last Modified:

PHP : Unable to use the mimeDecode.php file from PEAR

Hi Everyone,

I was hoping for some help in includnig mimeDecode.php in one of my
pages. When I try to include the file using:

include ('Mail/mimeDecode.php')

I get the following:

Warning: open_basedir restriction in effect. File is in wrong
directory in /home/httpd/vhosts/mydomain.com/httpdocs/phptest.php on
line 10

Warning: Failed opening 'Mail/mimeDecode.php' for inclusion
(include_path='.:/usr/share/pear')
in /home/httpd/vhosts/mydomain.com/httpdocs/phptest.php on line 10

I have confirmed that mimeDecode.php is located here:

/usr/share/pear/Mail

I turned off safe mode and confirmed it was off using phpinfo(), but
still have the same problem. Looking at my other settings, I see the
following that I assume are relevant:

include_path .:/usr/share/pear
safe_mode_include_dir /usr/share/pear

Could anyone shed some light on my problem?
0
usachrisk1983
Asked:
usachrisk1983
  • 2
1 Solution
 
Bob LearnedCommented:
If you can't get an answer here, try this PHP-specific topic area:

PHP:
http://www.experts-exchange.com/Web/Web_Languages/PHP/

Bob
0
 
usachrisk1983Author Commented:
Thanks, I expected to see PHP under programming and didn't even consider looking at Web.  If there is a mod out there who has the ability to move this, please feel fere.
0
 
usachrisk1983Author Commented:
Was able to solve before getting answer from board, resolution is to modify the httpd.conf and change the open_basedir to include /usr/share/pear.  

Mod, please close.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now