?
Solved

Exchange Server 2003 SMTP error

Posted on 2005-04-26
20
Medium Priority
?
2,749 Views
Last Modified: 2012-05-05
This seems to be a common question, but I still seem to be having issues.

Your message did not reach some or all of the intended recipients.

      Subject:     Origianl Subject
      Sent:     Date Time

The following recipient(s) could not be reached:

      'Recipient Mail Address' on Date Time
            You do not have permission to send to this recipient.  For assistance, contact your system administrator.
            <Mail server FQDN #5.7.1 smtp;550 5.7.1 Unable to relay for Recipient Mail Address <mailto:Recipient Mail Address>>

I have a SBS2003 Server with Exchange 2003 running where all inhouse email and most outside email goes through without incident.  I am however running into an issue where the above error is coming back to us on, at this time, only one address.  

I have checked for the possibility of being on a RBL list and I'm not listed.  I have checked the relay for authenticated machines and it is active.  I have also looked at responses about the Reverse PTR and I have my internal IP and external IP listed.

Any further thoughts would be greatly appreciated.

Thanks
0
Comment
Question by:c_ur_f8
  • 9
  • 7
  • 2
  • +2
20 Comments
 
LVL 9

Expert Comment

by:kfullarton
ID: 13869201
Open a telnet connection to your smtp server on port 25.  You may get more detailed error information.  For the command syntax, go to http://www.yuki-onna.co.uk/email/smtp.html

0
 

Author Comment

by:c_ur_f8
ID: 13870416
I'm not getting any reply from the server.  There is, however, a new firewall that was put in place.  Could this be at issue?
0
 

Author Comment

by:c_ur_f8
ID: 13871061
I did get into the telnet session and received the error, "501 5.5.4 Invalid Address"
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 79

Expert Comment

by:lrmoore
ID: 13871415
>There is, however, a new firewall that was put in place
Yes, this could be the issue. What kind of firewall? Do you administer it?

0
 

Author Comment

by:c_ur_f8
ID: 13872612
This is a PIX and I can administer it, but it has been in someone else's hands.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13873037
Can you go ahead and post the PIX config?
0
 
LVL 9

Expert Comment

by:kfullarton
ID: 13875991
When you ping the server by name, does it return the correct IP address?  If not, you have a DNS/hosts file resolution issue.  When trying to telnet to the server, follow this command syntax:  telnet xxx.xxx.xxx.xxx 25
0
 

Author Comment

by:c_ur_f8
ID: 13876665
I do get a correct IP when pinging and I have used that telnet function including the port number.  From the inside of our organization I can get a response that I can work with, but from the outside, there really is no response.  The response I get from the outside looks like:

220 **********************************************************0****0*2**********
********2******200**0*****2***0*00

As apposed to internally getting:

220 domain.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.211 ready a
t  Wed, 27 Apr 2005 08:45:07 -0600

I did recently add a reverse DNS for the outside IP and the first test I did failed.  I have tested again and was able to get a reply from the outside recipient.  I have since then replied to his reply to see if that will also get to him, but no response yet.  Does it take time for the reverse DNS to replicate?
0
 

Author Comment

by:c_ur_f8
ID: 13876719
As for the PIX configuration, see below:

Building configuration...
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 3QbW6VhGekYlnxRD encrypted
passwd (not shown) encrypted
hostname pix
domain-name domain.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit ip 10.0.1.0 255.255.255.0 10.0.3.0 255.255.255.0
access-list 100 permit ip 10.0.1.0 255.255.255.0 10.0.6.0 255.255.255.0
access-list 100 permit ip any 10.0.6.0 255.255.255.240
access-list inbound permit icmp any any
access-list inbound permit tcp any any eq www
access-list inbound permit tcp any any eq https
access-list inbound permit tcp any any eq ftp
access-list inbound permit tcp any any eq domain
access-list inbound permit udp any any eq domain
access-list inbound permit tcp any any eq smtp
access-list inbound permit tcp any any eq pop3
access-list inbound permit tcp any any eq 3389
access-list inbound permit tcp any any eq 3390
access-list inbound permit tcp any any eq 3392
access-list inbound permit tcp any any eq 6001
access-list inbound permit tcp any any eq 6002
access-list inbound permit tcp any any eq 6003
access-list inbound permit tcp any any eq 6004
access-list inbound permit udp any any eq 6001
access-list inbound permit udp any any eq 6002
access-list inbound permit udp any any eq 6003
access-list inbound permit udp any any eq 6004
access-list inbound permit tcp any any eq 593
access-list inbound permit tcp any any eq ftp-data
access-list outside_cryptomap_dyn_21 permit ip any 10.0.6.0 255.255.255.240
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 64.122.117.242 255.255.255.252
ip address inside 10.0.1.252 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool clientpool 10.0.6.1-10.0.6.10
pdm location 10.0.1.0 255.255.255.0 inside
pdm location 10.0.1.200 255.255.255.255 inside
pdm location 10.0.1.202 255.255.255.255 inside
pdm location 10.0.1.203 255.255.255.255 inside
pdm location 10.0.3.0 255.255.255.0 outside
pdm location 10.0.6.0 255.255.255.0 outside
pdm location 10.0.1.201 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 100
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface www 10.0.1.202 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 10.0.1.202 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ftp 10.0.1.202 ftp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface domain 10.0.1.202 domain netmask 255.255.255.255 0 0
static (inside,outside) udp interface domain 10.0.1.202 domain netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp 10.0.1.202 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pop3 10.0.1.202 pop3 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 10.0.1.202 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3390 10.0.1.200 3390 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3392 10.0.1.203 3392 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 6001 10.0.1.202 6001 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 6001 10.0.1.202 6001 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 6002 10.0.1.202 6002 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 6002 10.0.1.202 6002 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 6003 10.0.1.202 6003 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 6003 10.0.1.202 6003 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 6004 10.0.1.202 6004 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 6004 10.0.1.202 6004 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ftp-data 10.0.1.202 ftp-data netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 593 10.0.1.202 593 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5633 10.0.1.201 5633 netmask 255.255.255.255 0 0
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 64.122.117.241 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa-server domain protocol tacacs+
aaa-server domain (inside) host 10.0.1.201 timeout 10
http server enable
http 10.0.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community notsopublic
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-aes-256 esp-sha-hmac
crypto dynamic-map cisco 1 set transform-set myset
crypto dynamic-map cisco 21 match address outside_cryptomap_dyn_21
crypto dynamic-map cisco 21 set transform-set myset
crypto map dyn-map 20 ipsec-isakmp dynamic cisco
crypto map dyn-map client authentication crsengineers
crypto map dyn-map interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 1
isakmp policy 10 lifetime 1000
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption aes-256
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup unityclient address-pool clientpool
vpngroup unityclient dns-server 10.0.1.202 206.163.82.4
vpngroup unityclient wins-server 10.0.1.202
vpngroup unityclient default-domain domain.com
vpngroup unityclient idle-time 1800
vpngroup unityclient password ********
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 10.0.1.100-10.0.1.199 inside
dhcpd dns 10.0.1.202 10.0.1.201
dhcpd wins 10.0.1.202 10.0.1.201
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain domain.com
terminal width 80
Cryptochecksum:5c2ce4d6da0725d40113241587501ba5
: end
[OK]

0
 
LVL 2

Accepted Solution

by:
dazer1virginia earned 2000 total points
ID: 13879903
Your problem is most likely due to fixup protocol being turned on at the PIX:

>fixup protocol dns maximum-length 512

http://support.microsoft.com/?id=828263

Check your PIX IOS first.  You need to have at least 6.3(2).
To check this, logon to PIX and then type (show version)

To change fixup protocol issue:

Login to the PIX
Go to enable mode (en)
Go to terminal mode (conf t)
Type:  no fixup protocol dns
Type: write mem

You're done.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13880326
Exchange also has a problem with the smtp fixup. Try disabling it..

  no fixup protocol smtp 25
0
 
LVL 6

Expert Comment

by:magicomminc
ID: 13880713
>"I do get a correct IP when pinging and I have used that telnet function including the port number.  From the inside of our organization I can get a response that I can work with, but from the outside, there really is no response.  The response I get from the outside looks like:
220 **********************************************************0****0*2**********
********2******200**0*****2***0*00"

----this is due to PIX poor SMTP fixup implementation and it only allows few SMTP command through, breaks more than fix, it is useless. like lrmoore said, disable fixup smtp would allow you to get same reply when you telnet from outside. But I don't think this will fix the original problem.

>"I have a SBS2003 Server with Exchange 2003 running where all inhouse email and most outside email goes through without incident.  I am however running into an issue where the above error is coming back to us on, at this time, only one address."

---are you able to send email to other receptions in that domain?
0
 

Author Comment

by:c_ur_f8
ID: 13886968
I used both parts of the information from dazer1virginia and lrmoore and disabled fixup on both dns and smtp.  I have made the changes and I'm going to watch this for a couple days and let you know if this resolves my issue.  Thanks folks!
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13890127
On a side note, the "new" PIX 7.0(1) version fixes the smtp fixup to include the ESMTP commands that Exchange uses, and also provides better dns fixup.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13910425
I guess it's working now?
Was the issue just the DNS fixup, or was it both the DNS fixup and the SMTP fixup?
If both, then you could split the points...

Thanks!
0
 

Author Comment

by:c_ur_f8
ID: 13911845
From what I can tell, the DNS fixup did the trick.  I have been told that the error has not returned.  I did also disable the SMTP fixup and I should split the points, but I'm not sure how to at this time since I didn't do it initially.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13912055
Your choice. I can re-open the question and then you can split, or we can just leave it alone.
0
 

Author Comment

by:c_ur_f8
ID: 13919858
Lets just leave this one as is.  However, I have another question that nobody has touched.  Any thoughts to why?  I can re-open this one so points can be awarded.

Currently I have 3 2003 servers.  One is the SBS2003 which easilly allows you to configure monoitoring through the Server Management console.  However, the Standard and Enterprise editions are not so clearly marked.  I have been searching for a while on this site and Microsoft's site, but have been unsuccessful in locating the answer on how-to set up this service on my Standard and Enterprise servers.  Does Microsoft have a built-in program in these servers as they do in Windows 2003SBS or is this going to require a third party package?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 13920551
Your question is not at all clear to me (don't know anything about SBS), but you might try posting a new question in the Windows 2003 Topic Area..
0
 

Author Comment

by:c_ur_f8
ID: 13920730
Thanks
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
Tech spooks aren't just for those who are tech savvy, it also happens to those of us running a business. Check out the top tech spooks for business owners.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question