error loading the theme Default, fedora 4 test 2

Just installed Fedora 4 test 2 with Gnome as the only window manager. Everything was working great. I ran up2date -u, which updated all my rpm's including the gdm's. After a reboot I get the error message:

"There was an error loading the theme Default"
Can't open file /usr/share/gdm/themes/Default/Default.xml

Then it loads the default theme greeting (happygnome?) which doesn't work. So I ctrl + alt + F5 over to terminal and navigate to /usr/share/gdm/themes and low-and-behold, no Default directory. There is a Bluecurve directory with Bluecurve.xml which is what I would like to default to.

What config file do I need to get my hands on to make this happen?

TIA (Thanks In Advance)
LVL 2
whozieAsked:
Who is Participating?
 
wesly_chenCommented:
Can you get Gnome login screen?

If you just fail to login, then
I would say remove all the gnome setting in your home directory.
cd ~
rm -rf .gnome .gnome2 .gconfd .gnome-desktop .gconf .gnome2_private .nautilus .theme .icons .metacity

Then reboot your machine. Those directories/files will be regenerated.

If you can get Gnome login screen, then
rpm -q --filesbypkg `rpm -q gdm`
to see where is the gdm.conf (/etc/X11/gdm.conf ?) and edit it.
Also, you can do the trick
ln -s /usr/share/gdm/themes/Bluecurve  /usr/share/gdm/themes/Default
ln -s /usr/share/gdm/themes/Bluecurve/Bluecurve.xml  /usr/share/gdm/themes/Default/Bluecurve.xml
0
 
whozieAuthor Commented:
Thanks, I doubled checked the gdm.conf and saw in the greetings  sections that it was using Default theme for the greeting, but referring to Bluecurve.xml. I changed Default to Bluecurve and presto.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.