SQL Login

Hello...

Moving an asp.net project to a deployment server.  This project displays Crystal Reports.  The reports need to log into the SQL database housed on the development server.  Login was never a problem before becasue the asp.net and SQL were running on the same server.  Now they are not.  How do I add computer_account/aspnet to the SQL users group?

For example, it was easy to add oldComputer/aspnet to the users in SQL Enterprise Manager becasue oldComputer was on the same computer domain.  

Now I wish to add newComputer/aspnet to the instance of SQL running on oldComputer.  

I feel like I'm talking in circles.  Basically I want to add an aspnet user from another machine on to my SQL database users.

Please help.

Thanks,

T.
tssabatAsked:
Who is Participating?
 
BasharDoConnect With a Mentor Commented:
Hi T.

why don't you set the crystal report connection string just before calling it.

Report.SetDatabaseLogon(UserName, password, Server, Database)
0
 
laotzi2000Commented:
you can not do that because aspnet is a local account.

The simplest way is to use mixed mode authentication instead windows only authentication.
You can do this in enterprise manager(go to property of the sql server instance, in the security tab)
Then in your connection string, instead of set integrated security, you give a user name and password,
for example:
server=servername;database=Northwind;uid=sa;password=password
0
 
tssabatAuthor Commented:
The site required windows authentication due to the security of the information in the reports.  I can't use mixed mode.  Is there a way to do this through Windows Authentication?    I had thought do add the local ASPNET machine account to a domain group, but don't really know how to accomplish this...  Any suggestions?

T.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
laotzi2000Commented:
another way is to set the password of ASPNET account on both computers to be the same

This can be changed in machine.config, look for processModal,
change password from autogenarated to some other thing.
0
 
tssabatAuthor Commented:
That seems like a good answer.  Do you use mixed mode for that and provide, for example, the sa password for the Database?
0
 
tssabatAuthor Commented:
That option passes the pw in clear text over wire?
0
 
BasharDoCommented:
Hi T.

well about the password, I didn't check for that because i'm using a dummy account with certain permissions, such as, has access to certain stored procedures and views depending on the need.

for example,  i have a program that uses 6 or 7 dummy accounts each has its own permission to certain views, no other permission given to access any of the tables or the data.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.