DOS Boot with Network Support

Posted on 2005-04-26
Last Modified: 2011-10-03

I have recently managed to create a Ghost Boot disk which allows multiple network card choices when booting from a CD to use ghost.
The problem is, we have a number of Toshiba Tecra M3 Notebooks with Marvell Yukon NIC's in them. This presents a problem as the driver supplied by Toshiba and Marvell do not help a great deal.

The boot disk contents can be downloaded at:
You need to create a Windows 98 Boot Disk and then copy the contents of the zip onto the root of the floppy. You can then use the floppy as a boot disk for Nero to use to create a boot CD.

I get the following error messages (They appear in this order, but do have text between them):

PRO0003E: Protocol.ini file open failure

Protocol Manager not present

LTE0002E: Protocol Manager has not been loaded

Any ideas?

Question by:unitedmp
    LVL 4

    Accepted Solution

    I am assuming that  the other nics work when you use your boot disk.  Because although I have not tried making a boot disk from the file you provided everything looks very similar to the boot disk that I have for work.  Looking at the config.sys and and autoexec.bat everything looks correct.  The only thing that I can think of is that it does not like your drivers for that nic or one of those files are corrupt.
    The only thing that I would try would be to try different versions of nic drivers that you can find.  Not sure if you already tried that already.

    Well good luck
    LVL 1

    Author Comment

    Only 1 version of the driver exists.

    Toshiba tell me they successfully use it for production lines.

    I have downloaded the driver 2 times, and had it sent to me from Toshiba.

    I have replaced the netbind, protman and dis_pkt files aswell just to be sure and also the protocol.ini file.

    The error points towards a problem with opening the protocol.ini file. Not sure why tough. Am trying to find a USB floppy so I can do some tests and be sure of the problem.
    LVL 1

    Author Comment

    I figured it out.

    I don't know how or why this just jumped into my head and voila .. instant answer.

    This is the contents of the Config.sys file with the problem:

    MENUITEM=VEi8, HP Vectra VEi8
    MENUITEM=VL400, HP Vectra VL400
    MENUITEM=D510, HP/Compaq D51x Series
    MENUITEM=D530, HP D530 Series
    MENUITEM=DC7100, HP Evo DC7100 Series
    MENUITEM=TECRAM2, Toshiba Tecra M2 Notebook
    MENUITEM=TECRAM3, Toshiba Tecra M3 Notebook


    DEVICE=\3c90x\protman.dos /I:\3c90x

    DEVICE=\b57\protman.dos /I:\B57

    DEVICE=\E100B\protman.dos /I:\E100B

    DEVICE=\b57\protman.dos /I:\B57

    DEVICE=\E100B\protman.dos /I:\E100B

    DEVICE=\E1000\protman.dos /I:\E1000

    DEVICE=\yukon\protman.dos /I:\yuknd

    --- END OF FILE ---

    The problem is with this line:
    DEVICE=\yukon\protman.dos /I:\yuknd

    It appears"/I:\yuknd" should be pointing to the directory name not the driver name.

    Resolution to my problem, was changing this line to:
    DEVICE=\yukon\protman.dos /I:\yukon

    Amazing how something so small and simple can cause such an irritating problem.
    Hope this helps anyone else who may experience the same problem.

    LVL 4

    Expert Comment

    hey congrats on finding the answer to your problem.  I was looking at the file to see if something was off, but I didn't see anything wrong with it.  

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    Introduction How to create multiboot configuration with XP\Vista and Windows 7 on it? And most important question - how to do this correctly so not to have any kind of nightmares we get when system gets screwed? First of all one should realize t…
    Sometimes a user will call me frantically, explaining that something has gone wrong and they have tried everything (read - they have messed it up more and now need someone to clean up) and it still does no good, can I help them?!  Usually the standa…
    In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now