[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 13372
  • Last Modified:

FTP 550 Error - Port Related? Rights are fine.

I have a user in another companies network. They can log into my FTP server fine. They are getting an FTP 550 error when they try a put or a get. If I log in from the internal network with the user's ID and password I am able to make a put or get. I have tried the FTP Server from Win2000 and Solaris 8, and used both IE and command line as a client. Works from inside the network, but not outside.

Could this be a port issue? I have opened port 20 and 21 in the firewall between the two companies.

Could it be a PASV issue where the FTP server is trying to use a higher port not allowed through the firewall?

Any help would be great.

Thanks!
0
p1800volvo
Asked:
p1800volvo
1 Solution
 
rburns50Commented:
Is the remote user accessing  the FTP server through a firewall at their end (i.e. they are behind a firewall)? If so, they should use PASV mode. Normal mode FTP is weird in that the client connects to the server, but then the server drops that connection and initiates a connection back to the client. Seeing as most firewalls don't like connections initiated from outside, this tends to fail. Passive mode (PASV) keeps the session as a truly client to server conversation- firewall sees the connection go out, makes a note of it in its' state table (if it's a stateful inspection FW), and all is cool.

This may not be the solution to your problem, but PASV is always recommended when passing through a firewall.
0
 
p1800volvoAuthor Commented:
If I had to bet it is a PIX firewall.

I will try PASV. Hopefully that will work.

Thanks!
0
 
CCBeluxCommented:
Hi all,

I got exactly the same problem with FielZilla (FTP client).
I behind NAT and since port 21 was propely forwarded; I had the same firewall as before the NAT implementation so I thought the issue was related to NAT.

I was constantly getting the message:

Response:      550 Data connection must go to same host as control connection.
Error:      Disconnected from server
Error:      Could not retrieve directory listing
Error:      Timeout detected!

After reading this post, I've simply enabled the passive mode in FileZilla and ...

Response:      150 Data connection accepted from xx.xxx.xx.xxx:xxxx; transfer starting.
Response:      226 Listing completed.
Status:      Directory listing successful

:-)

thanks for the solution and I hopethis will help others as well...

have a nice day
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now