NTFS permissions

I have a W2K SP4 server.  I cannot give Creator Owner any NTFS permissions to any drive or folder on the server.  
That is, I cannot grant Creator Owner permissions at the root or to any folders only to files.  If I give Creator Owner permissions to any folder, when I hit Apply, all of the Allow boxes become unchecked.

If I go to Advanced and then try to add in Creator Owner there, I can only set permissions on Subfolder and Files
Only.  If I check anything else, the systems sets it back to Subfolder and Files only.  And even that does not appear
to work, because Creator Owner still has no permissions to any folders underneath that folder.

Trying to do this :

http://support.microsoft.com/?kbid=288991

Help

Michael
mchaney69Asked:
Who is Participating?
 
pazmanproConnect With a Mentor Commented:
This is by design. You set creator/owner rights on a folder so that users can add items to it, they don't mess with the folder itself (they are not the creator nor the owner). So the rights will be on subfoler and files only and will display as non being unchecked in security tab, but shows the actual rights in advanced.
0
 
veaceslavzCommented:
Are you on standalone server or under domain policy?
What indicate the Special Permision?
You can expect that doen't matter if Allow boxes are checked on Advanced tab you may have: Full Control for Creator Owner. Also as you know who is the creator check if he has the right permisions or if is aplicable corectly Inherited.
0
 
nader alkahtaniNetwork EngineerCommented:
This may be bug in SP4 , try to auto update OS ,
List of bugs in SP4
http://support.microsoft.com/?kbid=327194
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
pazmanproCommented:
As i said, this is by design. It is not a bug!
0
 
veaceslavzCommented:
It's as pazmanpro writed - by design. The same situation is on W2003 and XP
0
 
mchaney69Author Commented:
Thank You pazmanpro

Michael
0
 
pazmanproCommented:
Ur Welcome. Think nothing of it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.