PXE Boot With Ghost

Hi Guys,

I have just installed Symantec Ghost 8.2 Enterprise.
It came with 3COM PXE Boot Services.

I am trying to configure boot services for PXE, but it seems to be a challenge and a half.

I have created a PXE Image and added this to the default BOOTPTAB configuration, removed all hosts.
Please tell me I do not have to add each PC to the BOOTPTAB file by MAC Address. If I do, there must be some other way.

Thanks
Chris
LVL 1
unitedmpAsked:
Who is Participating?
 
Joseph NyaemaConnect With a Mentor IT ConsultantCommented:
0
 
amor_amolCommented:
By default the MAC filter in many PXE enabled services is disabled unless you manually turn them on. Were you able to boot through PXE without entering the MAC address of target machines??
0
 
unitedmpAuthor Commented:
Current Status:

Removed 3Com - Located Symantec Deployment Tools on Ghost CD.

Installed these on Windows XP Machine, managed to get my Custom CD Boot disk converted over and working through PXE just like I wanted, worked perfectly.

Then I uninstalled from the Windows XP Machine, and installed on the Ghost Server (Windows 20003 Server).
PXE does not work now from clients. Can see them connecting on the server as it is detecting the MAC address etc, but they are not being served by the PXE server.
I presume this issue is something to do with ports being blocked as it is a server OS. I guess the question now is, how do I allow the PXE server to serve the clients.

The server is not running DHCP, and does not need to be, as my XP machine is not and was working perfectly.

Any ideas?


Thanks
Chris
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
CmowCommented:
AFAIK a PXE server is essentially an extended DHCP server. Make sure that the DHCP Server service is not running on 2K3 (bearing in mind that not having configured DHCP is not necessarily the same as the service not running) as this may be occupying UDP/68 and preventing access to the PXE server.
0
 
Joseph NyaemaIT ConsultantCommented:
To be able to boot in an PXE environment you must have DHCP server to assign IP addresses
otherwise the PXE client has no way of assigning itself an IP address.

I won't pretend to be an expert with Ghost 8.2 enterprise..
But if it is not able to assign addresses to the PXE client
then you need to confifure a DHCP server on your network.
0
 
Joseph NyaemaIT ConsultantCommented:
0
 
unitedmpAuthor Commented:
There is a DHCP Server running on the network, however it is not on the same Server as Ghost. It is not recommended to run DHCP and Ghost on the same server, though it can be done.

The DHCP Service is not installed on the Ghost Server.

This worked perfectly from A Windows XP machine. Same config on a 2K3 box and it doesnt work.
I am thinking possibly port blocking in the new switch which was installed recently.

3COM Boot Services are a pain and dont work half the time.
0
 
CmowCommented:
Is there a router between the 2k3 box and the client? If so, because DHCP uses broadcast packets it may not be making it to the server and back. You may need to configure DHCP forwarding/relaying.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.