System bell not working under Mandrake 10.1

I have just upgraded from Mandrake 9.0 to Mandrake 10.1 and the system bell (the beep on the internal speaker)
has stopped working.

If I go to the Sound/System Bell menu in "Configure your desktop" (KDE control centre) I can select
"Use system bell instead of system notification" and set volume, pitch and duration, but the Test button
produces no result.

I have added the line "set bell-style audible" to /etc/inputrc

Operating System: Other (Mandrake 10.1)
Computer Make: Dell (Optiplex GX260)

LVL 3
martinAsked:
Who is Participating?
 
marxyCommented:
A bit of typpo.
Look at PC Speaker slide bar (not PCM).

And be sure you load pcspeaker module
try
modprobe pcspkr

And add it to /etc/modules.conf or /etc/modprobe.conf (depends of distro)
alias pcspk0 pcspkr
0
 
marxyCommented:
Run kmix or kmixctrl (this depends of what you use)
And slide up PCM bar 'cause it is on the minimum by default.
0
 
martinAuthor Commented:
marxy said:
> slide up PCM bar 'cause it is on the minimum by default.

I have already done this.

I should have mentioned that the rest of the sound system
is working normally, eg xmms can play sound files
and "Turn on all sounds" in System Notifications in
the KDE control centre produces lots of sounds.

It is the beep from the internal speaker which is not working.

0
 
martinAuthor Commented:

modprobe pcspkr

does the trick!
Now I know the magic word (pcspkr) I found a redhat bug report
on this issue:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123927
Looks like it will be fixed in the next version.

By the way, adding

alias pcspk0 pcspkr

to /etc/modprobe.conf didn't work, so I just added:

/sbin/modprobe pcspkr

to /etc/rc.d/rc.local
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.