• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 418
  • Last Modified:

Newbie cant figure out how to connect to internet

I am a newbie with linux, and then i mean NEWBIE, really newbie, just installed it..

I run Mandrake 10.1 on an old p3 500, 128 ram

I just got a network card, SMC-1255TX-PF and installed it. It seemed like it was installed correctly by linux.

i have 2 routers, 1 zyxel 650 prestige and 1 cnet cnig 914 (this router is just used as a switch, no input in the wan plug)


Now to the question; When i try to assign dhcp, it seems like linux automaticaly detects the cnet router, and lets that assign the adress.

I tried setting up static adresses, and then i manage to get into the other routers web configuration, but i cant connect to the internet. Please help me here, this works like a charm in windows, (no problems at all with the cnet router, it works like a switch, like it should do)

And remember, i am newbie to linux, i have been using it for a couple of hours max, so please be accurate when posting answers :)
0
leeds2k
Asked:
leeds2k
  • 4
  • 4
  • 3
  • +3
1 Solution
 
PsiCopCommented:
My guess is that when you defined the static address, you did not set a Default Gateway. Hence, your Linux install has no problem reaching things on the local subnet (like the router's web interface), but doesn't know where to send packets destined for other networks.

Unfortunately, I don't know Mandrake. You want to add a default route, but I'm not sure how to do it in that specific distro/version. You might see if there is a handy exmaple in the man pages for the route command, like so:

# man route

If the man page doesn't give an example, try checking into other man pages that deal with routing:

# man -k route
0
 
PsiCopCommented:
This looks like handy web page --> http://linux-ip.net/html/basic-control-files.html
0
 
PsiCopCommented:
And the command-line might be as simple as --> # route add default gw <ip of your gateway>
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
leeds2kAuthor Commented:
ive tried that add default gw, but it said my nethwork was unreachable, what does that mean?
0
 
wesly_chenCommented:
When you use dhcp, please write down the information of
dns server's IP address (cat /etc/resolv.conf)
default gateway's IP  (netstat -nr)

Then when you assign the static IP,
1. Edit /etc/resolv.conf to be the same as you see as DHCP client
2. Add default route as PsiCop's suggestion.
3. Edit /etc/nsswitch.conf
hosts:   files dns    # <=== make sure "dns"

Please post the output of
ifconfig -a
netstat -rn
ping "IP of your router"
nslookup www.yahoo.com

If you still unable to ping www.yahoo.com
0
 
rindiCommented:
Just so we can make comparisons, can you run a ipconfig /all on a windows px connected via dhcp to the cnet router and post those results here?
0
 
forgetmenotorelseCommented:
Are you trying to install a proxy server usind Mandrake?  If it so then you need to add 2 Lan Card in your proxy server.  One for your ISP and the other one is for your local network.  

Hope this would help you...

regards,

forgetmenotorelse
0
 
_iskywalker_Commented:
Try drakconf on console
it starts a gui, i  which you can select things that maybe helpful for installation, and administration of mandrake!
0
 
leeds2kAuthor Commented:
the gatway is 192.168.0.1  when it should be 192.168.1.1 (it gets ip from the cnet router when it should get from the zyxel) i cant seem to find out how to change default gateway, its quite annoying, i tried that command "route add default gw <ip of your gateway>" but it says, network unreachable, what should i do?

And no, i should not run it as a proxy, just yet, im on a learning basis of linux, and then i want to try it out first, getting over such troubles like this.
0
 
rindiCommented:
Turn off the dhcp server of the cnet and turn make sure that of the zyxel is on.
0
 
wesly_chenCommented:
> "route add default gw <ip of your gateway>" but it says, network unreachable,
This is network issue regarding to different subnet. It seems that you plug in to the wrong subnet network port.
Please provide the information I and rindi requested, otherwise people here don't have enough information
to help you.
The more details, the faster you get the solution.
0
 
leeds2kAuthor Commented:
well, i cant provide information when i dont understand a thing of what you are saying.

please be more accurate of what info you need, as i said, i am newbie with linux. This makes it hard for me to understand the pro words you linux users uses
0
 
rindiCommented:
I asked for you to run ipconfig /all on a Windows XP PC (open a command prompt to do that) connected to the cnet router (one with a dynamic ip address, not a static one). This will help us see what is different to the linux system and also understand what may be the problem (I think I know what it is, but I need something to proove it).

0
 
leeds2kAuthor Commented:
well, it was just to turn off the dhcp server on the cnet router, easiest is always the best :)
0
 
rindiCommented:
thanx
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 4
  • 4
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now