Text marked with "Do not check spelling and grammar" was skipped

After running the spell checker (Windows 2002) on a file I received from someone else, the following warning was issued:

Text marked with "Do not check spelling and grammar" was skipped

How do I identify the text that is skipped and how do I make it so that the text is checked.
LVL 3
rfr1tzAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Xanadu_1Commented:
You don't.  I've run into this very recently and the only way I knew how to get rid of it is to clean up the document.  Resetting the spell checker does not work.  It was something they pasted into the document that created that.  

The fix (I know of) for now:

Copy the text except the last paragraph mark > go to a blank document > special paste > unformatted text > reformate the document.

This will clean up any corruptions that may be in the document including the cause for the spell check skip.  
TonyJollansCommented:
There may be good reason why some text is set this way but if not, use Find and Replace.

Ctrl+h for Replace Dialog
If More button is visible, click on it

select Find What textbox.
Erase contents
If No Formatting button is not greyed out, click on it
Click on Format, select Language
Check "Do not check spelling or grammar" checkbox
Click OK

select Replace With textbox.
Erase contents
If No Formatting button is not greyed out, click on it
Click on Format, select Language
UNCheck "Do not check spelling or grammar" checkbox (this is a triple-state checkbox so make sure it is properly unchecked)
Click OK

Click on Replace All

Your text should now all be checked but you will have to force a recheck if you've already been through the document (Tools > Options > Spelling and Grammar > Recheck Document) and will have to (re)check whatever you've checked before (unless you've corrected it)

TonyJollansCommented:
Xanadu,

It's not corruption! It's a style setting.

By copying as unformatted text you are removing the style and hence the setting.
rfr1tzAuthor Commented:

I've got Office 2002. Tony's instructions may have been for another version. But his hint helped me find out the answer.

First, go to tools->options->spelling and grammar, hit recheck document. This insures everything is rechecked.

Here's the trick! tools->language->set language. See that "do not check spelling or grammar" box? It's aiming at whatever is highlighted. So you can select some text not to be checked.

I've included text for checking, then excluded it. Everything worked -FOR THE STUFF I CHANGED! But even if I do "select all" and then set language->check spelling and grammer, my original problem remains. I think there is a problem with Word.
TonyJollansCommented:
You seem almost sorted but to clarify -

Tools > Options > Spelling and Grammar > Recheck Document
Select All
Tools > Language > Set Language
Uncheck "Do not check Spelling and Grammar"
F7 (or equivalent) and process the errors
You still get the warning.

I can't duplicate this (2003) but there are far too many permutations for me test everything.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Word

From novice to tech pro — start learning today.