Really Annoying Drive Mapping Disconnection Problem

Hi folks,

I have a client with a Win2K Server environment, and mixed Win2K & Win98 workstations.

All users have a drive mapping to a directory on the server where files are shared.

One of the users, and it figures it would have to be the president of the company, is annoyingly getting his drive mapping disconnected after between 10 and 15 minutes of inactivity.  I knew about setting autodisconnect to -1 on the server, and checking whatever other parameters I thought were pertinent, to no avail.  He is the only Win2K user to have this problem.  As a test, I took my laptop in, set it on Win2K, joined the domain, and mapped the drive.  Everything works fine with no disconnection.

I've tried setting up a new computer account on the server (AD), changing the computer to a workgroup, changing its name and rejoining it to the domain, and it didn't do anything.  I went to regedit on the machine, and compared HKLM->System->CurrentControlSet->services->lanmanserver->parameters with the settings on my laptop, and removed anything that was different, and still nothing changed.

I'm getting to the point where I think it might be better to reinstall the O/S, but I want to find out if there's anything I might be missing.

One other thought I had is that possibly the network card is buggy, so swapping it out and testing also might be an option.

Does anyone have any ideas?

Thanks.

Charlie T.
LVL 3
charlietouAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
LazarusConnect With a Mentor Commented:
Consider checking the LAN Card properties on that machine and make sure that it does not have power management running. Some NICS power down loosing connections that way.
0
 
LazarusCommented:
Try this on the Machine:

START | CONTROL PANEL | ADMIN TOOLS | LOCAL SECURITY POLICY| LOCAL POLICIES | SECURITY OPTIONS
look down the list for "Microsoft Network server: amount of idle time required before suspending session - default = 15 minutes".

Right click and Properties.

Set this to a large number of minutes.
99,999

next...
on the same list... find:
"Microsoft Network Server: Disconnect clients when logo hours expire". Right click and Properties.

Set at "disabled"
0
 
charlietouAuthor Commented:
Thank you, thank you, thank you!

My frustrations are over.

It was the power management on the LAN card.

:-D
:-D

Thanks again.
0
All Courses

From novice to tech pro — start learning today.