• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 222
  • Last Modified:

CSS oddity

Hi all.

my CSS which i'm linking to


a:link {
      font-weight: bold;
      text-decoration: none;
      color: #CCCCCC;
      }
a:visited {
      font-weight: bold;
      text-decoration: none;
      color: #FFAF11;
      }
a:hover, a:active {
      text-decoration: underline;
      color: #FFAF11;
}

problem is, whenever I preview the page (F12) or if i open the html page, the link takes on the visited color, even when refreshing and reloading.

what's up with that?

thanks
blu.
0
blue-genie
Asked:
blue-genie
  • 8
  • 5
  • 4
  • +2
3 Solutions
 
grogmanCommented:
I know this may sound INCREDIBLY obvious, but have you cleared your browser's cache? This same type of problem drove me nuts for hours one day until I remembered to clear the cache.
0
 
blue-genieAuthor Commented:
yup, first thing i did.
0
 
grogmanCommented:
Hmmm. Interesting. I created a new css file and added only the css code you listed above. I then linked that css file to a new html page in Dreamweaver and tested it, and it seems to be working fine here (I previewed with F12, opened it in IE, and also in Firefox). Did you have different code for your A tags in your css file before this? I've run into something similar before, where I edited my css, but the changes either wouldn't show up at all, or only part of the changes would appear. It almost seemed like there was some type of cache on the server that took a while to clear, because after a few hours my changes just "magically" appeared.
You don't have more than one css file, do you? Whether you do or not, double-check your code to make sure you haven't duplicated any properties for your A tag that might be confusing the browser.

Wish I could be of more help here.

Doug
0
Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

 
MHenryCommented:
You might try clearing your cache and history, then closing the browser. Reopen and view. That sometimes works for me.
0
 
blue-genieAuthor Commented:
i have cleared everything possible.
0
 
MHenryCommented:
Try removing this:  a:active

I think what you're seeing is the active part of the link. If the link is active, you will see that color which is the same as your visited link. Remove the coma after hover too.

0
 
blue-genieAuthor Commented:
nope, that didn't do anything.
0
 
MHenryCommented:
Well, this works anyway:

a:link {font-weight: bold; text-decoration: none; color: #CCCCCC;}

a:visited {font-weight: bold; text-decoration: none; color: #FFAF11;}

a:hover, a:active {text-decoration: underline; color: #FFAF11;}

0
 
MHenryCommented:
And this works too. I guess you just needed another enter in between the lines. Let me know if this didn't work for you.

a:link {
     font-weight: bold;
     text-decoration: none;
     color: #CCCCCC;
     }
      
a:visited {
     font-weight: bold;
     text-decoration: none;
     color: #FFAF11;
     }
      
a:hover, a:active {
     text-decoration: underline;
     color: #FFAF11;
}
0
 
blue-genieAuthor Commented:
hi, its not that i'm not interested, just none of the suggested solutions above did the trick.....

0
 
VenabiliCommented:
And we are not mindreaderds.

When a solution does not work for you, you must tell this to the experts.:)
0
 
blue-genieAuthor Commented:
i humbly apologise. It slipped my mind.
please please please forgive me.
0
 
VenabiliCommented:
No problem:) Just keep this in mind next time.
0
 
blue-genieAuthor Commented:
if i could keep it in mind I wouldn't forget :-)

but i get ur pt.
can we close the question and get a refund?
0
 
VenabiliCommented:
Let's see what the experts will say.
But you can always ask Community Support to do this.
Just post a question here: http://www.experts-exchange.com/Community_Support/ and do not forget to post the link to this question :)

0
 
MHenryCommented:
Did you try putting another return after the close bracket? It worked for me.
0
 
prifreCommented:
Hi,

Now, this is probably even more obvious... but:
You use IE on Windows as browser? or some other browser?
You should set "Internet Options->General->Settings->Every visit to the page" so it does not use cache when testing.

Other tips: try with other browsers!
(Opera, Netscape, Firefox, etc)

finally: I dont think there is anything wrong with your css. But might it be so that you use multiple CSS files / definitions?
(In file and in external CSS file(s)...:-)
It happened to me once - and it took ages until I found out...

good luck hunting - with a smile
/prifre
0
 
VenabiliCommented:
blue-genie,
Any chance to answer to the experts?
0
 
blue-genieAuthor Commented:
in terms of prifre comments, it's not a catching issue.
on firefox, same thing, thats the only other browser i have access to.

i checked the multiple definitions. nothing.
its' never happened again, i'm going to close this post - and write off the problem as just one of those phantom things.

thanks all.
blu.
0
 
blue-genieAuthor Commented:
btw, since i was once flamed for closing a question where there was no solution, i shall split the points, sorry if i miss anyone out.

blu
:-)
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 8
  • 5
  • 4
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now