[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

FTP stops working

Posted on 2005-04-28
8
Medium Priority
?
475 Views
Last Modified: 2013-11-29
I have a Belkin 54G router. My computer have WINXP pro installed.

One day, FTP stoped working, I thought that it was because I installed WIN XP SP2. I did extended research on google, and I found that the firewall have some problems, even when it is disabled, I enabled it, opened the ports, disabled firewall and nothing. I tried LSP fix, winsock fix, and nothing. Note that I used many ftp clients: Bullet proof, windows command based client, internet explorer, ws ftp, etc. And same results for all.

Painfully I had to format my computer and decided never to install SP2 again.

Now the problem is back, and I did not installed SP2.

The problem is that the FTP protocol (client) stops working. Sometimes it works for some minutes and then it stops transfering. I could not isolate the problem, and I'm not newbie.

All the other internet protocols works good (WEB, msn, etc.)

this time I'm sure that I dont have spyware, because I have not opened not trustable sites. So, I think that it could be one of 2 things:

1. My ISP is blocking FTP trafic
2. My router gets tired of transfering in the FTP port(less likable)

I  cant come with more ideas about this. Please if anyone have an idea, let me know.

Thank you
0
Comment
Question by:emiliodabdoub
8 Comments
 
LVL 1

Author Comment

by:emiliodabdoub
ID: 13883998
Other strange thing is that I can connect to the site, but when it tries to get the files list, it cant.
0
 
LVL 9

Expert Comment

by:kfullarton
ID: 13884526
Are you transferring any large files?  How big?
0
 
LVL 6

Expert Comment

by:al-hasan
ID: 13884671
emiliodabdoub: interesting problem you have, and I do not have the solution either. However some thoughts, which might help others to find a solution:

"1. My ISP is blocking FTP trafic" - in this case _no_ ftp traffic would be possible at all. You say, you can do partial downloads.

"2. My router gets tired of transfering in the FTP port(less likable)" - any ftp tranfer uses additional (random) ports. This could lead closer to isolate the problem. I just did some test download of a linux kernel. So my computer sent the ftp request from the local port 2676 to the remote (ftp)port 21. You can verify this using the command 'netstat -an'. When I start the download, the remote port 40462 sends the data to the local port 2679. These ports (but not the 21, of course) change with each download, and your system must be able to handle this.

Some other idea: you did not mention the bandwidth of your internet connection. However if you can download at a rather high speed and your upload is very limited - as is often the case with ADSL - and you upload some mails while the ftp is running, there may be not enough bandwidth for the TCP control packets. In combination with some unfortunate time-out settings, this could choke your download to the point where it breaks down. Just an idea, would like to see comments of others about it.

Hope this helps to help you!
Regards,
has.
0
Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

 
LVL 6

Expert Comment

by:JimsZ
ID: 13885029
Is it possible that the site you are downloading off of is shutting you down?  Have you tried to ftp from somewhere else or just the same ftp site?   What kind of error are you getting when it stops, is it telling you the connection was broken, timed out, etc ?
0
 
LVL 1

Author Comment

by:emiliodabdoub
ID: 13887329
True, it may be also the server that its not working properly, I'm always in the same server. When the problem happens again I will try with another server and let you know
0
 
LVL 8

Accepted Solution

by:
kain21 earned 1000 total points
ID: 13888569
you may also have a problem with your MTU settings... try the steps in the following article..

http://www2.dslreports.com/faq/5975

I would recommend performing these steps as soon as you notice a problem...
0
 
LVL 1

Author Comment

by:emiliodabdoub
ID: 13916429
right, it was the MTU setting, many thanks..
0
 
LVL 8

Expert Comment

by:kain21
ID: 13916973
no problem... glad it's working
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
How to fix a SonicWall Gateway Anti-Virus firewall blocking automatic updates to apps like Windows, Adobe, Symantec, etc.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question