• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 712
  • Last Modified:

Cisco PIX to Router VPN Issues - URGENT

I am currently having problems connecting a CIsco PIX 515 to CIsco Router. I am getting the following error message on the Router

IPSEC(key_engine): major = 1
IPSEC(key_engine): expired_timer

When I ping from a client on the internal interface of the pix to a client on the internal interface of the router the tunnel is established but the ping times out. If I try the reverse from the router to pix nothing happens. Any ideas Im at my wits end.


*******PIX CONFIG*********************************************************
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz security50
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname blkheadpix
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list ipsec permit ip 10.0.1.0 255.255.255.0 10.0.10.0 255.255.255.0
access-list nonat permit ip 10.0.1.0 255.255.255.0 10.0.10.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip address outside 192.168.1.2 255.255.255.0
ip address inside 10.0.1.1 255.255.255.0
ip address dmz 172.16.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 192.168.1.4-192.168.1.11 netmask 255.255.255.0
nat (inside) 0 access-list nonat
nat (inside) 1 10.0.1.0 255.255.255.0 0 0
route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set SITEVPN esp-des esp-md5-hmac
crypto ipsec security-association lifetime seconds 3600
crypto map vpnmap 20 ipsec-isakmp
crypto map vpnmap 20 match address ipsec
crypto map vpnmap 20 set peer 172.30.1.2
crypto map vpnmap 20 set transform-set SITEVPN
crypto map vpnmap interface outside
isakmp enable outside
isakmp key password address 172.30.1.2 netmask 255.255.255.255
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn username cisco password ********* store-local
terminal width 80
**********END PIX CONFIG*********************************************

*****ROUTER CONFIG**************************************************
crypto isakmp policy 20
 hash md5
 authentication pre-share
crypto isakmp key password address 192.168.1.2
!
crypto ipsec transform-set SITEVPN esp-des esp-md5-hmac
!
crypto map vpnmap 10 ipsec-isakmp
 set peer 192.168.1.2
 set transform-set SITEVPN
 match address 120
!
interface FastEthernet0/0
 description internal interface
 ip address 10.0.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description external interface
 ip address 172.30.1.2 255.255.255.0
 duplex auto
 speed auto
 crypto map vpnmap
!
!
interface Ethernet1/0
 description dmz interface
 ip address 172.16.10.1 255.255.255.0
 half-duplex
!
router eigrp 1
 network 10.0.10.0 0.0.0.255
 network 172.30.1.0 0.0.0.255
 network 201.201.201.192 0.0.0.15
 distribute-list AdvertiseNAT out FastEthernet0/1
 no auto-summary
!
ip access-list standard AdvertiseNAT
 deny   10.0.10.0 0.0.0.255
 deny   172.16.10.0 0.0.0.255
 permit any
!
!
access-list 120 permit ip 10.0.10.0 0.0.0.255 10.0.1.0 0.0.0.255
*****END ROUTER CONFIG**************************************************
0
steven_alilovic
Asked:
steven_alilovic
  • 5
  • 4
1 Solution
 
christsisCommented:
Almost sounds like the issue may be a routing problem on the router instead of a tunnel issue.

Does a sh ip route give anything helpful along those lines?

Chris
0
 
steven_alilovicAuthor Commented:
I can ping the outside interfaces from the opposite device.
0
 
christsisCommented:
Right, but that doesn't mean the router has the info on how to get to 10.0.1.0. That's what I'm going to guess is missing from the table.
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
christsisCommented:
A quick test by adding a static route of:
ip route 10.0.1.0 255.255.255.0 192.168.1.2

that will easily give an answer if that's the problem.
0
 
steven_alilovicAuthor Commented:
I thought that is what the

crypto map vpnmap 10 ipsec-isakmp
 set peer 192.168.1.2
 set transform-set SITEVPN
 match address 120


access-list 120 permit ip 10.0.10.0 0.0.0.255 10.0.1.0 0.0.0.255

was for.
0
 
christsisCommented:
That's just an ACL that includes the those addresses in the encryption. Does nothing to add them to the routing table.
0
 
steven_alilovicAuthor Commented:
I wont be able to test the ip route statement for about 8 hours, because I am currently at work.


I followed this article outlined by Cisco
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094498.shtml

I doesnt mention the ip route statement but I will try it tonight. Thanks.
0
 
steven_alilovicAuthor Commented:
Looks like that was it - your a legend - sometimes it just takes someone to step back for you.

thanks again.
0
 
christsisCommented:
np, Cisco takes things for granted when they write up their stuff in a lab environment. Doesn't always reflect reality.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now