• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1983
  • Last Modified:

Control Acrobat Reader via GPO

Is it possible to control the setting in Acorbat Reader 6.0 via a GPO???

I need to deactivate "Display PDF in Browser"

/Jesper
0
HK-DK
Asked:
HK-DK
  • 4
  • 3
2 Solutions
 
wingateslCommented:
Make a .reg file that contains

[HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\Acrobat Reader\6.0\AdobeViewer]
"BrowserIntegration"=dword:00000000

then create a logon script that includes

regedit /s regfile.reg

put that logon script into the GPO

Shawn
0
 
Debsyl99Commented:
Hi
You could try a custom administrative template as the settings for controlling acrobat reader aren't available via group policy by default. To create a custom template, copy and paste the following into a blank notepad document.

CLASS MACHINE

  CATEGORY "Adobe Acrobat Reader 6.0"

  POLICY "Disable Browser Integration"
    KEYNAME "Software\Adobe\Acrobat Reader\6.0\AdobeViewer"
    EXPLAIN "Setting this policy disables Browser integration"
      VALUENAME "BrowserIntegration"
      VALUEON NUMERIC 1
      VALUEOFF NUMERIC 0
  END POLICY

  END CATEGORY

Save the file as say, adobe.adm - note you need the adm file extension. Copy the adm file into the relevant folder for policy templates usually the inf folder in %systemroot% ie C:\winnt\inf.

Next open your policy editor, expand the tree for the relevant gpo - right-click the folder "administrative templates" in computer configuration and select add/remove templates. Add the new adm file that you just created. In order to see the policy within the policy editor you'll need to do the following:

1.Highlight the Administrative Templates node for which you want to see preferences.
2.On the View menu, click Filtering, and then clear the "Only show policy settings that can be fully managed" check box.

You should now be able to view the policy you just created and turn the browser integration setting on or off,

Hope that helps,

Deb :))
 
0
 
HK-DKAuthor Commented:
Hi wingatesl

That wont work - the regfile dosent make the change wanted - Maybe its another plave in the Regisrty.

/Jesper
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
HK-DKAuthor Commented:
Hi  Debsyl99

When I add the adm - file where should it be placed??? I mean where in the GPO can i se this policy - i Cant find it under either User / Computer settings.

/Jesper
0
 
Debsyl99Commented:
Hi
Am assuming that you've added the template as I described - this should enable you to see an additional policy called "adobe" in the folder tree as expanded under administrative templates.  This should enable you to see an additional policy called "adobe" in the folder tree as expanded under administrative templates. If you then select adobe it appears blank - in that case you need to follow the steps as below in order to view the policy itself.
1.Highlight the Administrative Templates node for which you want to see preferences. (ie under computer configuration)
2.On the View menu, click Filtering, and then clear the "Only show policy settings that can be fully managed" check box.

Let me know if this solves it,

Deb :))
0
 
HK-DKAuthor Commented:
Hi Deb

Okay now i found it, but it dosen't make any difference :-(

But our problem is expanding.

Here a short disription of what we are dealing with.

We have launched a new intranet - based om Microsoft SharePoint server.

But we have a problem - when users try to display PDF documents on the portal - Acrobat opens just fine, but then it fails stating an error - " file dosent start with '%PDF-', " !?!?!

The supplyer has said that the problem i coming because we have danish letters "æøå" in the folders or in the filename - then we where told that removing the "Display PDF in Browser" would solve the problem.

Then we where faced with a new problem, our users dosen't have administrative control over there machines - so then cannot disable the "Display PDF in Browser" because its a setting that affects all users.

This caused this question. - but now it seems like this wont help either, we had one succes on a machine where we disabled the "Display PDF in Browser" this worked acrobat reader showed the PDF files in a separate window. But on my testmachine it only had the affect that before it tried to open Acrobat reader an then displayed an error, now it just displays the little picture with the red/blue/green as when the picture wasn't found on the server.

Can anybody help?!?!?

/Jesper
0
 
HK-DKAuthor Commented:
Hi there

I closing this question now - cant spend any more time to many problems with trying to control acrobat reader 6 - and no real syatem in what works on all machines, something works on one machine it wont work on another but something else works here.

Thanx for the replys - i have definatly learned someting.

I have deciedep to split points

So i will give you 250 each.
0
 
Debsyl99Commented:
Hi
Sorry you have had problems with this - as you know it appears to be a known bug with Acrobat/Sharepoint. Just a suggestion - does upgrading to Acrobat Reader 7 help?

Best wishes and good luck,
Deb :))
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now