?
Solved

Dont have write access to save a ini file

Posted on 2005-04-28
10
Medium Priority
?
363 Views
Last Modified: 2010-04-20
i have mandrake linux 10.1, and ive just installed americas army and want to run a dedicated server..

here is my problem; when i try to make a INI file called server.ini and tries to save it, i get this error message: the document could not be saved as it was not possible to write to file:/home/servers/aa/armyops/system/server.ini

Check out that you have write access to this file or that you have enough disk space

Well, i have enough disk space...


I am using kwrite and/or Kate editors, maybe another editor will work? or is it some setting i must do here?

I am a newbie with linux, so please help me!! 500 points to the first!
0
Comment
Question by:leeds2k
  • 6
  • 3
10 Comments
 

Author Comment

by:leeds2k
ID: 13891301
may it be becouse when i installed it, i was log on as root? and if so, how can i fix it?
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 13891486
Check the ownership of the file - if it is not owned by your user ID (and if you were root when you installed it, it may not be), then chown it to your user ID. You'll have to use su or sudo or whatever to do this.
0
 

Author Comment

by:leeds2k
ID: 13891694
well, im trying to use sudo command, but i dont understand which command i need to use to set ownership to my user... sudo -u username was 1, but it seemed like it didnt work
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:leeds2k
ID: 13891748
seemed like the correct answer was "chmod -R a=awx (directory)"


0
 
LVL 1

Accepted Solution

by:
apsivam earned 2000 total points
ID: 13892148
nope you are making the file is writable to everyone its a bad thing on a public server. try the following command

chown -R yourname:yourgroup <the_destination_dir>

--
Cheers,
Sivam
www.emmeskay.com

0
 

Author Comment

by:leeds2k
ID: 13892534
and what should i use if i dont have a group??
0
 
LVL 1

Expert Comment

by:apsivam
ID: 13892713
you must have a group in linux no problem if you ignore :group part of the command

--Cheers,
Sivam
www.emmeskay.com
0
 

Author Comment

by:leeds2k
ID: 13892963
and this works for all underdirectorys too?
0
 

Author Comment

by:leeds2k
ID: 13892990
btw, i have already used the command "chmod", do i need to reset this back also? or is it enough to change owner to me?
0
 
LVL 1

Expert Comment

by:apsivam
ID: 13892998
yup that what it -R option is for try it yourself it wont hurt you unless its production server

--
Cheers,
Sivam
www.emmeskay.com
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month14 days, 6 hours left to enroll

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question