[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 262
  • Last Modified:

buffer overflow hp all-in-one d135

EE,


peer-to-peer network
HP d135 printer off of the print sharing port of the wireless router
Windows XP computers send huge files (lots of graphics) to printer
Printer locks up (only has 16mb)
cannot add more memory to printer

I'm looking for a software setting that can be changed --
Can I slow down the spooled jobs so that the printer does not lock up by changing the printer properties? EMF vs RAW? Print after last page is spooled ?

I'm brainstorming here --
The best solution that I can think of is connecting the printer directly to the fastest computer running Windows XP and changing the page file, if necessary.
Second best solution is a printer that allows for additional memory.

Feedback on the solutions proposed would be appreciated.

Thanks,
crubio









0
crubio
Asked:
crubio
  • 2
  • 2
1 Solution
 
newuser4Commented:
It looks like a problem in the wireless router since internal memory size doesn't affect behaviour of ink-jet printer. Maybe the network has too much traffic or the bandwidth is too narrow but it could be also an incompatibility between the router and hp driver.

Current hp drivers rasterize data before sending it, therefore commands are executed as they arrive to the printer and no memory is used. Since your printer is an all in one system you have a wide internal memory (used for stand alone copy function) but on a common ink-jet printer you wouldn't find more than 64 kbyte.

I suggest you to remove the printer from the shared port and install it on a pc, sharing the printer across the network.

Spooling cannot be slowed down since it is the operative system that gives it the available resources. In the same way the choice between Raw or Emf format concerns pc performance, Raw occupates more hard disk space but reduces cpu occupation while the job is being spooled, Emf takes less space on the disk but requires more cpu work while generating print job (data must be processed two times).
"Start printing when the last page has been spooled" forces the pc to wait until the print job has been created on the hard disk before sending it to the printer.
0
 
wyliecoyoteukCommented:
Try changing print driver spool  settings to "start printing after the last page is spooled" that may help.
Spooling an entire job locally will reduce network transmission times, and reduce timeouts.
If that fails,  your only solution may be to buy a new printer.

0
 
crubioAuthor Commented:
It did not occur to me that the bottleneck could be the wireless network. It's a 802.11b (22Mbps) wireless network. Usually there is minimal network usage (e-mail, Internet) when the huge graphics files are sent to the printer.

I'll change the print driver spool settings to "start printing after the last page is spooled" to see if that helps.
0
 
wyliecoyoteukCommented:
newuser4, I apologise for repeating your comment about spool settings, did not notice it for some reason.
0
 
crubioAuthor Commented:
Thank you, all.
crubio
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now