Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 880
  • Last Modified:

FTP using WINDOWS FTP

Hi

heres the situation

I need to FTP files from Laptop to Switch, this is the only way I can do this so dont reccomend anything different.

THe laptop hasnt got any FTP software and that cannot change, what it has got is the FTP software built in form the OS, (Windows XP Proffesional SP2)

using the CMD I can get to FTP> by typing FTP, what I dont know what to do is how to transfer the files over using this software. is there a GUI version of FTP available on XP Pro??

help!
0
bluebirds1984
Asked:
bluebirds1984
1 Solution
 
nodiscoCommented:
What kind of switch do you mean?

If you can get into the device using ftp from the cmd line and login successfully you can ftp files to and from as follows:

ftp <device>
login - username and password

lcd c:\windows             changes local directory to c:\windows
cd /tmp                        changes directory on ftp device to /tmp
get filename                 ftps filename from /tmp to c:\windows
mget *                        ftps all files in /tmp to c:\windows
put filename                ftps filename from c:\windows to /tmp
mput *                       ftps all files in c:\windows to /tmp
close                          Ends connection
bye                            Closes ftp session

0
 
WallsyCommented:
FTP isn't too complicated too use... Here are the basics -
      OPEN your.switch.address
will connect to your switch. You can also type FTP your.switch.address at the command prompt.
You should be prompted for a user name and password. Once you're in,
      CD directory
will change directory, just like in DOS.
      TYPE BIN
changes the file transfer from ASCII to binary.
      PUT file.name
will upload a file
      MPUT file*.*
will upload all of the files starting with file
      GET file.name
will download a file.
These files are uploaded and downloaded from whatever directory you were in when you started FTP. You can use
      LCD dir
to change the local directory.

Finally,
      BYE
closes the connection, and
      QUIT
exits FTP.

While you're in FTP you can type
      ?
for a list of commands, you can then type
      ? COMMAND
for a (very brief) description.

Otherwise, you can download plenty of free or shareware product, like FileZilla or WS-FTP.

But for your needs, I think the built-in FTP should be fine.

HTH,

Wallsy
0
 
bluebirds1984Author Commented:
ive acidently erased the software on the Switch during an upgrade, so the only software on there is the miniboot menu.

Ive had a play and configured the switch and i can ping the laptop using a crossover cable from the EMP port on the switch to the laptops ethernet port. the switch's manual states that i need to use a corssover cable. i tried it with a normal cable and the local area conection showed now conection, wheras the corssover cable showed the LAN conected.

but for some reason i cannot ping the Switch from the Laptop. the switch can ping itself.

any ideas?

regarding the FTP heres what ive typed

FTP (enter)

10.2.2.3 (enter)   (the Ip of the swtich)

then i get 'Invalid Command'

what am i doing wrong? im sure it will have something to do with the fact i cant ping the switch.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
bluebirds1984Author Commented:
also one of the options on the Switch miniboot config was the "Host IP Address" which was set to 192.168.10.1. should i change this??

I can now ping the switch, gave the Laptop the gateway address of the Switch.
now all i need is the FTP help!
0
 
nodiscoCommented:
If you have erased the switches config then you will have to set a management ip address for it as well as a local subnet mask.  You won't be able to ftp to it without the new ip address

What type of switch is it? Dell/cisco/HP
0
 
nodiscoCommented:
Your second post got in ahead of me!

Most switches use tftp not ftp to move a config file - i.e.
You setup a tftp server on your pc and connect to the switch.  Then "pull" the config from the tftp server

Are you trying to move a config file?
0
 
bluebirds1984Author Commented:
Its an Alcatel 7800 and I attempted and upgrade on one of the CMM cards.i rebooted without installing the new files, oops. not sumthin you want to do with a £20000 switch.

what is a "management ip address"? anything to do with the "Host IP Address" ??
0
 
bluebirds1984Author Commented:
the 7800 has Labs training maual and im following that to try and FTP the files over to it.

heres what I'm following. doesnt mention TFTP?

Miniboot - FTP
Files can also be transferred using FTP within Miniboot. However, in order to do this the
Ethernet Management Port must be stated. First we will issue the command to start the
EMP, then we'll modify the IP address.
·  Enter the command ‘sysStartNetwork’, this enables the EMP port from
Miniboot
·  Enter 'sysNetlnfoShow' to get network statistics and IP information.
·  Scroll up to find the hostname falconcmm, take note of its IP address and
modify your PC if necessary.
·  Or, you can use the command ‘sysModifyBootParameters’ to change the IP
address of the EMP.
·  Ensure you have IP connectivity to the EMP (use a cross cable ).
·  FTP from your PC to the switch and log in.
At this point you're able to FTP files onto the switch from MiniBoot.
·  Type ‘reboot’ from the Miniboot prompt.
·  Break the boot process and set the flag parameter back to 0.
·  Reboot the switch to the fill operating system.
0
 
bluebirds1984Author Commented:
I'm trying to move all the Config files! the switch tries to boot from the Certified directory but there arent any files in there so it doesnt boot up.my only option is to ftp the files over using the miniboot menu.

i just tried this..

cmd

ftp 10.2.2.3 (enter)

and after a short wait i got this

ftp: connect :Unkown error Number
0
 
bluebirds1984Author Commented:
great news! just got it to FTP login.
i remembered that The CMM card has to be in Module A when upgrading the software, and it was in Module B! it must be the same for when you do it through miniboot.

now I'm gona try the file transfer. :s
0
 
nodiscoCommented:
Good stuff - I'm learning about Alcatel switches too!
good luck
0
 
bluebirds1984Author Commented:
ive gota go for half an hour

ive managed to FTP the files over, but as I'm in the Miniboot menu, i cannot use the command Install *.img to install the files like i would normally.

can you find anything to install the files?  

the manual says

Type ‘reboot’ from the Miniboot prompt.
·  Break the boot process and set the flag parameter back to 0.
·  Reboot the switch to the fill operating system.

can you find out how this is done please? :D
0
 
nodiscoCommented:
I have looked about on Alcatel support but cannot find anything specific.  This sounds like the same process you use with cisco devices - You got to the miniboot stage and cannot run certain commands.  You need to issue a break sequence as the device is booting up - usually hit Ctrl+Break, delete or just Break while the device starts to boot.

When you do this, it will bring you do a prompt wher you then need to "set the flag parameter back to 0"
I am presuming this means to set the switch to boot from a standard configuration - e.g. 0

Please bear in mind this is educated guesswork on my part - I will post further if I find more
0
 
nodiscoCommented:
PS - after issuing the break sequence and getting to a prompt - you may be able to run ? or help to find what commands are available.  This way you may be able to figure out how to issue the command to set the flag parameter to 0
0
 
bluebirds1984Author Commented:
i have no idea whats wrong now, the files have been transfered, they are in the directories when i reboot the switch, but hte switch fails to load them.
i get the message "cannot find component (alcatelNetworking_kernel.lnk) in package (/flash/certified/fos.img)
it says the same about kernel.lnk.
then "unable to boot from certified software release. "

Fos.img is there which is the thing thats annoying. the files are there!!!

why couldnt this be a Cisco switch then every1 would know exactly what to do! or why can't more people use alcatel! argh!
0
 
nodiscoCommented:
One thing you could try:

A Thought - The ftp may need to be binary :

If you ftp files to a device without issuing the binary statement, the files may not be readable.  You may well transfer the file but it will not read properly, even though its filename is correct and its size is correct.  I have encountered this on unix systems.

Try this;

ftp <device ip>

login with password
binary              just enter the word binary and hit enter - it should say "Type set to I"

Ftp the files as you did before and reboot accordingly.

good luck
0
 
bluebirds1984Author Commented:
it worked!! you're a genious!

i didn wonder why the first transfers took very little time to trasnfer, wheras when i normaly transfer them it takes a while.
i used the binary command and it took around the same time as it should to trasnfer the files. it booted up and worked, now im syncrhonising the working CMM card with the one i just did the FTP with so all the other config files are the same!

Thank you for your help! i didnt want to explain to my boss that we'd have to send the CMM card back!

if i could give you more points i would!

0
 
nodiscoCommented:
Most welcome - glad you got sorted!
0
 
newtonpg2Commented:
There is a program call WS-FTP PRO that allows for easy FTP of multiple files at one time to and from the switch.

0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now