Cannot connect or even ping UNIX server from only 1 client laptop.

Very Bizarre. We have just done an upgrade to our ERP system. All systems that upgraded (about 60 client PC's)  were upgraded fine with the exception of 1 laptop. The laptop in question could ping our old servers, UNIX (where old ERP system was) and Windows included, but cannot ping the new server. I've reformatted the laptop two times. First it was formatted with W2000 Pro, chipset and drivers installed, and still couldn't ping our new UNIX server, but it could still ping all others. I decided then to format with XP Pro, loaded the chipset and NIC driver only in order to connect to the network. Same thing happened where it could ping everything except 192.168.1.21. I was able to ping the laptop from the server in question, but the laptop could not reach the server. I have tried ipconfig /release and /renew, netstat -a (although I'm not entirely sure what to look for), critical updates for windows etc. When attempting to do a tracert on a working PC there is only 1 hop and it completes; on the laptop in question it times out every time. Is there something in the BIOS that may have been changed or altered.  
schumbe1Asked:
Who is Participating?
 
bstrauss3Commented:
The reason the device keeps being given the same address is that either the client or server have caches of prior assignments and so tend to request/give out the same address.  Especially if the DHCP server belives the client has a valid (unreleased) lease.

What's broken is that somebody machine is configured staticly with that address.  When you try to ping, the packets get routed to the other device, which doesn't expect them and so throws them away.  Meanwhile the pinger doesn't see it's replies.

It's not supposed to happen, but I have seen it.  As part of the DHCP address assignment process, the server and client are supposed to check if it is in use and NOT assign an in-use address.

But network topology doesn't always allow that to work, because it's done via broadcast packets.  Switches, being smart, 'know' who is where and will not forward packets out ports which it shouldn't belong.  If the topology is just right (wrong?), you can have two devices with the same address and the DHCP server won't know about it, so it won't detect the problem.  

The usual answer is to figure out which device has a static address in the DHCP pool and fix the device.  But that's a nasty, difficult process.

-----Burton
0
 
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
Can this very Laptop still ping the other systems (PCs, servers, routers, etc)?
What O/S (UNIX brand) is your server running?
0
 
ahoffmannCommented:
use tracert on laptop and post result
at same time use tcpdump on server and post result, like:
  tcpdump -l -n host IP-of-laptop
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
bstrauss3Commented:
Is this a static or dynamic address?  It sounds to me like you have a duplicate ip address.

On the server, when you ping the laptop, check (arp -a) the MAC address that is responding.  On the laptop, check what the actual address of the card is.

Try assigning the laptop a different address.

------Burton
0
 
schumbe1Author Commented:
Thank you all for posting responses. It turns out that we had to release the IP address and remove it from the leases.  When we gave it a static IP address it worked fine. I changed it back to obtain an IP address dynamically and it picked up the old address. Sure enough the ping nor the tracert would work to the UNIX server, so we realized that it must be the IP address. I did an ipconfig /release, removed the IP address off of the server so that it could not be used, then did an ipconfig /renew, it picked up a different IP address and it works fine. I guess that mystery has been solved, but what could cause a single IP address to do that? Anyway thank you all.
 -Debbie
0
 
ahoffmannCommented:
> .. but what could cause a single IP address to do that?
either caching problem on the client (as described above)
or a malicious hub/switch (try to reset them)
0
 
bstrauss3Commented:
"Never attribute to malice what can be explained by stupidity."

It's most likely that somebody, when prompted to specify an address prior to DHCP being installed, picked one - oh, nobody will ever use 232...


-----Burton
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.