[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2067
  • Last Modified:

Port not open in Fedora 3

Hello,
I have Fedora 3 installed and I have configured sendmail and dovecot for mail server and pop3 imapd purposes .Now when I try to use outlook express and specify the ip address of the mail server , it says cannot connect , but when I try to setup the mozilla mail client in linux on the server with localhost as the servers it works (but still does not work with ip address).

I tried to check if the ports are open using nmap and this is th command I used

nmap -sT 65.103.191.30
Starting nmap 3.70 ( http://www.insecure.org/nmap/ ) at 2005-04-29 10:16 MST
Interesting ports on 65.103.191.30:
(The 1658 ports scanned but not shown below are in state: closed)
PORT   STATE SERVICE
23/tcp open  telnet
80/tcp open  http

Nmap run completed -- 1 IP address (1 host up) scanned in 0.998 seconds

and on localhost

nmap -sT localhost

Starting nmap 3.70 ( http://www.insecure.org/nmap/ ) at 2005-04-29 10:16 MST
Interesting ports on localhost.localdomain (127.0.0.1):
(The 1647 ports scanned but not shown below are in state: closed)
PORT      STATE SERVICE
21/tcp    open  ftp
22/tcp    open  ssh
25/tcp    open  smtp
80/tcp    open  http
110/tcp   open  pop3
111/tcp   open  rpcbind
113/tcp   open  auth
143/tcp   open  imap
443/tcp   open  https
631/tcp   open  ipp
3306/tcp  open  mysql
5900/tcp  open  vnc
10000/tcp open  snet-sensor-mgmt

Nmap run completed -- 1 IP address (1 host up) scanned in 0.246 seconds

I also tried port forwarding on my dsl modem (actiontec provided by qwest) , but the same problem.Is there a way to get around this?
0
janu_s
Asked:
janu_s
1 Solution
 
apsivamCommented:
Firewall!!! whats your firewall rule it might block other ports on your network ip

--
Cheers,
Sivam
www.emmeskay.com
0
 
harbor235Commented:
Make sure you have an account and password established in the outlook config and also make sure the linux
box has the same accounts and passwords.

harbor235
0
 
janu_sAuthor Commented:
I am able to receive messages  from all sorts of email address and can send only to @domain.com from @domain.com , not from @domain.com to @hotmail.com . Do I need to ceate smtp.domain.com like mail.domain.com ?to send messages , while sending to emails other than domain.com , it gives the following error message  (while using outlook express )

The message could not be sent because one of the recipients was
rejected by the server. The rejected e-mail address was
'xyz@gmail.com'. Subject 'test', Account: 'mail.domain.com',
Server: 'XX.XXX.XXX.XX', Protocol: SMTP, Server Response: '550 5.7.1
<xyz@gmail.com>... Relaying denied', Port: 25, Secure(SSL): No,
Server Error: 550, Error Number: 0x800CCC79

But when I try to use pine which I installed on my server , I can send and recieve messages from to any address.Then why this problem with pop?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
janu_sAuthor Commented:
This is my firewall  , iptables file

# Firewall configuration written by system-config-securitylevel
# Manual customization of this file is not recommended.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:RH-Firewall-1-INPUT - [0:0]
-A INPUT -j RH-Firewall-1-INPUT
-A FORWARD -j RH-Firewall-1-INPUT
-A RH-Firewall-1-INPUT -i lo -j ACCEPT
-A RH-Firewall-1-INPUT -p icmp --icmp-type any -j ACCEPT
-A RH-Firewall-1-INPUT -p 50 -j ACCEPT
-A RH-Firewall-1-INPUT -p 51 -j ACCEPT
-A RH-Firewall-1-INPUT -p udp --dport 5353 -d 224.0.0.251 -j ACCEPT
-A RH-Firewall-1-INPUT -p udp -m udp --dport 631 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 443 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 21 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 23 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 25 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 110 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 143 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 5901 -j ACCEPT
-A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited
COMMIT
0
 
steveb3210Commented:
hello,

3 things need to be happening...

The ISP needs to not be blocking anything.
The Router doing NAT needs to be forwarding the ports.
The server needs to have its firewall configured correctly.

The firewall rules above does seem to be correct so I don't think that is the cause.  If anyting, I'm putting money on the router not doing NAT correctly or the ISP is blocking ports...This is frequent with port 25 tese days as a spam blocking method.

Have you tried momentarily turning off IPTables?  How about setting the computer as te DMZ?

If you turn off iptables, set the computer as DMZ and ten run

nc -l -p <anyport>

You should then be able to go to any other computer and type "telent <ip> <port>" and see it connect (just establish a generic TCP connection)

nc is netcat by the way in case its not installed on your system.

Best Regards,
Stephen
0
 
l0stCommented:
Hello,
Your problem seams to be the same as this one:
http://www.experts-exchange.com/Networking/Linux_Networking/Q_21443275.html
but instead try trusting www , mail and in the other ports section add 143 (imap)
0
 
linux2000inCommented:
Cheers,

This is not problem of firewall.. just enter in /etc/mail/access file

your netwokr ip  relay keyword and
rebuild access.db and restart sendmail your problem will sloved...nothing to do with firewall...
I assumed your 192.168.1.0/24 ip network ( where u configured outlook )
================ACCESS========================
192.168.1.0/24     RELAY

============================================
2nd step give command like this.

#makemap hash /etc/mail/access.db < /etc/mail/access

============================================

Restart sendmail server u r mail will go to gmai...huuuuuuuh...
# service sendmail restart


Happy mailing..

Regards,

linux2000in@yahoo.com
Vipul Ramani
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now