Port not open in Fedora 3

Posted on 2005-04-29
Last Modified: 2007-12-19
I have Fedora 3 installed and I have configured sendmail and dovecot for mail server and pop3 imapd purposes .Now when I try to use outlook express and specify the ip address of the mail server , it says cannot connect , but when I try to setup the mozilla mail client in linux on the server with localhost as the servers it works (but still does not work with ip address).

I tried to check if the ports are open using nmap and this is th command I used

nmap -sT
Starting nmap 3.70 ( ) at 2005-04-29 10:16 MST
Interesting ports on
(The 1658 ports scanned but not shown below are in state: closed)
23/tcp open  telnet
80/tcp open  http

Nmap run completed -- 1 IP address (1 host up) scanned in 0.998 seconds

and on localhost

nmap -sT localhost

Starting nmap 3.70 ( ) at 2005-04-29 10:16 MST
Interesting ports on localhost.localdomain (
(The 1647 ports scanned but not shown below are in state: closed)
21/tcp    open  ftp
22/tcp    open  ssh
25/tcp    open  smtp
80/tcp    open  http
110/tcp   open  pop3
111/tcp   open  rpcbind
113/tcp   open  auth
143/tcp   open  imap
443/tcp   open  https
631/tcp   open  ipp
3306/tcp  open  mysql
5900/tcp  open  vnc
10000/tcp open  snet-sensor-mgmt

Nmap run completed -- 1 IP address (1 host up) scanned in 0.246 seconds

I also tried port forwarding on my dsl modem (actiontec provided by qwest) , but the same problem.Is there a way to get around this?
Question by:janu_s
    LVL 1

    Expert Comment

    Firewall!!! whats your firewall rule it might block other ports on your network ip

    LVL 32

    Expert Comment

    Make sure you have an account and password established in the outlook config and also make sure the linux
    box has the same accounts and passwords.


    Author Comment

    I am able to receive messages  from all sorts of email address and can send only to from , not from to . Do I need to ceate like ?to send messages , while sending to emails other than , it gives the following error message  (while using outlook express )

    The message could not be sent because one of the recipients was
    rejected by the server. The rejected e-mail address was
    ''. Subject 'test', Account: '',
    Server: 'XX.XXX.XXX.XX', Protocol: SMTP, Server Response: '550 5.7.1
    <>... Relaying denied', Port: 25, Secure(SSL): No,
    Server Error: 550, Error Number: 0x800CCC79

    But when I try to use pine which I installed on my server , I can send and recieve messages from to any address.Then why this problem with pop?

    Author Comment

    This is my firewall  , iptables file

    # Firewall configuration written by system-config-securitylevel
    # Manual customization of this file is not recommended.
    :INPUT ACCEPT [0:0]
    :OUTPUT ACCEPT [0:0]
    :RH-Firewall-1-INPUT - [0:0]
    -A INPUT -j RH-Firewall-1-INPUT
    -A FORWARD -j RH-Firewall-1-INPUT
    -A RH-Firewall-1-INPUT -i lo -j ACCEPT
    -A RH-Firewall-1-INPUT -p icmp --icmp-type any -j ACCEPT
    -A RH-Firewall-1-INPUT -p 50 -j ACCEPT
    -A RH-Firewall-1-INPUT -p 51 -j ACCEPT
    -A RH-Firewall-1-INPUT -p udp --dport 5353 -d -j ACCEPT
    -A RH-Firewall-1-INPUT -p udp -m udp --dport 631 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 443 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 21 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 23 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 25 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 110 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 143 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 5901 -j ACCEPT
    -A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited
    LVL 1

    Expert Comment


    3 things need to be happening...

    The ISP needs to not be blocking anything.
    The Router doing NAT needs to be forwarding the ports.
    The server needs to have its firewall configured correctly.

    The firewall rules above does seem to be correct so I don't think that is the cause.  If anyting, I'm putting money on the router not doing NAT correctly or the ISP is blocking ports...This is frequent with port 25 tese days as a spam blocking method.

    Have you tried momentarily turning off IPTables?  How about setting the computer as te DMZ?

    If you turn off iptables, set the computer as DMZ and ten run

    nc -l -p <anyport>

    You should then be able to go to any other computer and type "telent <ip> <port>" and see it connect (just establish a generic TCP connection)

    nc is netcat by the way in case its not installed on your system.

    Best Regards,

    Expert Comment

    Your problem seams to be the same as this one:
    but instead try trusting www , mail and in the other ports section add 143 (imap)
    LVL 2

    Accepted Solution


    This is not problem of firewall.. just enter in /etc/mail/access file

    your netwokr ip  relay keyword and
    rebuild access.db and restart sendmail your problem will sloved...nothing to do with firewall...
    I assumed your ip network ( where u configured outlook )
    ================ACCESS========================     RELAY

    2nd step give command like this.

    #makemap hash /etc/mail/access.db < /etc/mail/access


    Restart sendmail server u r mail will go to gmai...huuuuuuuh...
    # service sendmail restart

    Happy mailing..

    Vipul Ramani

    Featured Post

    Why You Should Analyze Threat Actor TTPs

    After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

    Join & Write a Comment

    ​Being a Managed Services Provider (MSP) has presented you  with challenges in the past— and by meeting those challenges you’ve reaped the rewards of success.  In 2014, challenges and rewards remain; but as the Internet and business environment evol…
    BIND is the most widely used Name Server. A Name Server is the one that translates a site name to it's IP address. There is a new bug in BIND (, affecting all versions of BIND 9 from BIND 9.1.0 (inclusive) thro…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now