toogle viewer window

Hello guys I created a report with out any groups and when i am passing this url in my browser

http://pc-oreddy/Reports/allevents.rpt?user0=crystal&password0=crystal&promptex-Node="xsi/queue/jmon"&promptex-Manager="All"&promptex-Date=["datetime(2005,04,10,12,00,00)"-"datetime(2005,04,28,12,00,00)"]

My report is running perfectly, but with the toogle group tree on the left side. i dont want this toggle group tree, since i am not grouping in my report . can some one tell me how to remove this toggle window from my browser.


Thankyou,
Reddy.
varunogiliAsked:
Who is Participating?
 
frodomanConnect With a Mentor Commented:
Sorry Reddy, I don't have any other suggestions for you along the lines you're going.  As you may know, what you're doing (unmanaged url reporting) is deprecated in CE9 & 10 so you may be hitting on an unsupported feature / glitch. (Deprecation reference: http://support.businessobjects.com/library/kbase/articles/c2016644.asp ).

If you aren't clear on the differences between managed and unmanaged reporting then this technical brief is a good place to start: http://support.businessobjects.com/communityCS/TechnicalPapers/ce8_managed_unmanaged_rpts.pdf.asp

I suspect that by switching to managed reporting you'll be able to solve this problem.  You'll still have the group tree appearing (your original problem), but the export to PDF will probably work as expected and can be used as a workaround.

HTH

frodoman
0
 
mlmccCommented:
Which version of Crystal.

Is it the "group tree" you are seeing or what?

There is a REPORT OPTION to build or not build the group tree
Open the report
Click FILE --> REPORT OPTIONS
Uncheck BUILD GROUP TREE

mlmcc
0
 
varunogiliAuthor Commented:
i am using crystal reports10 , i did uncheck the create group tree . But still i am getting the  toggle (group tree) in my browser. Is there any option to change the report settings to open in ActiveX. Will this work.

Thankyou,
Reddy.
                                                                                                                                 
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
frodomanCommented:
Reddy,

I know exactly what you're talking about and as you have discovered, even setting the report options correctly doesn't help...

You can force the report to open in the ActiveX viewer by adding this to your URL  "&INIT=actx"  

HTH

frodoman
0
 
varunogiliAuthor Commented:
Hi frodo i treid activex url placing in 2places. first now shows an error

1. http://pc-oreddy/Reports/allevents.rpt?"&init=actx"&user0=crystal&password0=crystal&promptex-Node="www.xpedite.com"&promptex-Manager="All"&promptex-Date=["datetime(2005,04,10,12,00,00)"-"datetime(2005,04,28,12,00,00)"]

2.http://pc-oreddy/Reports/allevents.rpt?&user0=crystal&password0=crystal&promptex-Node="www.xpedite.com"&promptex-Manager="All"&promptex-Date=["datetime(2005,04,10,12,00,00)"-"datetime(2005,04,28,12,00,00)"]"&INIT=actx"

error: A viewer of type 'actx"' is not supported. Please contact your system administrator to enquire about supported viewers. [On Web Component Server: pc-oreddy.WCS]

So i tried to put a ? in it

http://pc-oreddy/Reports/allevents.rpt?"?init=actx"&user0=crystal&password0=crystal&promptex-Node="www.xpedite.com"&promptex-Manager="All"&promptex-Date=["datetime(2005,04,10,12,00,00)"-"datetime(2005,04,28,12,00,00)"]

If i am using this the group tree is displaying again. Any suggestions

Thankyou,
Reddy.
0
 
varunogiliAuthor Commented:
Activex content have been turnes off by the administrators so is there any other way.

Thankyou,
Reddy.
0
 
frodomanCommented:
Sorry Reddy - I don't believe there's another way.  

One possibility you could consider is to export the report to (for example) PDF.  That way it would open in the browser in Acrobat Reader and you wouldn't have the group tree there.  Of course you also lose the ability to refresh, etc. so it's a far-from-perfect solution.

If you go that route add to your URL:  cmd=export&export_fmt=U2FPDF:0

frodoman
0
 
varunogiliAuthor Commented:
ok thank you.
0
 
vidruCommented:
There should be a displayGroupTree property for the viewer that you can set.  Something like:

<PARAM NAME="DisplayGroupTree" VALUE=1>

or

CRViewer.DisplayGroupTree = False

-dave
0
 
frodomanCommented:
Dave - I don't think that works with unmanaged reports??? - frodoman
0
 
vidruCommented:
Frodoman: I don't serve up rpts throught the web/via intranet, so I'm not exactly sure how this deployment scenario
works, but I DO know that just about every one of the Smart Viewers has some method for turning the group tree
on/off.

-dave
0
 
frodomanCommented:
Dave: Thanks for the reply.  I know that typically this isn't a problem but as far as I know this doesn't apply when you've got Crystal Enterprise in the mix.  You can turn off all trees but I've never been able to find such a method that works through URL commands or even through the CE Management Console to turn off just a single instance. - frodoman
0
 
varunogiliAuthor Commented:
Hello frodoman i tried to do as you said, i tried to pass the export pdf in the url in this way, but it is showing me an error

http://pc-oreddy/Reports/HOURLYgraph.rpt?"&?init=actx"&user0=crystal&password0=crystal&promptex-Node="xsi/queue/jmon"&promptex-hour=8&cmd=export&export_fmt=U2FPDF:0


error: Adobe Reader could not open 'pa001801.fdf' because it is either not a supported filr type or because the file has been corrupted(for example, it was sent as an email attachment and wasn't correctly decoded).

Any suggestions.

Thank you,
Reddy.
0
 
frodomanCommented:
Reddy,

Looks like acrobat is trying to open a .fdf file instead of a .pdf file.  I found an article back from CE8.5 that sounds like it might address this: http://support.businessobjects.com/library/kbase/articles/c2015161.asp

Basically I'm thinking to add the filename to your URL:
....&cmd=export&export_fmt=u2fpdf:0&/filename.pdf

This is an educated guess - I'm not sure about this one.

frodoman
0
 
varunogiliAuthor Commented:
Sorry frodoman it is still showing me the same error

Thankyou,
reddy.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.