• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 726
  • Last Modified:

Cisco 2620 no ip traffic

Site A has a Cisco 2620 with 2 Serial Interfaces, and 2 Ethernet Interfaces-the config is as follows:

Current configuration : 3185 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime
no service password-encryption
!
hostname Kindrum_2620
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable password cisco
!
no network-clock-participate slot 1
no network-clock-participate wic 0
voice-card 1
!
no aaa new-model
ip subnet-zero
ip cef

no ip domain lookup
ip host Rinmore 10.3.4.1
ip host Kindrum 10.3.4.2
no ftp-server write-enable
isdn switch-type primary-qsig

controller E1 1/0
framing NO-CRC4
pri-group timeslots 1-12,16

class-map match-all voice
match access-group 100


policy-map LLQ
class voice
priority 105

interface Loopback0
 ip address 192.168.1.1 255.255.255.255
 h323-gateway voip bind srcaddr 192.168.1.1

interface Multilink1
 bandwidth 128
 ip address 10.3.4.2 255.255.255.0
 ip accounting output-packets
 ip tcp header-compression iphc-format
 load-interval 30
 ppp multilink
 ppp multilink fragment delay 10
 ppp multilink interleave
 ppp multilink group 1
 max-reserved-bandwidth 100
 service-policy output LLQ
 ip rtp header-compression iphc-format

interface FastEthernet0/0
 no ip address
 load-interval 30
 speed auto
 full-duplex

interface FastEthernet0/0.1
 description *** LAN ***
 encapsulation dot1Q 1 native
 ip address 10.3.2.100 255.255.255.0
 no snmp trap link-status

interface FastEthernet0/0.100
 description *** 54Mbps Wireless Network ***
 bandwidth 54000
 encapsulation dot1Q 100
 ip address 10.3.5.1 255.255.255.0
 no snmp trap link-status

interface Serial0/0
 description *** 128K Link To Site B ***
 bandwidth 128
 no ip address
 encapsulation ppp
 no ip mroute-cache
 load-interval 30
 no fair-queue
 ppp multilink
 ppp multilink group 1

interface Serial0/1
 description *** 128K Link To Site C ***
 bandwidth 128
 ip address 10.3.7.1 255.255.255.0

interface Serial1/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 isdn bchan-number-order ascending
 no cdp enable

router eigrp 10
 redistribute static
 network 10.0.0.0
 auto-summary

ip classless
ip route 0.0.0.0 0.0.0.0 10.3.2.1
ip route 192.168.1.2 255.255.255.255 10.3.4.1
ip http server

logging trap debugging
logging 10.3.2.10
access-list 1 permit 10.3.2.2
access-list 1 permit 10.3.2.6
access-list 100 permit udp any any range 16384 32768
access-list 100 permit tcp any eq 1720 any
access-list 100 permit tcp any any eq 1720

snmp-server community cisco RW 1

voice-port 1/0:15
 output attenuation 3




dial-peer cor custom



dial-peer voice 10 pots
 destination-pattern 2..
 direct-inward-dial
 port 1/0:15
 forward-digits all

dial-peer voice 20 voip
 max-conn 3
 incoming called-number 2..
 destination-pattern 3..
 session target ipv4:10.3.4.1
 ip qos dscp cs5 media
 no vad

dial-peer voice 11 pots
 destination-pattern 9.T
 direct-inward-dial
 port 1/0:15
 forward-digits all

dial-peer voice 21 voip
 max-conn 4
 incoming called-number 9
 ip qos dscp cs5 media
 no vad


line con 0
line aux 0
 password cisco
 stopbits 1
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login




the main site is A...this is connected to B via a 54mbits wireless newtork for data and also via a 128k leased line as backup for data but as the primary route for voice.  everything was fine until this evening when i wanted to enable the connection on Serial0/1 which is now connected to Site C via a 128k hdlc connection.  i was not involved in configuring the router originally.  i have the new connection operational-in that i can ping between the serial interfaces-however i cannot ping between a remote workstation and the server in SiteA.  also it now seems that pinging from SiteB to the same server in SiteA is intermittent....

what is wrong with my configuration...i have simply set the router at SiteC up withe the ip address 10.3.7.2 on the serial interface and ive done nothing else...

troy


0
donegalman
Asked:
donegalman
  • 23
  • 11
  • 11
  • +1
3 Solutions
 
BILJAXCommented:
under the Serial0/0 you have this.

no ip address
 encapsulation ppp


You need to make sure you have encapsulation ppp setup on site b and c.




also here.

ip route 192.168.1.2 255.255.255.255 10.3.4.1

should more than likely be:  ip route 192.168.1.2 0.0.0.255 10.3.4.1



AC
0
 
donegalmanAuthor Commented:
ok

lets see your first point about the encapsulation:

site b is connected via a bit circuit over 5 miles...site c is 70 miles away and is a hdlc circuit??  so i have under serial0/1 encapsulation hdlc...and as you saw under serial0/0 encapsulation ppp.

i dont understand the use of multilink in the config above.   is this because i have 2 links to site B-wireless and leased line? all i want to do is add another site on a hdlc connection.  

in site C when i ping the serial interface on the opposite side from within the router-it replies-but if i ping the ethernet interface it doesn't.   ie

serial interface SiteC 10.3.7.2 ping SiteA 10.3.7.1 and it replies
if i ping from 10.3.7.2 to 10.3.2.100 i get nothing???

the 192.168.1.2 255.255.255.255 was there before i started and it all worked fine...all ive done is add entries to serial0/1 as can be seen above and now i cannot ping any computers across the WAN....strange
0
 
BILJAXCommented:
access-list 100 permit tcp any eq 1720 any <<<<<   REMOVE THIS LINE.
access-list 100 permit tcp any any eq 1720  -- only permits port 1720??  why is this?



What I'm saying about the encapsulation is that they have to match on both ends of the circuit.   Make sure you timing for the HDLC is the same on both ends as well.   Mulilink (trunking) allows you to take a physical connection and divide it up into multiple virtual connections (it's spread out over the interweb-thing).

You need to make sure that "router eigrp 10"  is consistent throughout.



AC

0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
donegalmanAuthor Commented:
right we're getting somewhere

i checked that eigrp and there was differences between it and SiteC..i have replicated SiteA to SiteC and now i can ping from SiteC to the serial interface in SiteA...which i couldn't do before...i can ping all the Internal interfaces now on the router in SiteA..but none of the external...

from SiteA i can ping both the internal and external interfaces of SiteC but not a PC on the network


any more suggestions???
0
 
christsisCommented:
Is your EIGRP setup on Site C or do you have a proper static route there so it knows 10.3.7.1 is the proper destination for 10.3.2.0/24?
0
 
christsisCommented:
Okay, nm I stared at that too long while making my response.

What's the Ethernet subnet on Site C? Is it in the 10.0.0.0 so it's being added to the EIGRP?
0
 
BILJAXCommented:
the PC on the network at Site C needs to know that it's on the same network as the internal interface.
0
 
donegalmanAuthor Commented:
this is the config of SiteC


Current configuration : 809 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Altan
!
enable password 7 060506324F41
!
ip subnet-zero
!
!
no ip domain-lookup
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 10.3.6.1 255.255.255.0
 half-duplex
!
interface Serial0/0
 description Connection to SiteA
 bandwidth 128
 ip address 10.3.7.2 255.255.255.0
!
router eigrp 10
 redistribute static
 network 10.0.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
!
ip classless
no ip http server
ip pim bidir-enable
!
snmp-server community public RO
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
 password 7 094F471A1A0A
 login
line aux 0
line vty 0 4
 password 7 094F471A1A0A
 login
!
end
0
 
donegalmanAuthor Commented:
the PC at siteC is 10.3.6.2/255.255.255.0  and the Ethernet Interface is 10.3.6.1/255.255.255.0
0
 
christsisCommented:
Get rid of the rip.
0
 
donegalmanAuthor Commented:
i find that i can ping the EthernetInterface at SiteA with the ip address 10.3.5.1 from SiteC...but i cannot ping the EtherInterface 10.3.2.100 from SiteC...surely this is strange??  i can ping out to PC's on the 10.3.5.x range but nothing on the 10.3.2.x range
0
 
BILJAXCommented:
wow, this is fun :)


with RIP out of the way, it should be working now.



AC
0
 
christsisCommented:
Hopefully you're making a typo, cause in your config site C has Ethernet interface as 10.3.6.1 not 10.3.5.1... or maybe that's the whole problem :)
0
 
christsisCommented:
Or maybe I just misunderstood what you stated, I guess reading it a few times it could be taken multiple ways.

How about posting a show ip route from site A & C?
0
 
donegalmanAuthor Commented:
right this is siteA setup

Router 2620

EthernetInterface to main LAN 10.3.2.100
EthernetInterface to 54Mbits Wireless Network to SiteC 10.3.5.1
Serial Interface to SiteB for Voice 10.3.4.1
Serial Interface to SiteC 10.3.7.1

Ranges used externally in SiteA is 10.3.2.x
                                  in SiteB is 10.3.3.x
                                  in SiteC is 10.3.6.x

now the show ip route of SiteA is as follows:

Gateway of last resort is 10.3.2.1 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D       10.3.3.0/24 [90/284160] via 10.3.5.2, 00:00:31, FastEthernet0/0.100
C       10.3.2.0/24 is directly connected, FastEthernet0/0.1
C       10.3.5.0/24 is directly connected, FastEthernet0/0.100
C       10.3.4.1/32 is directly connected, Multilink1
C       10.3.4.0/24 is directly connected, Multilink1
C       10.3.7.0/24 is directly connected, Serial0/1
D       10.3.6.0/24 [90/20537600] via 10.3.7.2, 00:00:31, Serial0/1
     192.168.1.0/32 is subnetted, 2 subnets
C       192.168.1.1 is directly connected, Loopback0
S       192.168.1.2 [1/0] via 10.3.4.1
S*   0.0.0.0/0 [1/0] via 10.3.2.1


and SiteC is as follows:


Gateway of last resort is 10.3.7.1 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D       10.3.3.0/24 [90/20540160] via 10.3.7.1, 00:00:42, Serial0/0
D       10.3.2.0/24 [90/20514560] via 10.3.7.1, 00:06:48, Serial0/0
D       10.3.5.0/24 [90/20514560] via 10.3.7.1, 00:06:48, Serial0/0
D EX    10.3.4.1/32 [170/23072000] via 10.3.7.1, 00:06:48, Serial0/0
D       10.3.4.0/24 [90/23072000] via 10.3.7.1, 00:06:48, Serial0/0
C       10.3.7.0/24 is directly connected, Serial0/0
C       10.3.6.0/24 is directly connected, Ethernet0/0
     192.168.1.0/32 is subnetted, 1 subnets
D EX    192.168.1.2 [170/23072000] via 10.3.7.1, 00:06:48, Serial0/0
D*EX 0.0.0.0/0 [170/20514560] via 10.3.7.1, 00:06:48, Serial0/0





0
 
christsisCommented:
That looks good. Routes are being distributed right...

are the machines on 10.3.2.x using 10.3.2.1 as the gateway or 10.3.2.100?
0
 
donegalmanAuthor Commented:
the machines on 10.3.2.x are using 10.3.2.100 as their gateway-this then points them to 10.3.2.1 for internet-as the last route...im still lost as to why i cannot ping 10.3.2.100...the main ethernet interface at siteA??
0
 
christsisCommented:
I'd have to agree, there's no reason you shouldn't be able to ping it.

0
 
donegalmanAuthor Commented:
right lets see if we could tackle this one first??

from the computer 10.3.2.10 i can ping 10.3.6.1 (the ethernet interface on SiteA) but when i ping 10.3.6.2 i get no reply...which router do you think is at fault for this?
0
 
donegalmanAuthor Commented:
if i do a tracert from 10.3.2.10 it goes as follows:

10.3.2.10   -  10.3.2.100  -  10.3.7.2  - and then gets stuck
0
 
christsisCommented:
Is it possible there's just a lot of traffic on that line and it's timing out? Can you try a ping with a really high timeout?

like ping -w 999999999 10.3.6.2

It seems so odd since the routes are there properly in the show ip route you gave. So it's not likely a routing issue at this point.
0
 
donegalmanAuthor Commented:
sorry thats not it....its GMT here-so its 10 o'clock on a friday nite-no one here but me!

it seems strange that from inside the router i can ping anywhere on SiteA or SiteB but from the PC attached i cannot.  i think there is something fundemenatlly wrong with the config on SiteA...could u maybe just take a look at it again...thanks
0
 
christsisCommented:
Well, let's go through it step by step...

-----SITE A--------
interface FastEthernet0/0
 no ip address
 load-interval 30
 speed auto
 full-duplex

interface FastEthernet0/0.1
 description *** LAN ***
 encapsulation dot1Q 1 native
 ip address 10.3.2.100 255.255.255.0
 no snmp trap link-status

So, we have VLAN's and 802.1q trunking setup and this is clearly the native so there's no real problem there...
We've confirmed the machines use 10.3.2.100 as their gateway so anything on 10.3.2.0 properly routes to here....
There's no incoming ACLs to block any sort of traffic, so that's good as well..

nterface Serial0/1
 description *** 128K Link To Site C ***
 bandwidth 128
 ip address 10.3.7.1 255.255.255.0

interface Serial1/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 isdn bchan-number-order ascending
 no cdp enable

Okay, so now we have the ISDN setup, which is clearly up or there'd be no connectivity...
IP address is setup properly and interface is up, again, there'd be no connectifity at all if that weren't true...
And also, no ACLs setup that would block anything

--------SITE C----------
interface Serial0/0
 description Connection to SiteA
 bandwidth 128
 ip address 10.3.7.2 255.255.255.0

So here's the other end of the Serial interface, IP is good and on the same subnet as the other side...
Again there's no ACL's to block anything, so that's good as well....

interface Ethernet0/0
 ip address 10.3.6.1 255.255.255.0
 half-duplex

Again... good IP no ACL's blocking... should be good.
Assuming all machines are properly using 10.3.6.1 as their gateway?


---------SITE A Show IP route--------------
     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D       10.3.3.0/24 [90/284160] via 10.3.5.2, 00:00:31, FastEthernet0/0.100
C       10.3.2.0/24 is directly connected, FastEthernet0/0.1
C       10.3.5.0/24 is directly connected, FastEthernet0/0.100
C       10.3.4.1/32 is directly connected, Multilink1
C       10.3.4.0/24 is directly connected, Multilink1
C       10.3.7.0/24 is directly connected, Serial0/1
D       10.3.6.0/24 [90/20537600] via 10.3.7.2, 00:00:31, Serial0/1
     192.168.1.0/32 is subnetted, 2 subnets
C       192.168.1.1 is directly connected, Loopback0
S       192.168.1.2 [1/0] via 10.3.4.1
S*   0.0.0.0/0 [1/0] via 10.3.2.1

Here we see that Site A properly has the connected routes for 10.3.2.0 and 10.3.7.0...
We also see Site A knows that 10.3.6.0/24 is available via 10.3.7.2 out Serial0/1


---------SITE C Show IP route--------------
Gateway of last resort is 10.3.7.1 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D       10.3.3.0/24 [90/20540160] via 10.3.7.1, 00:00:42, Serial0/0
D       10.3.2.0/24 [90/20514560] via 10.3.7.1, 00:06:48, Serial0/0
D       10.3.5.0/24 [90/20514560] via 10.3.7.1, 00:06:48, Serial0/0
D EX    10.3.4.1/32 [170/23072000] via 10.3.7.1, 00:06:48, Serial0/0
D       10.3.4.0/24 [90/23072000] via 10.3.7.1, 00:06:48, Serial0/0
C       10.3.7.0/24 is directly connected, Serial0/0
C       10.3.6.0/24 is directly connected, Ethernet0/0
     192.168.1.0/32 is subnetted, 1 subnets
D EX    192.168.1.2 [170/23072000] via 10.3.7.1, 00:06:48, Serial0/0
D*EX 0.0.0.0/0 [170/20514560] via 10.3.7.1, 00:06:48, Serial0/0

Finally here we see that we properly have the connected route for 10.3.7.0 and 10.3.6.0...
We also can see that Site C knows about 10.3.2.0 and it's available via 10.3.7.1 out Serial 0/0
It's also known that everything else is available out S0/0 via 10.3.7.1 so even if that wasn't in the table via EIGRP...

So by going through this there is absolutely nothing that should interupt the routing.

The only other thing I could think of is:
1: The machines at Site C aren't using 10.3.6.1 as their gateway
2: The machines at Site C aren't using the proper 255.255.255.0 subnet

Other than that based on the information you've given here I don't see anything that could be wrong.




0
 
donegalmanAuthor Commented:
i have checked the ip address of the PC in siteC and it is all correct.

from SiteC i can ping anything on the 10.3.6.x , 10.3.7.x , 10.3.5.x and 10.3.4.x ranges.

its very strange that the router at SiteA is letting my ping request for 10.3.5.x go out to the wireless network-i can ping the Alvarion Wireless Units on the network...its as if its filtering the requests if they are for 10.3.2.100  what about access lists? would this cause any problem?

sorry for going on-but id love to get this sorted and get home to me bed-its a 2 hour drive home after this!!!
0
 
christsisCommented:
That's what I went through and pointed out, there's no access lists that are applied to the affected interfaces at all.

I agree, it's just confusing at this point what might be causing it at all.
0
 
donegalmanAuthor Commented:
ok il let it go and head home-thanks for your help-if you think of anything else id appreciate it
0
 
donegalmanAuthor Commented:
just heading now....but maybe its something to do with the VLANs...id need to have that on the Ethernet interface on SiteC would i?  

0
 
christsisCommented:
Only if there's trunking needed and 10.3.6.2 isn't on the same VLAN as the router 10.3.6.1
0
 
lrmooreCommented:
Missed all the fun....

router eigrp 10
 redistribute static
 network 10.0.0.0
 auto-summary  <== you need to disable auto-summary on the remote sites....

0
 
donegalmanAuthor Commented:
hi lrmoore

tucked up in bed now-but just logged in over the VPN and removed the auto-summary form the remote sites and its still the same-cant ping anything outside of the 10.3.6.1 interface.   but my problems have got bigger-as the connection between SiteA and SiteB-the one that was there before we started this is not working properly either.  form within the routerA i can ping the Serial interface on RouterB but not the ethernet interface on it or any PC's connected to that interface....the plot thickens!
0
 
lrmooreCommented:
Add a static default on C?

ip route 0.0.0.0 0.0.0.0 10.3.7.1

0
 
donegalmanAuthor Commented:
just tried that...it didn't make any difference.

i think the problem is to do with the multilink interface : this connects the 10.3.2.x and 10.3.3.x ranges over 10.3.4.x and from these i cannot ping SiteC or vice versa.   the 10.3.8.x range and 10.3.5.x can see each other perfectly.  could you have a look through the multilink details above and see what you think could be wrong in there...thanks
0
 
lrmooreCommented:
I don't quite get Site A's config for Mlppp with only one physical interface...
How about site B's config? I don't see it anywhere...

Add no auto-summary to all routers' EIGRP config

Make sure ip classless is enabled on B, as it is on A and C..
Make sure B has a default pointing to A..
0
 
donegalmanAuthor Commented:
i dont have B's configuration-its too remote to get access to-but i made no changes to it.

originally:

SiteA was connected to SiteB  with a 54mbits Alvarion Wireless Network the interface address on A for this is 10.3.5.1 and 10.3.5.2 on B's side. as a backup we use a 128k leased line from A to B. but we also put the voice over it all the time. it uses the serial0/0 on A 10.3.4.2 and Serial0/0 on B 10.3.4.1.  

sometimes now when im on the 10.3.2.10 PC i ping 10.3.3.12 a server on siteB and i get intermittent replies-its as if it doesn't know which way to go to find it-it'll reply 3 times-then timeout for 10 or 20.

should i put no auto-summary in the main router at SiteA too?
0
 
lrmooreCommented:
>should i put no auto-summary in the main router at SiteA too?
Yes, all routers should have this statement.

0
 
donegalmanAuthor Commented:
SiteB Config

Current configuration : 3460 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname Rinmore_2620_1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no network-clock-participate slot 1
no network-clock-participate wic 0
voice-card 1
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ip ftp passive
ip ftp username cisco
ip ftp password cisco
no ip domain lookup
ip host Rinmore 10.3.4.1
ip host Kindrum 10.3.4.2
no ftp-server write-enable
isdn switch-type primary-qsig
!
!
!
!
!
!
!
!
!
!
!
!
!
controller E1 1/0
 framing NO-CRC4
 pri-group timeslots 1-12,16
!
class-map match-all voice
  match access-group 100
!
!
policy-map LLQ
  class voice
   priority 105
!
!
!
!
interface Loopback0
 ip address 192.168.1.2 255.255.255.255
 h323-gateway voip bind srcaddr 192.168.1.2
!
interface Multilink1
 bandwidth 128
 ip address 10.3.4.1 255.255.255.0
 ip tcp header-compression iphc-format
 no ip mroute-cache
 load-interval 30
 ppp multilink
 ppp multilink fragment delay 10
 ppp multilink interleave
 ppp multilink group 1
 max-reserved-bandwidth 100
 service-policy output LLQ
 ip rtp header-compression iphc-format
!
interface FastEthernet0/0
 ip address 10.3.3.1 255.255.255.0
 ip helper-address 10.3.2.255
 no ip mroute-cache
 load-interval 30
 speed auto
 half-duplex
!
interface Serial0/0
 bandwidth 128
 no ip address
 encapsulation ppp
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no fair-queue
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1
 no ip address
 shutdown
!
interface Serial1/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn overlap-receiving T302 3000
 isdn protocol-emulate network
 isdn incoming-voice voice
 no isdn T309-enable
 no cdp enable
!
router eigrp 10
 redistribute static
 network 10.0.0.0
 auto-summary
!
ip classless
ip route 192.168.1.1 255.255.255.255 10.3.4.2
ip http server
!
logging trap debugging
logging 10.3.2.10
access-list 1 permit 10.3.2.2
access-list 100 permit udp any any range 16384 32768
access-list 100 permit tcp any eq 1720 any
access-list 100 permit tcp any any eq 1720
!
snmp-server community cisco RW 1
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps xgcp
snmp-server enable traps envmon
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps config
snmp-server enable traps dial
snmp-server enable traps dsp card-status
snmp-server enable traps entity
snmp-server enable traps frame-relay
snmp-server enable traps frame-relay subif
snmp-server enable traps hsrp
snmp-server enable traps ipmulticast
snmp-server enable traps rsvp
snmp-server enable traps rtr
snmp-server enable traps syslog
snmp-server enable traps voice poor-qov
snmp-server host 10.3.2.2 cisco
!
voice-port 1/0:15
!
!
!
!
dial-peer cor custom
!
!
!
dial-peer voice 11 pots
 destination-pattern 3..
 direct-inward-dial
 port 1/0:15
 forward-digits all
!
dial-peer voice 21 voip
 max-conn 3
 incoming called-number 3..
 destination-pattern 2..
 session target ipv4:10.3.4.2
 ip qos dscp cs5 media
 no vad
!
dial-peer voice 22 voip
 max-conn 4
 destination-pattern 9.T
 session target ipv4:10.3.4.2
 ip qos dscp cs5 media
 no vad
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
!
end
0
 
lrmooreCommented:
Looks like B is summarizing all 10.x.x.x
 use "no auto-summary" on B also...

I would also go ahead and add a static on B

 ip route 0.0.0.0 0.0.0.0 10.3.4.2
0
 
donegalmanAuthor Commented:
right i've just logged into all 3 routers and from within them i can ping anything on any of the ranges-so from Router B i can ping PC's on SiteC through RouterA...but from windows i cannot.  if i trace a route from the machine im on now (10.3.2.10) to say 10.3.8.2 a PC in SiteC-the route goes as far as 10.3.7.2 (Serial interface on RouterC) then times out from there
0
 
lrmooreCommented:
Sounds exactly like A doesn't know to get to C's LAN subnet, because B is telling A that "hey, all 10.x.x.x is over here.."
0
 
donegalmanAuthor Commented:
right you're getting places-Sites A and B now talk to each other again perfectly...where to next??? any more good ideas??
0
 
lrmooreCommented:
how about a new output of "sho ip rout" from all 3 routers?
0
 
donegalmanAuthor Commented:
SiteA

Gateway of last resort is 10.3.2.1 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D       10.3.6.0/24 [90/20537600] via 10.3.7.2, 00:01:35, Serial0/1
D       10.3.3.0/24 [90/284160] via 10.3.5.2, 00:01:40, FastEthernet0/0.100
C       10.3.2.0/24 is directly connected, FastEthernet0/0.1
C       10.3.5.0/24 is directly connected, FastEthernet0/0.100
C       10.3.4.1/32 is directly connected, Multilink1
C       10.3.4.0/24 is directly connected, Multilink1
C       10.3.7.0/24 is directly connected, Serial0/1
     192.168.1.0/32 is subnetted, 1 subnets
C       192.168.1.1 is directly connected, Loopback0
S*   0.0.0.0/0 [1/0] via 10.3.2.1

SiteB

Gateway of last resort is 10.3.4.2 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D       10.3.6.0/24 [90/20565760] via 10.3.3.90, 00:03:23, FastEthernet0/0
C       10.3.3.0/24 is directly connected, FastEthernet0/0
D       10.3.2.0/24 [90/78080] via 10.3.3.90, 00:03:23, FastEthernet0/0
D       10.3.5.0/24 [90/75520] via 10.3.3.90, 00:03:23, FastEthernet0/0
C       10.3.4.0/24 is directly connected, Multilink1
D       10.3.7.0/24 [90/20540160] via 10.3.3.90, 00:03:23, FastEthernet0/0
C       10.3.4.2/32 is directly connected, Multilink1
     192.168.1.0/32 is subnetted, 2 subnets
S       192.168.1.1 [1/0] via 10.3.4.2
C       192.168.1.2 is directly connected, Loopback0
S*   0.0.0.0/0 [1/0] via 10.3.4.2

SiteC

Gateway of last resort is 10.3.7.1 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C       10.3.8.0/24 is directly connected, Ethernet0/0
D       10.3.3.0/24 [90/20540160] via 10.3.7.1, 00:18:38, Serial0/0
D       10.3.2.0/24 [90/20514560] via 10.3.7.1, 00:32:26, Serial0/0
D       10.3.5.0/24 [90/20514560] via 10.3.7.1, 00:32:26, Serial0/0
D EX    10.3.4.1/32 [170/23072000] via 10.3.7.1, 00:32:26, Serial0/0
D       10.3.4.0/24 [90/23072000] via 10.3.7.1, 00:32:26, Serial0/0
C       10.3.7.0/24 is directly connected, Serial0/0
S*   0.0.0.0/0 [1/0] via 10.3.7.1

0
 
lrmooreCommented:
OK, it does not look like Site B is learning 10.3.8.0/24
Neither is Site A.

Is the Ethernet interface of C even connected and up/up ?

0
 
donegalmanAuthor Commented:
yes its connected-if i am logged into routerA or RouterB i can ping 10.3.8.2-the first PC on the SiteC LAN...however if i try pinging it from windows it just times out...
0
 
lrmooreCommented:
That's a good sign.
From the windows PC, an you post
C:\> route print

and result of
c:\>tracert 10.3.8.2
0
 
donegalmanAuthor Commented:

C:\>route print

IPv4 Route Table
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x10002 ...00 53 45 00 00 00 ...... WAN (PPP/SLIP) Interface
0x10003 ...00 0f 20 f8 ca 38 ...... HP NC7781 Gigabit Server Adapter
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0       10.3.2.100        10.3.2.10     20
         10.3.2.0    255.255.255.0        10.3.2.10        10.3.2.10     20
        10.3.2.10  255.255.255.255        127.0.0.1        127.0.0.1     20
        10.3.2.90  255.255.255.255        127.0.0.1        127.0.0.1     50
   10.255.255.255  255.255.255.255        10.3.2.10        10.3.2.10     20
        127.0.0.0        255.0.0.0        127.0.0.1        127.0.0.1      1
        224.0.0.0        240.0.0.0        10.3.2.10        10.3.2.10     20
  255.255.255.255  255.255.255.255        10.3.2.10        10.3.2.10      1
Default Gateway:        10.3.2.100
===========================================================================
Persistent Routes:
  None

C:\>

C:\>tracert 10.3.8.1

Tracing route to 10.3.8.1 over a maximum of 30 hops

  1    <1 ms     1 ms    <1 ms  10.3.2.100
  2    22 ms    22 ms    22 ms  10.3.8.1

Trace complete.

C:\>tracert 10.3.8.2

Tracing route to 10.3.8.2 over a maximum of 30 hops

  1     1 ms    <1 ms    <1 ms  10.3.2.100
  2    20 ms    19 ms    20 ms  10.3.7.2
  3     *        *        *     Request timed out.
  4  ^C
C:\>

0
 
lrmooreCommented:
That's as expected from PC at site A
What about same tests from PC at site C?

0
 
donegalmanAuthor Commented:
sorry but cant do that one from my bed!!!  ive terminal services set up on that PC but as i cant get thru to it....

just sending you the latest SiteC config to refresh your memory!     but must go to sleep now...if you come up with anything i'll check in again in the norning-thanks for your help...much appreciated


Building configuration...

Current configuration : 787 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Altan
!
enable password 7 060506324F41
!
ip subnet-zero
!
!
no ip domain-lookup
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 10.3.8.1 255.255.255.0
 full-duplex
!
interface Serial0/0
 description Connection to Kindrum
 bandwidth 128
 ip address 10.3.7.2 255.255.255.0
!
router eigrp 10
 redistribute static
 network 10.0.0.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.7.1
no ip http server
ip pim bidir-enable
!
snmp-server community public RO
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
 password 7 094F471A1A0A
 login
line aux 0
line vty 0 4
 password 7 094F471A1A0A
 login
!
end

0
 
lrmooreCommented:
G'night...
I don't think the problem is the router(s), but rather the machine. wrong IP subnet mask, or wrong default gateway
Proof is that PC at A can ping Ethernet IP of C, but not host on C..
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 23
  • 11
  • 11
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now