?
Solved

Primary e-mail address for Exchange 2003 Users not saved

Posted on 2005-04-29
5
Medium Priority
?
259 Views
Last Modified: 2011-09-20
I am running Exchange 2003 on SBS 2003.  I have four Exchange users who have aliases or two SMTP addresses. Example: jdoe@mycompany.com and john@mycompany.com.  I would like to have john@mycompany.com be the primary address so I set as such in Active Directory Users & Computers.  However, when I come back a short while later the other SMTP address is the primary.  I have tried to set one SMTP address as the primary and deleting the other but they always come back.  Any ideas?
0
Comment
Question by:wmorlett
  • 2
  • 2
5 Comments
 
LVL 21

Accepted Solution

by:
marc_nivens earned 750 total points
ID: 13898002
Recipient policies are responsible.  Next time you're on the Email addresses tab for the user, uncheck the box that says "automatically update email addresses based on recipient policy" and then make the address change.
0
 
LVL 27

Expert Comment

by:Exchange_Admin
ID: 13898023
FOR A SINGLE USER:
In ADUC, go to the properties of the user account.
Go to the email addresses tab.
Select the email address that will be primary.
You will se a box that also says something like "do not let recipient policy....." (I don't remember the specific wording.

FOR EVERYONE:
Go to the properties of the recipient policy.
Select which address to be primary.
0
 

Author Comment

by:wmorlett
ID: 13898046
I just tried that and it seemed to work.  In other words, it saved the setting.  I looked at the policy earlier but could not see what in it causes the e-mail address to come back.  Should I check the box "automatically update the e-mail addresses based on recipient policy," make the changes and then go back to AD Users & Computers and check "automatically update the e-mail addresses based on recipient policy" again?  Also, I am kinda confused as to why I could not just set the SMTP address I wanted as the primary.
0
 

Author Comment

by:wmorlett
ID: 13898078
Sorry, I meant should I check UNCHECK the box "automatically update the e-mail addresses based on recipient policy," make the changes and then go back to AD Users & Computers and check "automatically update the e-mail addresses based on recipient policy" again?
0
 
LVL 27

Expert Comment

by:Exchange_Admin
ID: 13898142
By UNCHECKING the box "automatically update the e-mail addresses based on recipient policy", the user will retain the settings you made.
If the box is checked, then it will be configured according to how the recipient policy is configured next time it updates.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
how to add IIS SMTP to handle application/Scanner relays into office 365.
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Suggested Courses

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question