Win XP Hangs loading ethernet connect to cable modem

I have a Gateway desktop running Windows XP home edition and a cable modem W/ethernet connection.  Every time I re-boot the system hangs while loading network settings. If I unplug the ethernet cable and wait untill the OS loads and then plug in the ethernet - the conection works fine. What could cause it to hang?  (NiC= Intel Pro/100 VE Network Card - all tests OK)  ???
RichZinneAsked:
Who is Participating?
 
JohnnyCanuckCommented:
Things to try
 - uninstall and reinstall network card
 - from a command prompt "NETSH INTERFACE IP RESET LOG.TXT" (without the quotes)
 - try a different cable
 - try a different ethernet card
 - rebuild winsock
How to Recover from Winsock2 corruption
To resolve this issue, delete the corrupted registry keys, and then reinstall the TCP/IP protocol.
Step 1: Delete the corrupted registry keys
1.      Click Start, and then click Run.
2.      In the Open box, type regedit, and then click OK.
3.      In Registry Editor, locate the following keys, right-click each key, and then click Delete:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2
4.      When you are prompted to confirm the deletion, click Yes.
Note Restart the computer after you delete the Winsock keys. Doing so causes the Windows XP operating system to create new shell entries for those two keys. If you do not restart the computer after you delete the Winsock keys, the next step does not work correctly.
Step 2: Install TCP/IP
1.      Right-click the network connection, and then click Properties.
2.      Click Install.
3.      Click Protocol, and then click Add.
4.      Click Have Disk.
5.      Type C:\Windows\inf, and then click OK.
6.      On the list of available protocols, click Internet Protocol (TCP/IP), and then click OK.
7.      Restart the computer.
0
 
rburns50Commented:
My suggestion is to force the NIC in your WinXP Home PC to whatever settings your cable modem connection is (likely half-duplex, 10Mbps). Some NIC's don't like to autonegotiate very well.

Just go to the properties of that connection, click "configure" next to the card, and then "advanced". there shoudl be a setting to manually set the speed and the duplex setting.
0
 
Rafiq24Commented:
Adam said move the network card into another PCI slot. Or first go to the bios and check which IRQ the NiC card is using and make sure its not sharing with any other commuinication device like modem or video card.(If not integrated)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.