[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 187
  • Last Modified:

Trying to save a new file across the network (XP)...

I'm on XP.

This should be pretty straight forward. When I browse to a file across my network and open it, i can make changes and save it with no problem.

However when i'm in a text editor and try to save a brand new file, instead of saving to the drive on the pc i'm networked with it says its saving it to: "C:\Documents And Settings\Dennis\NetHood\Storage on Laptop\test.txt"

In the save menu I click on "My network places" and then "Storage on Laptop" the directory i'm currently sharing. As soon as I save it here it saves to C:\Documents And Settings\Dennis\NetHood\Storage on Laptop\ and that file does NOT show up on the drive that it should.

Can anyone explain this? It seems to be saving it locally rather than across the network. Even if that local folder is somehow mapped to the network drive it's still not putting the file where it should on my other computer.

Any help would be appreciated. This sucks.

Thanks.

-Dennis
0
bombATOM
Asked:
bombATOM
1 Solution
 
Rafiq24Commented:
Adam Says try changing the permissions. Right click on the shared folder and make sure it has READ/WRITE permissions enabled. Or Add group permissons for the group "Everyone".
0
 
bombATOMAuthor Commented:
Thanks... The files already had 'read only' *unchecked* and in addition under the folder sharing properties the "allow other users to modify these files" was checked. I have been able to open current files in that folder and even modify them and save them. I just cant create new files in this program. If i type this into my save box for a new file: \\laptop\storage\test.txt it WILL save the file... So it doesn't at least appear to be directly caused by a permissions problem. It's only when i browse to the network folder through the save dialog box when it tries to save it to that local folder.

I didn't try anything with groups like you suggested because I couldn't find anything group related =) ... Any ideas?

Thanks!

-Dennis
0
 
xrokCommented:
>>In the save menu I click on "My network places" and then "Storage on Laptop" the directory i'm currently sharing.
And
>>\\laptop\storage\test.txt

maybe you are sharing your own drive and saving in via network to your own drive.




0
 
cjardCommented:
your question is a little confusing to me, can you tell me:

the network name of the machine you are working on
the shares this machine has that are currently mapped and where they are mapped to

the name of the machine you want to actually save the file on
the shares that machine has available; what the path is that is shared and what the share name is


you may be able to get your solution from this example:
example, i have a desktop and a laptop, called DESKTOP and LAPTOP respectively. they are linked together by a network, and the network works ok

On the DESKTOP machine i created a folder called c:\my work
i right clicked on this and chose the SHARING option
i shared the folder as WORKSTUFF and gave EVERYONE full control
the username and password of my desktop machine is: username= cjard, password= deskpass

i then went to the laptop, who has username= moose, and password = chocolate
i logged into the laptop, then opened My Computer
I click Map Network Drive from the tools menu, and in the screen that comes up i do:

  drive letter = W: (for work)
  server path to map = \\DESKTOP\WORKSTUFF
  i click "i want to connect with a different username and password"
  i enter the credentials for the DESKTOP (because even though my permissions say EVERYONE, it actually means EVERYONE THIS COMPUTER KNOWS ABOUT. the desktop computer that is hosting the share, doesnt know about a user called MOOSE, with CHOCOLATE password, so i CANT use those credentials. the credentials i enter are username= cjard, password = deskpass)
  i tick "reconnect at logon"
  then i click OK


in My Computer on the laptop, now has appeared the drive W:, and i can open it up, create and delete files, save as... from ms word and put the new files on W: drive on the laptop. the files are saved on the desktop machine


do not rely on My Network Places; if you have any folders shared on your local machine, then they show up here aswell as network locations. the whole thing is very confusing, and mapping a drive is ALWAYS better

you might be prompted to re-enter your password for W: drive the next time you log in. the password you enter is the password for the desktop machine, not the laptop machine. you can definitely avoid this by having the same username and password on both machines. if you do this, additionally, you dont need to click "connect using different name" in the map drive box
0
 
bombATOMAuthor Commented:
Thanks so much. As pathetic as it might seem, I didn't even know the 'map network drive' tool existed. That makes things a whole lot easyer =). It completley solved my problem!

Thanks so much!

-Dennis
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now