[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 214
  • Last Modified:

PPTP connection terminating on a PIX....Having routing issues with Internal networks.

I have a PIX 501 with configuration  listed below. I am able to get connected and able to connect to devices on the same network segment as the inside interface but there is another internal network of 172.20.252.0/24 that I also need my PPTP VPN client to access. I am able to ping this network when I SSH to the pix and also from clients that are in the 172.16.211.0/24 network. The only client that are not able to connect to this netowrk is client that terminate to the PIX via a PPTP connection. Thank in advance.

:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 10full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password lkdjflkjsdkfnklsdf encrypted
passwd kjdshfkjshdfn encrypted
hostname pix
domain-name acme.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit icmp any any
access-list 100 permit ip 172.16.211.0 255.255.255.0 172.16.211.0 255.255.255.0
access-list 100 permit ip 172.20.0.0 255.255.255.0 172.16.211.0 255.255.255.0
access-list 102 permit ip any any
pager lines 24
logging buffered informational
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.x 255.255.255.0
ip address inside 172.16.211.126 255.255.255.128
ip audit info action alarm
ip audit attack action alarm
ip local pool remote 172.16.211.124-172.16.211.125 mask 255.255.255.128
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 100
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group 102 in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x
route inside 172.20.0.0 255.255.0.0 172.16.211.123 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet 172.16.211.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
vpdn group corebts accept dialin pptp
vpdn group corebts ppp authentication pap
vpdn group corebts ppp authentication chap
vpdn group corebts ppp authentication mschap
vpdn group corebts ppp encryption mppe 40
vpdn group corebts client configuration address local remote
vpdn group corebts pptp echo 60
vpdn group corebts client authentication local
vpdn username ******** password *********
vpdn enable outside
terminal width 80
0
shenanigan
Asked:
shenanigan
1 Solution
 
magicommincCommented:
you have a route for inside:
>route inside 172.20.0.0 255.255.0.0 172.16.211.123 1    --> that covers 172.20.252.0/24, okay.
assuming that 172.20.252.0/24 knows the route back to 172.16.211.0/25 (double check), but your no-nat acl doesn't make sense:
>access-list 100 permit ip 172.16.211.0 255.255.255.0 172.16.211.0 255.255.255.0 ---same source and dest or typo?
>access-list 100 permit ip 172.20.0.0 255.255.255.0 172.16.211.0 255.255.255.0 --- doesn't cover 172.20.252.0/24
try this:
access-list 100 permit ip 172.16.211.0 255.255.255.128 172.20.0.0 255.255.0.0
access-list 100 permit ip 172.20.0.0 255.255.0.0 172.16.211.0 255.255.255.128
0
 
lrmooreCommented:
Magico found the same thing I did, so you're on the right track.
Make sure the client has "use default gateway on remote network" checked. You might not like the result.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now