recovery console problem

when i selected R to use recovery console on my win2000 pro PC, it bypassed the options and goes directly to c prompt. for that reason i was unable to execute any commands b/c of "access denied" messages. i know it requires a password and that recovery console has to display the options such as choose an OS (pick a number) then prompts for password. i tried to shut down then power up several times but the RC still bypass the options. the hard drive is in good condition and checked that the drive is accessible by the win98 bootable floppy and also used BIOS setup to check that it can detect the HD. my purpose for using RC is to restore the missing ntoskrnl.exe file. please advise.

thanks
tony
tcunning4Asked:
Who is Participating?
 
oBdACommented:
There are two possibilities here; let's start with the better one:
You had the "Recovery console: Allow automatic administrative logon" in the local security policy enabled. The "Access denied" message comes up when you're trying to access a directory outside root, cmdcons, %systemroot% and its subfolders (or removable media).
Description of the Windows 2000 Recovery Console
http://support.microsoft.com/?kbid=229716

If together with the logon policy you enabled "allow floppy copy ..." as well, you need to enable access by setting the allowallpaths variable in the recovery console:
Description of the SET Command in Recovery Console
http://support.microsoft.com/?kbid=235364

Either way, you should be able to copy the ntoskrnl.exe file from the %systemroot%\driver cache directory or copy/expand it directly from a CD (with the ntoskrnl.exe version matching your service pack).
To Replace a Driver by Using Recovery Console in Windows 2000
http://support.microsoft.com/?kbid=313670

The second one (which is actually more probable, I'm afraid) is that you're starting the console from CD, and that your W2k installation can't be verified, due to a corrupted disk or MBR (You should still be able to run the fixboot and fixmbr commands):
Recovery Console Starts Without Prompting for a Password
http://support.microsoft.com/?kbid=238836
0
 
tcunning4Author Commented:
second one is the problem and have performed the fixmbr/fixboot and tried to expand ntkrnlmp.exe from cd crive but still cannot access winnt folder..is there any other way to restore the missing ntoskrnl file ?
0
 
oBdACommented:
I actually don't think it's the "missing" kernel file. Seems like the complete installation is inaccessible, that's why you can't even use the recovery console.
If you have another machine, try to put the drive into this one and see if you can access any files on the drive. If so, backup anything of importance.
Next best thing to try might be a repair installation (with an install medium that matches your service pack level).
0
 
tcunning4Author Commented:
thanks for your time..goin to do some backup, format HD then reinstall the OS.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.