Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1565
  • Last Modified:

Sharing files over SMB protocol - Debian Linux and Windows XP

Hi

I'm in a network environment where most other machines on the switch are Windows XP and have file shares, which I cannot seem to access with the Samba setup I have. All I want to be able to do is access their file shares. At the moment when ever I try to connect with xsmbclient I get an NT_STATUS_ACCESS_DENIED error from the stdout and when I try using the Nautilus Windows network client I just get asked for passwords when in fact the shares should not require password authentication for access, and subsequently I am refused access.

Any thoughts?
0
GeneriK
Asked:
GeneriK
  • 2
1 Solution
 
rindiCommented:
Make sure your XP boxes have simple file and print sharing disabled. Then create users which are allowed access to all those PCs and give them access rights to the shares. If you are using knoqueror on your linux box, you should be able to connect to the xp boxes simply by entering smb://IPAddressOfWindowsBox/ShareName. You will then have to enter the username and password of the user you have just setup on the XP Box. You can also use "mount" to connect to a windows share.
First create a mount point (/mnt/xp1), then use the following command to connect:

mount -t cifs -o username=name //IpAddress/share /mnt/xp1

You'l again be asked for the password. After that the shared drive of the xp box should be mounted in /mnt/xp1

You'll have to do that as root. The cifs filesystem will also have to be installed. With older linux kernels this probably won't be the case (kernels below 2.6). With most newer systems cifs probably is installed already.
0
 
GeneriKAuthor Commented:
I do not have adminstrative access to the Windows boxes. They are people's personal machines. There are no domain-wide users either - this is not an Active Directory controlled environment. All I want to do is get onto the Windows shares that have been set up for anonymous access, and for some reason are available to all the other Windows users but not to me.
0
 
rindiCommented:
You don't need AD, but you have to get that simple file sharing option turned off, that only works with XP (and even then it is erratic). And you will have to create those users. Samba needs some sort of authentification, it is not like windows which throws all security into the winds. You'll have to get the admins of those PCs to make those changes if you don't have enough rights yourself. An alternative could be to use an ftp server program on those xp boxes. There are free 3rd party ftp programs available for windows (but you will again need enough rights to install them).
0
 
sekargopiCommented:

You should be able to access in anonymous user mode by entering null password (simple enter) when it asks for password.

you can try using forward slash (/) instead of backward(\) in hostname.
eg: smbmount //hostname/disk-share /mnt/point

also before trying smbmount, try listing available shares on the server.
eg: smbclient -L //hostname

if that shows the shares properly with anonymous login then you should be able to mount them

Hope this helps,
Gopi
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now