FTP Isolation mode? Permissions?

Hi.
I have configured a FTP server on a Microsoft Windows 2003 and I have configured it with the isolation option. It works fine but I have some problems with the permissions settings. Some folders should have Read+Write and others should only have Read. Is it possible only if I create some Virtual Directories or can I use the NTFS permissions? I have tried configure the FTP-site with Read permissions and Full rights on the NTFS permissions but then a user have access denied when they are trying to copy something to the folder.? Is it possible to mix FTP rights with the NTFS permissions? If yes how?
Thanks!
Morten
mortenhemAsked:
Who is Participating?
 
BrianConnect With a Mentor IT ManagerCommented:
Sorry Mortenhem I had websites on my mind.  Like you said I meant the Security Accounts Tab.

Make sure that the user you are testing this with doesn't belong to another group that may have elevated permissions to that directory.


Brian
0
 
BrianIT ManagerCommented:
Do you allow guest access to this FTP Site?  If not check the write permission as well as the read permission.  Before you do that make sure that you uncheck Anoynmous access from the Directory Security tab.  This way the guest account will not be able to connect but your users will have the permission you want them to have which are assigned through NTFS.

Brian
0
 
mortenhemAuthor Commented:
Hi Brian.
When I take properties on my FTP site and click on the "Directory Security" tab I can only change "TCP/IP address access restrictions" (I think you talk about if you take properties on a web site). If I click the tab "Security Accounts" I have the opportunity to disable "Allow anonymous connections". I have tried that and then checked the write permissions but I can still create files in a folder where the user only have read NTFS permissions.

Morten
0
 
mortenhemAuthor Commented:
Hi Brian.
It was very strange because the FTP user was only member of one group, and this group had only read rights, but I removed all groups and I added only the specific FTP user and assigned the read rights and now it works fine.
THANKS Brian!!!!!!!!!!!!!!!!!!!!!!!!!!!
Morten
0
 
BrianIT ManagerCommented:
No problem Morten,

Let us know if you have any other questions.

Brian
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.