[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 604
  • Last Modified:

URGENT: WinXP connecting 2 computers directly

Can you guys help me with a few simple steps, because I'm going nuts. I am trying to connect 2 pcs with WinXP pro, using a cross cable. Right now, the only thing I got to work is sharing the internet connection, but I'm not even sure how that happened.
0
NeoTeq
Asked:
NeoTeq
  • 10
  • 5
  • 4
  • +4
1 Solution
 
dis1931Commented:
What is not working at this point?  You should need to connect the crossover and make sure both clients are configured correctly to either receive an IP from DHCP or to use a static IP.  I assume one of the PCs has dual nics to be able to both directly connect and also connect to the internet.  Make sure both interfaces on the dual nic'd PC have the same IP address range.  If not then the directly connected PC will not be able to access anything on the other network.
0
 
NeoTeqAuthor Commented:
I'm connecting to the internet via a USB DSL modem.

Could you provide me with a small walkthrough as to what I should do from the start, or a good link providing that?

The internet connection works for both pcs, but other than that, nothing works.
0
 
NeoTeqAuthor Commented:
Correction: the internet connection is now gone, too.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
rindiCommented:
First use a command prompt on both PC's and run

ipconfig /all

Then post the results here.
0
 
NeoTeqAuthor Commented:
Sorry it's in Dutch.. This is the pc with internet connection:

Windows IP-configuratie

        Host-naam  . . . . . . . . . . . .: Bert
        Primair DNS-achtervoegsel. . . . .:
        Knooppunttype . . . . . . . . . . : hybride
        IP-routering ingeschakeld. . . . .: ja
        WINS-proxy ingeschakeld . . . . . : nee

Ethernet-adapter LAN-verbinding:

        Verbindingsspec. DNS-achtervoegsel:
        Beschrijving . . . . . . . . . . .:
          Intel(R) PRO/100 VE Network Connection
        Fysiek adres. . . . . . . . . . . : xx-xx-xx-xx-xx-xx
        DHCP ingeschakeld:. . . . . . . . : nee
        IP-adres. . . . . . . . . . . . . : 192.168.1.1
        Subnetmasker. . . . . . . . . . . : 255.255.255.0
        Standaardgateway. . . . . . . . . :

PPP-adapter Alcatel Speedtouch Connection:

        Verbindingsspec. DNS-achtervoegsel:
        Beschrijving . . . . . . . . . . .:
          WAN (PPP/SLIP) Interface
        Fysiek adres. . . . . . . . . . . : xx-xx-xx-xx-xx-xx
        DHCP ingeschakeld:. . . . . . . . : nee
        IP-adres. . . . . . . . . . . . . : 81.69.xxx.xxx
        Subnetmasker. . . . . . . . . . . : 255.255.255.255
        Standaardgateway. . . . . . . . . : 81.69.xxx.xxx
        DNS-servers . . . . . . . . . . . : 194.134.5.5
                                            194.134.0.97

The other pc:

Windows IP-configuratie

        Host-naam  . . . . . . . . . . . .: benetech-vvvy1q
        Primair DNS-achtervoegsel. . . . .:
        Knooppunttype . . . . . . . . . . : hybride
        IP-routering ingeschakeld. . . . .: nee
        WINS-proxy ingeschakeld . . . . . : nee

Ethernet-adapter LAN-verbinding:

        Verbindingsspec. DNS-achtervoegsel:
        Beschrijving . . . . . . . . . . .:
          Intel(R) PRO/100 VE Network Connection
        Fysiek adres. . . . . . . . . . . : xx-xx-xx-xx-xx-xx
        DHCP ingeschakeld:. . . . . . . . : nee
        IP-adres. . . . . . . . . . . . . : 192.168.1.1
        Subnetmasker. . . . . . . . . . . : 255.255.255.0
        Standaardgateway. . . . . . . . . :


0
 
rshooper76Commented:
It appears that both PC's have the same ip address, 192.168.1.1, is this in fact true?.   Make sure that the Windows firewall is not blocking any traffic as well.  Assign differnt IP adrresses to each PC and try to ping each machine, and your DNS servers from each machine.  That should at least get you started.
0
 
alanheatonCommented:
Have you run the Network Setup Wizard

If not

disconnect the cable

On the PC running the internet connection

Tun Network Setup Wizard and make sure you enable File and Print sharing and ICS (Internet Connection Sharing)

This will run through and may ask you to restart

When it restarts do the same on the otherbut make sure you tick the box

'This compouter connects via another computer for the internet'

Let me know what happens
0
 
dis1931Commented:
the first problem is your IP address on both adaptors is the same.  You should change one of them to be 192.168.1.2.  There cannot be duplicate IP addresses on the same network.
0
 
NeoTeqAuthor Commented:
First, I made a typo (had to type the second pc's result, but it has 192.168.1.2.
0
 
alanheatonCommented:
If you are sure you are using a crossover and not a patch by running the setup wizard should resolve issues, as long as you check the correct boxes whilst running through the wizards

dis is spot on !!
0
 
NeoTeqAuthor Commented:
I'm sorry no result. Unless it really isn't a crossover... But that would be strange since it says so on the packing.
0
 
alanheatonCommented:
Are you putting them in the same 'Workgroup' during set up

When you go into Network Place

then View Workgroup computers can you see Both PC's
0
 
Jared LukerCommented:
look at the wire colors on both ends of your cable.  If it's a straight through cable, then the order will be exactly the same.  If some wires are "crossed," then you should have yourself a crossover cable.
0
 
dis1931Commented:
Did you run the wizard on the PC connected to both the PC and the Internet?  It should be able to setup the internet connection sharing and the other PC should just work.  Also make sure the second PC has DHCP set as Internet Connection Sharing will assign it an address.
0
 
NeoTeqAuthor Commented:
Yes, I am... I sometimes see the other pc from the 'internet'-pc, but can't access it. From the other pc, I see nothing.
0
 
rindiCommented:
If you right click the network connection on your 2nd pc, make sure the IP configuration isn't set to auto. Give that pc an ip of 192.168.1.2 and leave the subnet mask at 255.255.255.0.
Set the gateway address to 192.168.1.1 (the ip address of your 1st PC). Now set the dns server addresses on your 2nd pc to:

DNS-servers . . . . . . . . . . . : 194.134.5.5
                                              194.134.0.97

(like in your ppp connection on the 1st pc.)

Now, on both PC's, disable "simple file and print sharing". On the PC you want to share your resources on, enable "file and printer sharing" in the settings of the network configuration.

Now create a common user on both PC's.
Now Right click the folder you want to share and click on "sharing and security", and add the user you created.

Now on the other PC you should be able to connect to that share by using the explorer, Tools, Map network drive. Now select a drive letter you want to assign that shared resource, and in the folder put the following:

\\192.168.1.X\SharedName

Where X is the IP address of the PC you are sharing the files on.

Now, if you click on "finish" you'll be asked for the username and password. Here you must enter the user you created above and the password for that user.

If you are using windows xp home, you will have to do a lot of these adjustments in safe mode, as you need to be administrator to do that and the administrator only is available in safe mode, as well as some of the menu options needed.
0
 
NeoTeqAuthor Commented:
>> If some wires are "crossed," then you should have yourself a crossover cable.
The green and orange are reversed. Does this mean it's a crossover cable?
0
 
alanheatonCommented:
Are you SP2

If so check your Firewall settings and Make sure File and Print Sharing is enabled
0
 
pseudocyberCommented:
>>The green and orange are reversed. Does this mean it's a crossover cable?

Yes.

If from PC 2 you can ping PC 1 then that part is OK.

from a command line, on PC 2, type "ping 192.168.1.1" assuming .1 is the other one.
0
 
NeoTeqAuthor Commented:
@rindi

So far so good. I've been able to share internet and files on both pcs your way. Now - how do I add printers to this story? I don't see the other computers when trying to add network printers.
0
 
NeoTeqAuthor Commented:
interesting, if I type the printer server and name manually I do get it.
0
 
rindiCommented:
First you have to right click on the printer you want to share, and again use the "sharing" option. Now select "Share this printer" and give it a sharename. Now on the other PC, use the "Add a printer Wizard", select Network Printer, then Connect to the printer.... and type in the shared printer \\192.168.1.X\PrinterSharedName.

After that you will have to install the printer driver. With some printers you will have to install the driver locally on the PC before before you can use it as a network printer. This is mainly the case with multifunction inkjet models.
0
 
rindiCommented:
If you want to be able to browse your network you will have to edit your hosts and lmhosts files, which are in \windows\system32\drivers\etc

You will have to add the PCs to these files like this:

192.168.1.1              PC1
192.168.1.2              PC2
127.0.0.1                  localhost

Once these 2 files exist on both PCs, you should also be able to browse them.
0
 
dis1931Commented:
Connection to each PC should function without the hosts files as long as you have not disabled netbios in the network connections.
0
 
NeoTeqAuthor Commented:
Thanks a lot, rindi! With your help I managed to get everything I needed!
0
 
rindiCommented:
Thanx too.
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

  • 10
  • 5
  • 4
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now