?
Solved

Can't install or uninstall .net framework 1.1

Posted on 2005-05-02
10
Medium Priority
?
62,382 Views
Last Modified: 2012-06-27
System has a number of problems, after a bad cloning and upgrade to XP Pro SP2 .... Java applets a problem (different issue, same system and another Q in this TA on that) and .net framework 1.1....

Tried to do WindowsUpdate to add the most recent service pack for .net framework .... never completes, always fails.  Tried removing it using the add/remove process but also always fails, is there but tells me it's not installed .... ?

Check this information from Microsoft, but still leaves me in the same place.  

Installation Repair
You may need to repair your installation of the .NET Framework after upgrading your operating system or if the system becomes corrupted.

To repair the .NET Framework
Obtain the original installation source. For example, if you installed the .NET Framework from CD or DVD, insert the disk. Or, if you downloaded the .NET Framework, download again and choose to save to disk. If you installed from a network share, reconnect.
On the Start menu, choose Run.
For Windows 98 and Windows Me type:
command
For Windows NT, Windows 2000, Windows XP or later, type:
cmd
In the command window, type the following:
n:\<Installation Source>\dotnetfx.exe /t:%temp% /c:"msiexec.exe /fvecms %temp%\netfx.msi"


For example:
d:\dotNetFramework\dotnetfx.exe /t:%temp% /c:"msiexec.exe /fvecms %temp%\netfx.msi"
To repair a .NET Framework Language Pack
Obtain the original installation source. For example, if you installed the .NET Framework Language Pack from CD or DVD, insert the disk. Or, if you downloaded the .NET Framework Language Pack, download again and choose to save to disk. If you installed from a network share, reconnect.
On the Start menu, choose Run.
For Windows 98 and Windows Me type:
command
For Windows NT, Windows 2000, Windows XP or later, type:
cmd
In the command window, type the following:
n:\<Installation Source>\langpack.exe /t:%temp% /c:"msiexec.exe /fvecms %temp%\langpack.msi"


For example:
d:\dotNetFramework\langpack.exe /t:%temp% /c:"msiexec.exe /fvecms %temp%\langpack.msi"


-------------------------

Again, when I try the uninstall, it tells me that it can't be done, product not installed, yet resides in the add/remove process.

When I try to install the WindowsUpdate service pack, get errors and points here:
Security Update for Microsoft .NET Framework, Version 1.1 Service Pack 1 (KB886903)
A security issue has been identified that could allow an attacker to compromise your Windows-based system running the Microsoft .NET Framework and gain access to restricted data. You can help protect your computer by installing this update from Microsoft. After you install this item, you may have to restart your computer.
How to Uninstall
This software update can be removed via Add or Remove Programs in Control Panel.
Help and support
http://go.microsoft.com/fwlink/?LinkId=38537 

Installation error message from WindowsUpdate is:
The upgrade cannot be installed by the Windows Installer Service because the program to be upgraded may be missing or the upgrade patch may be a  different version of the program.  Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch.

????

Thanks,
Asta
0
Comment
Question by:Asta Cu
  • 7
  • 2
10 Comments
 
LVL 49

Assisted Solution

by:sunray_2003
sunray_2003 earned 800 total points
ID: 13909713
Asta,

I have seen this software has helped in solving .net framework install or uninstall issues..

http://www.microsoft.com/downloads/details.aspx?FamilyID=5fbc5470-b259-4733-a914-a956122e08e8&displaylang=en

0
 
LVL 29

Accepted Solution

by:
blue_zee earned 1200 total points
ID: 13909731

Don't really know if this will help, but have you tried the "aspirine" approach?

Renaming MSCOREE.DLL and retrying the install?

I've seen it solve so many errors when installing .NET framework, that I wonder...

Asta, I haven't seen your error message before, so see this as a wild shot.

Zee
0
 
LVL 27

Author Comment

by:Asta Cu
ID: 13909892
Thank you both.  Ash, I've tried the 3.0 before, but as it says there:  "Windows Installer 3.0 Redistributable supports Windows 2000 with Service Pack 3 or later, Windows XP, Windows XP Service Pack 1 and Windows Server 2003. Windows XP Service Pack 2 contains Windows Installer 3.0 and therefore can't be installed or upgraded by this redistributable" ....

Zee, I'll try the renaming of that dll.

I found it further frustrating when doing research on this (months now); and found that with all these fiddlings, can't access the OfficeUpdate process without errors; and points to gdiplus.dll .... shows as missing and installer problems as well.

This has been a long process, and so far no luck; will try the renaming.

Asta
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 27

Author Comment

by:Asta Cu
ID: 13909953
Sadly, no change.

This is what I get when I try OfficeUpdate.... and again, likely due to the installer issues and versions...

Office Update is unable to check for updates Help
 
The Office Update site is unable to check for updates on this computer. This may be happening because of one of the following reasons:

You do not have administrative privileges for this computer. (not true)
There is a network problem and the detection catalog used by the Office Update site failed to download. Go back to the Downloads home page and try running detection again. (no help)
Windows Installer patch files (.MSP files) from previously applied Office updates are missing from the \Windows\Installer hidden directory on your computer. MSP files are stored on your computer after update installation completes because they need to be referenced for future update operations. If the files are missing you will not be able to apply Office updates. You may also be unable to uninstall Office products as a result of the same problem. Please contact Microsoft Product Support Services for assistance. (already done)
You installed Office updates in the past and then upgraded from Windows Installer version 1.0 to Windows Installer version 1.1. For more information see the KB article Windows Installer May Prompt for Install Source if Unavailable. (exactly what was done when I upgraded to SP 2)
0
 
LVL 27

Author Comment

by:Asta Cu
ID: 13910628
I should add that I had installed the WindowsInstaller version 3.1 update as noted here:
http://support.microsoft.com/kb/893803#5

But problems still persist.

sfc /scannow also run.
0
 
LVL 27

Author Comment

by:Asta Cu
ID: 13917711
XP SP2 support via Email has sent me a HUGE step-by-step which I'll try tomorrow and report back with details and progress.
0
 
LVL 27

Author Comment

by:Asta Cu
ID: 13919503
Gordon from Microsoft Technical Support for the XP SP2 issue I've had on .net framework has been very helpful, I'm making great headway and very much appreciate his diligence, so sharing the information so far.  I need to do a few more things and reboot, but this is the best I've done so far, and again, very appreciative of the Microsoft team for this level of detail and commitment to help me.

Paste start ->

Step One:

1. Go to Add or Remove Programs, try to remove all .NET Framework.
2. Please download and install the Windows Installer Cleanup utility
from this link:
http://download.microsoft.com/download/E/9/D/E9D80355-7AB4-45B8-80E8-983A48D5E1BD/msicuu2.exe

3. Then, please run it from Start-> All Programs-> Windows Install
Clean Up.
4. Please remove all Microsoft .NET Framework shown there and click
Remove.

Step Two:

1. Click Start->Run, type INSTALLER and click OK.
2. In the open folder, click View menu and select Details.
3. Right-click the Date Modified column header.
4. Click Comments
5. In the Comments column, locate the cached Windows Installer file
that displays Microsoft .NET Framework 1.1 (English) RTL x86 enu.
6. Right-click the cached Windows Installer file and then click
Uninstall.
7. Close the window.
8. Delete the cached Windows Installer file.

Step Three:

1. Restart your computer.
2. While your computer is booting up, press F8 to invoke the startup
menu.
3. In the startup menu, choose Safe Mode.
4. Log on as an administrator.

Note: In Safe Mode, your system display and Desktop will look and
perform differently than in Normal Mode. This is only temporary.

5. Delete the folder C:\WINDOWS\Microsoft.NET
6. Delete the folder C:\WINDOWS\system32\URTTemp
7. In the C:\Windows\System32 folder, locate the file mscoree.dll.
Right click and rename it to mscoree.old

Step Four:

1. Click Start->Run, type REGEDIT and click OK.
2. Navigate to the following registry key by expanding the "+" beside
the registry tree in the left pane:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework

3. Delete this key in the left pane.
4. Repeat steps 2-3 to delete the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup
5. Restart your computer to Normal Mode

Step Five:

1. Please download the Microsoft .NET Framework Version 1.1
Redistributable Package from the following link and save it to C:
http://www.microsoft.com/downloads/details.aspx?FamilyID=262d25e3-f589-4842-8157-034d1e7cf3a3&DisplayLang=en 

2. Click Start->Run, type "c:\dotnetfx.exe /C" (without quotation marks
and there is a space in this command) in the open box and click OK.

3. Click Run, and type "C:\.NET Framework 1.1" (without quotation
marks) in the open box click OK

Note: If you are prompted to create this folder, please click Yes to
continue.

4. Locate the folder C:\.NET Framework 1.1 and double click the file
netfx.msi in it to install .NET Framework components.

If .NET Framework 1.1 can be successfully installed, we can go on to
install .NET Framework 1.1 Service Pack 1:

Microsoft .NET Framework 1.1 Service Pack 1
http://www.microsoft.com/downloads/details.aspx?FamilyID=a8f5654f-088e-40b2-bbdb-a83353618b38&DisplayLang=en 

Step Six:

If the above two can be installed correctly, please download KB886903
from the following link and install again:
http://www.microsoft.com/downloads/details.aspx?familyid=8EC6FB8A-29EB-49CF-9DBC-1A0DC2273FF9&displaylang=en 

If the problem still exists, please describe the error message when
installing Microsoft .Net Framework Service Pack in further detail.

Paste End !

Asta
0
 
LVL 27

Author Comment

by:Asta Cu
ID: 13946401
Thanks a bunch to you both.  The detail from MS worked 100%!  Yay!  MSCOREE.DLL was a piece of the process.

Happy FRIDAY!  Or should I say "YAY-Day"

Next, the other issue of Java Applet problems, other question here.

":0) Asta
0
 
LVL 29

Expert Comment

by:blue_zee
ID: 13946519

"YAY-Day"
(whatever that means... but it sounds just like a great Friday!)

Thanks Asta!

Zee
0
 
LVL 27

Author Comment

by:Asta Cu
ID: 13954019
Yes it is!  We've officially renamed Friday to YAY-day here at home, tee hee.
":0) Asta
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Can I legally transfer my OEM version of Windows to another PC?  (AKA - Can I put a new systemboard in my OEM PC?) Few of us are both IT and legal experts but we all have our own views of Microsoft's licensing rules and how they apply.  There are…
Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
Integration Management Part 2
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Suggested Courses
Course of the Month14 days, 8 hours left to enroll

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question