yum causes out of memory error

I've been trying to update my linux box for 3 days now!!!  up2date in the taskbar says there are 335 updates.  I ran up2date many times with various errors.  I read that yum is better for Fedora Core 3 (which i'm running).  So, I typed yum -y update.  It took about 2 hours to download all the updates over dsl.  Then proceeded to run a transaction test?  That went for hours.  I fell asleep and woke up to an out of memory error and the process had been killed.  How do I update FC3 on an AMD64 with 512mb of RAM.  Yes, I've modified the yum.conf to point to the approriiate a64 directories of the repository.  
Who is Participating?
rindiConnect With a Mentor Commented:
As far as I know there shouldn't be too much of a problem. Do you have enough free diskspace in your /tmp, /var and most other folders? If there are so many updates, you may have run out of space? You could also try doing less updates at on time. This is probably easier with up2date, as you can select the programs. Try just selecting a bunch of 10 per run...
sekargopiConnect With a Mentor Commented:

the most likely issue is the huge number of updates. rpm tries to set up required packages to be updated by checking database and downloaded updates.

try having fewer updates at a time.

if you have not enabled swap then enable swap also just to get more memory.

keep the system idle during this period, kill all memory consuming process (X, mozilla, Openoffice etc)

then try your luck

Hope this helps,
sekargopiConnect With a Mentor Commented:

alternatively you can use --exclude option in yum to exclude single or bunch of packages to be installed.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.