library problems in slackware?

Posted on 2005-05-02
Last Modified: 2013-12-05
Hi there... I've got a really tricky question for people who love a challenge in linux...

event 1) 2004, I build a server with slackware linux, sendmail, apache and cyrus-sasl2 on (among other apps), all workin fine.

event 2) 2005, I try to build another slackware installation on a fresh server with the same programs but using up-to-date versions. I fail miserably making sasl run saslpasswd2, continually gives segmentation errors etc.

event 3) I use tar jcvf archive.tar /* on the original server (as per the advice on and ftp that 2gb file over to the new server (that already has it's own 10.1 slackware op. system on it with apache, sendmail and failed install of sasl on it etc.

event 3) everything _seems_ to work apart from apache and xwindows. when I try to run xwindows, it complains of "undefined symbol" etc in it's library files. Loads into Xwindows and complains of "Cannot start kdeinit". Apache does the same. Have tried remaking apache but complains of "can't find symbol's <numerous symbol names>".

event 4) Have reinstalled from the slackware cd setup, the xwindows install and the "L" group. Not much change.

I'm ok with installing and configuring apps on linux but the deeper stuff ( ie libraries ) then that is beyond me.

have checked ldconfig, runs fine. the /etc/ is fine.. I'm somewhat helpless and confused.

I know installing one os over another is a somewhat suicidal move but I havent got much to lose and trying to install sasl is driving me nuts when I appear to be doing nothing wrong. Can anyone provide _any_ help on my situation please?

Thanks for any and all help.

Question by:daryn
    LVL 87

    Expert Comment

    This might just be a hardware error. Segmentation faults can arise from bad memory, so I suggest you download memtest86 from and run it. Give at least 5 passes if you don't get an error before.
    If you have the UBCD ( you could also use this CD, which also has diverse memory test programs included, along with other usefull tools.
    LVL 2

    Accepted Solution


    looks to be that your old server installation of apache, xwindows links with few dynamic library versions which are missing in newer version of slackware.

    try running 'ldd' command for X windows binary and apache binary, they will give list of libraries with version numbers they are depending on. just ensure they are available in newer version of slackware(10.1).

    it is very likely that the libraries are available except for few missing links.

    Hope this helps,

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
    If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
    Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

    729 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now