?
Solved

Intel 82546GB and SuSe 8.0

Posted on 2005-05-03
8
Medium Priority
?
514 Views
Last Modified: 2008-01-16
Hi all!

I've got a MAXDATA Platinum Server 1500 IR and some problems with the
Intel 82546GB 10/100/1000 Adapter under SuSE 8.0. I dont want to bond
the connection. I only want a normel 100 Mbit konfiguration. I got the newest driver
from the Intel page for Linux and installed it. During the bootprocess lo, eth0, eth1
are corectly marked with 'done', but it is impossible to get a ping or send one.
Do I have forgot somthing, or does anybody know the Problem?

Thank You thinking about it
0
Comment
Question by:ikuhlmann
  • 4
  • 3
8 Comments
 
LVL 8

Assisted Solution

by:marxy
marxy earned 200 total points
ID: 13916991
Which driver did you download.
I assume that's sk98lin?
Then change the line in your /etc/modules.conf
alias eth0 sk98lin
options eth0 Autoneg_A=Off, Speed_A=100
0
 

Author Comment

by:ikuhlmann
ID: 13917067
I installed

Linux* Gigabit Adapter Base Driver [e1000-5.7.6.tar.gz] (131KB) 5.7.6 2/11/2005 Download
Linux* base driver for 2.4.x and 2.6.x kernels for Intel® PRO/1000

In my /etc/modules.conf

do I have:

alias eth0 e1000
alias eth1 e1000
0
 
LVL 3

Expert Comment

by:joju
ID: 13917602
where you connected your system?  to a switch/hub/ or another system?
I suspect the other end has auto negotiation problem.
give `tail -f /var/log/messages`
remove your cable and connect back
post here what you got in messages.


Thanxs,
Joju.

0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:ikuhlmann
ID: 13917855
The server is connected with a D-Link DI 624 hub with switch.

restarting with connection gives the messages:

iksqlserv kernel: isapnp: No Plug & Play device found
iksqlserv kernel: IPv6 v0.8 for NET 4.0
iksqlserv kernel: IPv6 over IPv4 tunneling driver
..
iksqlserv modprobe: modprobe: Can´t locate module char-major-10-134
iksqlserv /etc/hotplug/net.agent[811]: No HW description found ... exciting
iksqlserv kernel: eth0: no IPv6 routers present
iksqlserv kernel: eth1: no IPv6 routers present

After disconnect and connecting cable the messages:

iksqlserv kernel: e1000: eth1: e1000_watchdog: NIC Link is Down
iksqlserv kernel: e1000: eth1: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex

follows.



0
 
LVL 3

Expert Comment

by:joju
ID: 13917887
please post  ifconfig command output
0
 

Author Comment

by:ikuhlmann
ID: 13918185
eth0      Link encap:Ethernet  HWaddr 00:0E:0C:4F:C5
          inet addr:192.168.0.75  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20:cff:fe4f:fec5/64 Scope:Link
          UP BROADCAST  MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0(0.0 Mb)  TX bytes:0(0.0 Mb)
         Base address:0xdc00 Memory:fcfe0000-fd000000

eth1      Link encap:Ethernet  HWaddr 00:0E:0C:4F:C4
          inet addr:192.168.0.76  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20:cff:fe4f:fec5/64 Scope:Link
          UP BROADCAST  MULTICAST  MTU:1500  Metric:1
          RX packets:94 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes: 9562 (9.3 kb)  TX bytes:0(304.0 b)
         Base address:0xdc00 Memory:fcfa0000-fcfc000000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1120 (1.0 kb)  TX bytes:1120 (1.0 kb)

0
 
LVL 3

Accepted Solution

by:
joju earned 1800 total points
ID: 13918221
Your eth1 is connected to hub
ping might be sending packets from eth0.


try this

"ifdown eth0"
then ping any other system in network.

if it works .. change eth0's ip address to some other network
like 192.168.1.75.


Thanxs,
Joju.
0
 

Author Comment

by:ikuhlmann
ID: 13918339
It works!
Thank You very mutch!
Greetings from Germany
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Is your OST file inaccessible, Need to transfer OST file from one computer to another? Want to convert OST file to PST? If the answer to any of the above question is yes, then look no further. With the help of Stellar OST to PST Converter, you can e…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question