Urgent - Cisco Pix configuration was "How do i configure a cisco PIX passthrough IP addresses on the same subnet"

Posted on 2005-05-03
Last Modified: 2013-11-16
I have been given a range of 64-1 usable IP addresses.  I have a problem in that i cannot use NAT and as so have been advised to split the range into a /27 subnet.

The range that i have been given is *.*.*.192/26 thus
network Address = *.*.*.192
ISP default gateway = *.*.*.193
Broadcast = *.*.*.255
subnet mask

I need to further subnet this for the outside and inside network so i get:
network Address = *.*.*.192
ISP default gateway = *.*.*.193
PixFirewall = *.*.*.194

However when i do this i am unable to route anything through the firewall (connectivity has been tested by getting it all working using NAT first).

Here is a copy of my config. What am i missing?


: Saved
: Written by enable_15 at 14:45:33.289 UTC Tue May 3 2005
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ************* encrypted
passwd *************** encrypted
hostname lewes
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
name *.*.*.254 Pat
access-list inside_access_in permit icmp any any
access-list outside_access_in permit icmp any any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside *.*.*.194
ip address inside *.*.*.225
ip audit info action alarm
ip audit attack action alarm
pdm location *.*.*.226 inside
pdm location Pat inside
pdm location inside
pdm location *.*.*.* outside
pdm logging informational 100
pdm history enable
arp timeout 14400
nat (inside) 0 0 0
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
rip inside default version 1
route inside 1
route outside 2
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http *.*.*.* outside
http inside
http Pat inside
http *.*.*.224 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server outside *.*.*.*
floodguard enable
telnet timeout 5
ssh *.*.*.* outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
terminal width 80
: end

Broadcast = *.*.*.223
subnet mask

network Address = *.*.*.224
default gateway / inside interface = *.*.*.225
Broadcast = *.*.*.255
subnet mask
Question by:PatHastings

    Author Comment

    oops seem to have pasted the config in the middle of the IP address summary - to confirm i wish to configure the two interfaces with the following ranges:

    network Address = *.*.*.192
    ISP default gateway = *.*.*.193 (unusable by us)
    PixFirewall = *.*.*.194
    Broadcast = *.*.*.223
    subnet mask

    network Address = *.*.*.224
    default gateway / inside interface = *.*.*.225
    Broadcast = *.*.*.255
    subnet mask

    LVL 79

    Accepted Solution

    You need to remove this line:
       access-group inside_access_in in interface inside

    You are only permitting icmp out...

    Instead of this:
      >nat (inside) 0 0 0

    I would use this:
      static (inside,outside) *.*.*.224 *.*.*.224 netmask

    I think you want the route outside to be the default:
     route inside 1  <== remove this:
    route outside 2 <== change this metric from "2" to "1"

      no route inside
      no route outside 2
       route outside

    LVL 43

    Expert Comment

    Remove your inside route:

    lewes(config)#no route inside 1

    Author Comment

    The deletion of the route command had no effect,

    however the changing the NAT command to a static worked a treat

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    What Is Threat Intelligence?

    Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

    Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
    This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now