Software installations via group policy "Fatal error during installation"

fairfranco
fairfranco used Ask the Experts™
on
I'm trying to deploy Office 2003 via Group Policy, publishing it to the user.

However I have come across an error message that is preventing the user OR administrators from being able to install.  On trying to Add the program I get the error

"Fatal Error During Installation"

This doesn't give much away.  But if i look in the event log I get the following messages.

The assignment of application Microsoft Office Professional Edition 2003 from policy  failed.  The error was : Fatal error during installation.

error code: 101  source:  application management


I've looked this up across the WEB including event id that had a few similar bits but nothing that solved my problem.

I've assigned permissions both user and computer to the shared directory and elevated permissions for installations are set via policy to allow users to install the program.  however as stated I can't install logged in as myself either so it is not a permissions issue.

Please could someone suggest a solution if they have had a similar problem as this is really hampering my project to roll Office out!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
JoeWeb Application Developer

Commented:
It sounds like your MSI is corrupted did you make it yourself?

Author

Commented:
No I didn't.  It is the MSI that comes with Office 2003 and runs fine if I run it manually.

I was using an MST on the install as well but have stripped this out now to get rid of as many variables as possible that could be causing this problem.

Commented:
I would go to a station and run from the command line the office transform install with this appended to the end.
/qb+
It should be more descriptive as to what is happening with installation problem or you can use logging with this installation.
http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3B826511&Product=off20
It will say at what point it fails.
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

Author

Commented:
that's a useful article and could prove very useful.  however when I try at the moment it's not even hitting the Office MSI.

It seems to be failing before running anything from the MSI.  I have another MSI also that was made by one of our developers that worked only last week through an advertisement that is now getting this same error.

Commented:
If the same thing is happening to two different installations.. hmm.. are there spaces in the path to this msi file? If so you may have to enclose the path in quotations? Verify the permissions of the share? Just quick thoughts.

Author

Commented:
domain admins which includes my account has full permission over the whole office 2003 directory.

i've also given domain computers read, write and exexcute permissions over this directory.

There are no restrictions that i can find on installs on the GPO's.

I have tried setting it to assigned and install on log on and get the same error.

there are spaces in the path but I don't think you can add "" when setting the path on the GPO, you browse to the location, select it and it finds it.  I'm thinking there's no problem with this as it correctly brings back the microsoft information about the install in the properties.
Hi,
are you sure it couldn't be a problem with spaces in the path?
It might be worth removing any that might be there, just to be sure.
John.

Author

Commented:
when i removed the spaces it has made no difference.

verbose msi logging shows the following.

=== Verbose logging started: 04/05/2005  11:46:28  Build type: SHIP UNICODE 3.00.3790.2538  Calling process: C:\WINDOWS\System32\svchost.exe ===
MSI (c) (7C:B4) [11:46:28:219]: User policy value 'DisableRollback' is 0
MSI (c) (7C:B4) [11:46:28:219]: Machine policy value 'DisableRollback' is 0
MSI (c) (7C:B4) [11:46:28:219]: Executing op: Header(Signature=1397708873,Version=300,Timestamp=849629427,LangId=1033,Platform=0,ScriptType=3,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=0)
MSI (c) (7C:B4) [11:46:28:219]: Executing op: ProductInfo(ProductKey={A724D31A-56BD-4252-BE61-A9A788701B50},ProductName=CSFA_A11_StaticData_Setup,PackageName=CSFA_A11_StaticData_Setup.msi,Language=1033,Version=16777216,Assignment=1,ObsoleteArg=0,,,PackageCode={21C434EF-C230-4BE2-B35C-BBBFFF662500},,,InstanceType=0,LUASetting=0)
1: 1934
MSI (c) (7C:B4) [11:46:28:219]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (c) (7C:B4) [11:46:28:219]: DoAdvertiseScript is returning: 1603
=== Verbose logging stopped: 04/05/2005  11:46:28 ===

that was on the developers MSI.

Commented:
Try a gander at these.

"In order to see just what the problem actually is you should enable Windows Installer logging which will allow you to view a log of all attempts and failures related to your installation. Generally this problem revolves around SYSTEM account permissions on the target system, free disk space on the target system, or bad file download or locked/inaccessable file. For more help... One member reports having received this error installing MSN Messenger 6.2. They were able to get it to install successfully (and eliminate error 1603) by de-activating Ad-Watch from Lavasoft."
http://appdeploy.com/faq/msi_errors/detail.asp?id=11
http://support.installshield.com/kb/view.asp?articleid=Q107182
http://appdeploy.com/faq/detail.asp?id=76

Author

Commented:
Hi, thanks for those, i'd checked some similar issues out on appdeploy already but hadn't found any decent answers.  i've looked at all the reg keys etc that are mentioned in those bits but everything I can see is set correctly.

Author

Commented:
i've managed to solve this now.

after a day of playing about with the GPO's and moving a test user and machine into different OU's without GPO's which worked then gradually stripping them down till i found the problem setting.

the setting turned out to be one that looks so obvious i should have seen it really.

computer settings > administrative tools > windows components > Windows installer > prohibt user installs

this was set to enabled.

like i said, so obvious it should have been spotted along time ago!

thanks for the help but as there's no answers theres no points on this question but appologies for wasting your time.
Commented:
PAQ'd, 500 points refunded.
CetusMOD
Community Support Moderator

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial