[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Accessing WIN XP Workgroup Computers - Can only access using IP addr,  not by name

Posted on 2005-05-03
5
Medium Priority
?
3,289 Views
Last Modified: 2010-03-18
Scenario  
======

1. I have just added a brand new Dell machine WIN XP Pro SP2 to an existing workgroup of 7 computers, most of them WIN XP Pro SP2.

2. On this new computer (I will call it computer A), when I try to view other computers through Network Neighbourhood I can only see my own computer and not the other 7.  Even tried accessing another computer using

3. On this computer A I can connect to the Internet without any problems.
Private ip addresses on all computers are handled  by a router which is taking care of  DHCP and NAT services for all workgroup computer including Internet access.  No issues here.

4. On computer A, I can even access shares from another computer WIN XP Pro (I will call it computer B) using andrun an application that exists on computer B, however only by IP address.

5. On computer A, I can only map a drive to a share on computer B, but only using ip address not by it's
name.

6. Not sure what's going on here. I thought of LMHOSTS file but that is something that I never had to worry about in WIN XP networking workgroups.  The rest of the machines I added to this workgroup in the past without any problems and work OK.  None of this is happening on any other machines.

7. One thing to note, I did not install WIN XP Pro on this new machine. It came pre-installed.  All I had to do was to start the machine, go through some configurational questions and next, next, next....and it was finished.  Not sure what caused this unusual problem.  I looked at Microsoft File and Printer sharing and it's there and seems to be OK.  Normally, this should be a no-brainer.

Thanks
0
Comment
Question by:mailfreak
  • 2
  • 2
5 Comments
 
LVL 41

Accepted Solution

by:
stevenlewis earned 800 total points
ID: 13922340
first check the firewall(s)
then

Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.

Step 2: Start the Computer Browser Service

Click Start, right-click My Computer, and then click Manage.

In the console tree, expand Services and Applications.

Click Services.

In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.

Close the Computer Management window.
0
 

Author Comment

by:mailfreak
ID: 13928650
stevelewis, I see light at the end of the tunnel from your response.

I will be going over to the site today to try out your solution and let you know.

thanks
Sam (mailfreak)

0
 

Author Comment

by:mailfreak
ID: 13943028
I tried out the suggested solution.  It did not resolve the issue.
I then called Dell support and their techs were also unable to help.  They said they are not allowed to help in cases which are Network related.

Very frustrated, I decided to do  re-install of WIN XP Pro hoping that it will detect the LAN and fix things on it's own during installation.  So I reinstalled the WIN XP image on hidden partition.  That did not fix the problem either. I then tried temporarily disabling Norton Internet Security that comes preloaded as part of Norton Anti Virus from icon in system tray.
And luckily to my surprise, I was able to browse and name resolution started to work.
I then disabled that one component of Norton permanently.  Everytihing works fine now.

I will close this item now.

Thanks for your efforts.
Sam (mailfreak)












































































































































































































Hi Steven:

I tried out your suggested solution.  It did not fix the problem.
So I called and talked to Dell and their tech' s were also unable to help, saying they are not trained/allowed to help in Network related issues.

Very frustrated, I decided to re-install Windows from  hidden partition where the image is stored.

0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 13943402
Norton Internet Security is a firewall, check the very first thing I said in my post :-)
0
 

Expert Comment

by:tjmitch
ID: 14429326
I had the same problem with Norton Internet Security disabling access to a Workgroup. I configured the Personal Firewall with a Trusted Zone specifing the range of IPs that could jhave access.
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Resolve DNS query failed errors for Exchange
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question