• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1142
  • Last Modified:

Network Pauses

Hi, not sure if this is the correct area to post this but here it goes..

I have a Windows XP machine that is having problems with the network. Not major, but majorly annoying. Everytime I go into my Profax program (accounting software) for the first time after starting the machine, the profax windows blinks on screen, then sits there and "hangs", then it finally comes up. If you close it and open it again straight away, it comes up instantly. Also if you have the profax program open, and leave the pc for, say, 5 or 10 minutes, then come back and try to use it again, it again hangs (for about 15 - 20 seconds), then resumes so you can continue to use the Profax program. So if you are using the machine constantly, it works fine all the time. The Profax program runs from the server (data is on the server, client run locally).

Also i noticed that when you go into "My Network Places", for the first 5 seconds of it being open, everything works fine (i can select shares that have been found), but then it hangs for about 15-20 seconds.

It feels like it needs to always check to see if the server is still there if the network connection hasnt been active for a set time. Is there any such setting in windows xp? My XP machine is running Windows XP SP1.

So far i have tried replacing the network card, and also run a scandisk on the machine (no errors).

Don't know if it is relevant or not, but if i go into event viewer it has some errors around the time i started up the machine to do with atapi device or IDE (sorry cannot remember which one, but i know it didn't say bad blocks, and scandisk came up fine). i will make sure i write down the full error next time i am on it.

I can also remember reading somewhere about a reg key or something to do with windows searching for printers on other pc's and this sometimes causes hanging, but i since cannot find this article. Am i going in the right direction? Does this seem familiar to anyone?

Any help will be greatly appreciated.

Cheers
0
compuit
Asked:
compuit
  • 10
  • 2
1 Solution
 
stevenlewisCommented:
a few things to try
1. enable lmhosts lookup, and edit the lmhosts file
http://www.realcomputerguy.com/lmhosts.htm
and
http://support.microsoft.com/default.aspx?scid=kb;en-us;314884
0
 
stevenlewisCommented:
2.
Removal of registry key: http://cyberwizardpit.net/article2.htm

{{Full-text content removed from this post as per http://www.experts-exchange.com/help.jsp#hi125 --alimu / Page Editor}}
0
 
stevenlewisCommented:
3. enable NetBIOS over tcp

Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
stevenlewisCommented:
4.
{{added article attribution --alimu / Page Editor}}
Article from techrepublic.com by Brien Posey (MCSE).  This article has since been removed from the techrepublic site.

----------
After installing Service Pack 1 on several of my Windows XP workstations, I noticed a dramatic reduction in network performance when communicating with my Windows 2000 servers. Although everything worked fine with small files, when I tried to access, create, or modify a file over 70 KB, I would get a file creation error, a delayed write failure, or some other odd error. After a little digging, I discovered that my Windows 2000 servers were holding the files open even after I had closed them, thus making it impossible to modify the file. Unfortunately, these file lock problems often occurred while the file was open, resulting in a corrupt file.

I first suspected faulty hardware—a bad network cable or hard disk ribbon. Yet after months of experimenting, I determined that my hardware was working perfectly. Since I have almost 20 computers and only PCs running Windows XP with SP1 were experiencing these communication errors, I decided that SP1 must be the culprit. I began researching the problem and after months of searching I found three potential solutions.

Word of warning

The following article suggests ways to edit your system registry. Using the Windows Registry Editor incorrectly can cause serious problems that could require you to reinstall your operating system and you could possibly lose data. TechRepublic does not and will not support problems that arise from your editing the registry. Use the Registry Editor and the following directions at your own risk.

XP has trouble writing to 2000 domain controllers

Unfortunately Microsoft's support Web site doesn’t list Windows XP SP1 problems in a single location so I dug through its knowledge base until I found article 321169, "Slow SMB Performance When You Copy Files from Windows XP to a Windows 2000 Domain Controller."

According to the article, Windows sometimes has problems writing to domain controllers, but should have no trouble reading from domain controllers. Alas, I was having trouble reading and writing to Windows 2000. Sometimes it would take a full 60 seconds for Windows XP to open a 50-KB file that was stored on a Windows 2000 domain controller. Other times though, the same file would open instantly. Although this knowledge base article didn't address my exact problem, I decided to follow the instructions and see what happened.

The article suggests that the slow performance results from a delayed TCP/IP acknowledgement occurring in an SMB: C NT Transact-Notify Change packet. To put it simply, Windows 2000 uses what are known as SMB security signatures. If security signatures are enabled, the redirector is forced to wait until the current SMB command has completed before processing the next one. This means waiting for an SMB acknowledgement from the server. The easiest way to implement a workaround to the problem is simply to disable SMB security signatures on the domain controller by editing the registry.

To do this, open the Registry Editor and navigate to HKEY_LOCAL_MACHINE\System\

CurrentControlSet\Services\LanmanServer\Parameters. Double click on the RequireSecuritySignature value and enter 0 in the Value Data dialog box. Next, double-click on the EnableSecuritySignature value and enter 0 in the Value Data dialog box. However, this registry modification didn’t correct my particular problem.

Possible task scheduling bug

I decided to turn my attention to the Web and see if anyone else was having the same problem. A quick search revealed dozens of Web pages where people discussed similar problems. One of the suggested fixes involved a bug that exists in both Windows XP and in Windows 2000. The bug causes Windows to check for any scheduled tasks that might exist on a remote machine before displaying the browse contents.

This particular bug is also controlled by the registry. To solve the problem, just remove the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\

Explorer\RemoteComputer\NameSpace\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}. This registry fix did speed things up somewhat for me, but didn’t completely correct the problem.

A solution at long last: SMB signing incompatibility

Finally, after another month of digging, I discovered MSKB article 331519, "Network File Errors Occur After You Install Windows XP SP1," in which Microsoft acknowledges the problem. According to Microsoft, the problem is related to an incompatibility in SMB signing between Windows 2000 and Windows XP SP1. It appears several group policy settings are to blame.

To fix the problem, go to a domain controller and open the Active Directory Users And Computers console. Then, right-click on the Domain Controller organizational unit (OU) and select the Properties command from the shortcut menu. Doing so will display the Domain Controllers Properties sheet. Select the Group Policy tab. Select the Default Domain Controller Policy (or what ever group policy applies to the domain) and click the Edit button. Navigate through the policy to Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options. Then, locate the following four policy settings and change them to Disabled:

Digitally Sign Client Communications (Always)

Digitally Sign Client Communication (When Possible)

Digitally Sign Server Communication (Always)

Digitally Sign Server Communication (When Possible)

Close the Group Policy Editor, click OK, and close Active Directory Users And Computers. After you apply the settings, wait for the next replication cycle to complete and the settings should take effect. Once the settings took effect on my system the communication problems disappeared. Rumor has it that Microsoft intends to correct this issue in the next Windows XP Service pack.
0
 
compuitAuthor Commented:
Wow stevenlewis i'm gobsmacked, what an amazing response!

I'm going to the PC right now to try all these suggestions, will let you know.
0
 
stevenlewisCommented:
another thing to try
a work around is to change the auto disconnect time on the pc's

lower it, and it will free up the connection so another user can use it

Change LAN Auto-a Timeout (Windows NT/2000/XP): http://www.winguides.com/registry/display.php/194/

{{Full-text content removed from this post 04-May-2005 as per http://www.experts-exchange.com/help.jsp#hi125 --alimu / Page Editor}}
0
 
stevenlewisCommented:
Hmmm, not sure what to do in this case. I have been a top expert here for a LONG time, and have a considerable database of solutions, from which I C&P my responses. I am not going to go thru and source the whole thing. I will continue to post in the manner that I have been now for almost 5 years. alimu, if you want to follow me around and source all my posts feel free. If you have a problem with this, then I suggest you get a Mod to email me. I also object to your removal of the instructions in my post #2. I credited the source, but your edit removed the meat and meaning of my suggestion (no reference to what reg key to remove, and as I'm sure you know, there are tons of reg keys)
removal of reg key hardly describes what my post refered to!!
In your effort to sanitize my posts, you diluted the content so it becomes worthless.
IMHO, as long as I include a link to the original source, then I haven't violated the MA. As you know (see your comment on suggestion #4) pages are removed from the web all the time, and if I just post the link, and the page is removed, then the PAQ becomes worthless. By including the source, and then quoting the page, the info is then included, and the PAQ is valid
0
 
stevenlewisCommented:
some info on Plagiarism
http://www.georgetown.edu/honor/plagiarism.html

"Plagiarism is defined by the Honor Council document as "the act of passing off as one's own the ideas or writings of another.""
In no way did I pass off any of the above as my own work, and cited the sources. I don't know if you went to college or not, but when writing papers, it is common to use the research you find, and is allowed as long as you source it correctly.
Please unedit my posts above
Thank you
0
 
stevenlewisCommented:
Hehe, gotta get 3k/month to keep the premium (and the weather hasn't been helping here either)
OK, I'll try it your way, but (and this happened just this morning) I post the link, another expert comes in and paraphrases it (happens a lot here). Got my 3k for this month, so I'll just be finnishing off the few Q's I'm working on, and see ya next month LOL
0
 
compuitAuthor Commented:
Thanks Steven, I tried all your suggestions, and it looks like the autodisconnect thing done it. It all works awesome now! I ended up installing Windows XP SP2 aswell which i think contributed.

I would just like to take time out to thank you greatly for your quick fire responses, and quality of help. I felt like you went the extra mile for me. I have given you an A grade, which I think is totally deserved! (i would have given you an A+ if it was possible).

Also I don't want to get involved with the arguement with the admin's, i just want to put in my 2c. I think experts should be able to post a link, along with part of the text which is relevant. Saves me going through the whole text, which can save me time aswell as getting confused by the rest of the content. Luckily i printed out what you had typed before it was removed!

Anyway, thanks heaps!


0
 
stevenlewisCommented:
Gl;ad we could help! and thanks for the great grade
Steve
0
 
stevenlewisCommented:
N, I will do my utmost to try and folow the new guidelines on this (you know I never rock the boat, ....well almost never hehe), but I do think (an opinion here) if we list the source, as a reference, then quoting the article should be OK (again, I'm not a legal expert, barely an EE expert *grin*), Like if you source your research paper at college, giving credit where credit is due. I could be wrong, not that versed in copywrite law. Bu I do see your pointg, and will abide as best I can (If i slip, I'm sure you will let me know)

BTW, won a skin worth $23 toinight LOL
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 10
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now