IIS ASP.Net Session timeout

Hi,

 I've been informed that the session timeout for one of our web
 applications should now be 60 minutes instead of the default 20 minutes.

 I've gone into the web.config file, and changed the sessionState element to look like this:

<sessionState mode="InProc"
   stateConnectionString="tcpip=127.0.0.1:42424"sqlConnectionString="data
  source=127.0.0.1;Trusted_Connection=yes"cookieless="false" timeout="60"   />

  I've also added Session.Timeout() = 60 to the Global.asax.vb file's  Session_OnStart()

 I also added Session.Timeout() = 60 to my PageLoad event.

 I even went into the configuration settings in IIS and changed the

 default timeout for this particular application to 60 minutes.

 The problem is, the timeout is still only 20 minutes.

  Am I missing something? let me know immediately.
 
Thanks
 sivaji raju.
psivajirajuAsked:
Who is Participating?
 
pratcpCommented:
You may want to check the ASP Script Timeout property in IIS as well...

HTH
Pratcp
0
 
dvsameerkumarCommented:
Hi

Open your IIS Manager from program files...and follow the below process

1. Right click on default website option
2. Select Home Directory tab
3. Click on Configuration button
4. Select App Options tab
5. here the session timeout is by default set to 20 mins....change it here...check the enable session state....

Let me know incase of any difficulty

Regards,
Sameer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.