USB DOS Printing using Laserjet 1020

Hi

Before i start, i would just like to mention that i downloaded the latest driver from HP as well and the results are the same.

I just purchased 2 HP Laserjet 1020 printers. These are USB printers. We use a DOS based point of sale program. I have 16 other USB printers connected on my network, using this command to have the DOS program print to the USB port.:
NET USE LPT1 \\COMPUTERIP\PRINTERNAME /PERSISTENT:YES

All the other printers work fine, but the 2 new ones has a strange problem. In the printer status window it shows "Local Downlevel Document" status "Printing".

The document does NOT print. I have tried this printer on both Windows 2000 and Windows XP computers with the same results. I also added the driver to my Windows 2003 Server.

I also tried remote printing for example: My ip is 192.168.0.1 and the printer i installed on another pc with ip 192.168.0.2 and shared the printer as HP1020.
I used the following command to map the printer : NET USE LPT1 \192.168.0.2\HP1020 /PERSISTENT:YES, but no luck.

What else could be wrong? I just don't get this. Could this be related to the print processor or an invalid registry entry???

Please help
LVL 10
kcarrimAsked:
Who is Participating?
 
NetminderConnect With a Mentor Commented:
Closed, 500 points refunded.
Netminder
Site Admin
0
 
kcarrimAuthor Commented:
Very Urgent. Please reply!
0
 
kcarrimAuthor Commented:
I solved the problem. This printer and future printer models does not understand the PCL3 language, therefore, printing from DOS is not possible. To overcome this issue, i have downloaded DOSPRN  1.77 from http://www.dosprn.com/
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.