[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 334
  • Last Modified:

550 Relay Denied - Using Backup Assist Software On Exchange2003

Hello,

I have a Win2003 server, running Exchange2003.  In the SMTP protocol, I have relaying allowed for all computers which authenticate.......

I have installed a software product called BackupAssist, which helps manage NTbackups.
I has the option to send a notification email (backup report summary) to a user.
I have set up correctly, using my userid and password.  However, when it trys to send the
email it is getting 500 Relay Denied errors.  I have contacted the company and they said I need to allow relaying......which was already set for authenticated users.  

Any ideas?  Please advise.  Thanks.
0
rstuemke
Asked:
rstuemke
  • 8
  • 7
1 Solution
 
rstuemkeAuthor Commented:
Hello,

Here is the text I culled from the link you provided:

no problem....ADSIEdit\configuration\services\microsoft exchange\urdomain name\
first administrative group\servers\servername\protocals\smtp\CN=1
1 = ur first virtual server(i suppose u have one virtual server)  right click\click on
properties....then click on security tab  and u will see the options u are  looking for..
in this section the server that is relaying including the exchange server must have
"send as" allow permission....(do not touch anything else)....usually the first exchange
server (exchange domain servers)has that option grayed out ...which means it is inherited just check to see if ur server has that option checked

Now Send AS has both the ALLOWED and DENY checked and GRAYED OUT.
I have changed nothing at this point......now what do I need to do?

Thanks.....
0
 
rstuemkeAuthor Commented:
There is a list of Users, etc.  Not all have both, but some do.  The Domain Administrator has both with is the account I used to send mail notification in Backup Assist......
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
VahikCommented:
OK first to take care of permissions....if both are allow and deny are grayed out that means they are inherited and since both allow and deny are checked ...deny takes precedence...so to undo deny ...u must clik on advanced find the user or admin with deny
permission in the list click on it and next to deny check ALLOW and ok ur way out...
now when u check permissions again u will see that gray has turned in to a white box for
allow permission( checked) which now means allow takes precedence over deny permission....
as to which account will make ur problem go away ...i dont know...but try admin account
or the agent account u created for backupassist or backup software...
call back if u need more help...
0
 
rstuemkeAuthor Commented:
I allowed SEND AS for the all accounts which were denied.....restarted the Backup Assist program and ran an email test......still not working......so I added a new user with administrative (domain) authority......gave it full control allowed.....changed the Backup Assist SMTP logon to this userid and password....ran notification test again....still failed....
0
 
VahikCommented:
did u restart exchange server?
0
 
VahikCommented:
one more thing ...in ur smatp virtual server under relaying section u must check
Select which computers may relay through this virtual server
  ALL EXCEPT LIST BELOW and list below must be empty
0
 
rstuemkeAuthor Commented:
Okay,

I restarted the server......checked relaying options....checked - ALL EXCEPT LIST BELOW and there is nothing in the list.  Ran the test again......same failure....pretty nice huh?
0
 
VahikCommented:
i know man it is frustrating..the same setup working for some and failing for others...i really now believe exchange has a soul....a moody woman's soul....maybe the original programer was a lady..hahaha..let me think more...if i find something else i will post back....
0
 
VahikCommented:
ok try this go to the relaying section and check "only the list below" and add the ip address of ur server that the software is installed on....then go and uncheck "allow all
computers bla bla" and check users and just add the user that softeware uses to relay...
and check allow submit and allow relay....restart and try again.....we have to get this working orelse even mcdonallds wont hire us....
0
 
VahikCommented:
dont forget to add 127.0.0.1 also to the allowed relaying part besides the ip address of
the relaying server....
0
 
rstuemkeAuthor Commented:
Can not try again until Monday....will update then.....thanks for taking the time to help me.....
0
 
rstuemkeAuthor Commented:
Added 127.0.0.1 and also the subnet for our domain.....still failed.....
0
 
rstuemkeAuthor Commented:
Any one have any addition info which could help me?  Please advise.  thanks.
0
 
rstuemkeAuthor Commented:
Awared points to Vahik, for effort that was put forth.  Problem found to be with McAfee anti-virus software preventing relay.  Thanks.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now