Problems saving to network drive

Posted on 2005-05-04
Last Modified: 2010-04-03
I have a number of XP PRO clients connected to a server running Small Business Server.

One client is having problems saving files to a network drive on the server. He gets the error message "Error copying file of folder - Cannot copy xx: The is not enough free disk space. Delete one or more files...."

The is plenty of free space on the destination disk and other users do not have the same problem.

In My Computer the total size is shown as 1.00GB and the free space 4.00KB which is clearly not correct. Other users show the total & free space reported incorrectly but with different values but as mentioned do not have the same problem.

Is there a way to solve this?
Question by:paulcronin
    LVL 95

    Accepted Solution

    Sounds like someone enabled Disk Quotas on the server.  If you don't want them, disable them.  If you do, learn how they work.  Specifically, When a quota is enabled, it calculates usage based on file ownership for the ENTIRE drive letter.  If you have a Shared drive on F: and a user's drive on F: (where F is the server drive) and you want to limit users to 1 GB on their home directory, you MUST understand that files stored in the SHARED folder will also count towards that 1 GB limit.  The way around this is to put the users on one disk (say F:) and the group shared drive on another (G:) since quotas only apply to the drive letter they are set for.

    Author Comment

    I did think about quotas but did not think that applied as the users do not have their own folder/drive on the server. They all share one folder and subdirectories and have W mapped to that folder on the server. Their only personal folders are on the client PCs. If the quoatas still apply I can turn them off.
    LVL 16

    Expert Comment

    >> I did think about quotas but did not think that applied as the users do not have their own folder/drive on the server.

    It doesn't make a difference with disk quotas, they're not calculated on a per-folder basis.  If a disk quota of 1GB is set up on a disk, users are limited to that 1GB across all folders on that drive.

    For instance, we have a setup here so that all user area folders are on a disk-quota'd drive, G:\.  While I was on holiday, a new group folder was added to the drive.  Once a user copied 800MB into the group folder, he only had 200MB available in his personal folder, even though the disk itself had 30GB free.

    You might not have a user folder setup but, if there is a disk quota of 1GB on that disk, each user will only be allowed to 'own' 1GB of files on that entire disk.



    Author Comment

    I will accept the answer from leew because changing the quota limits has solved the problem - thanks.

    Out of interest I would like to know how the usage is calculated because in this case all users were accessing a single folder & sub folders on the server and files were being accessed by multiple users (at different times). There was no user specific folders & files. The strange thing is that all users (architects using AutoCAD) are doing similar jobs and only a few reached thier limits.

    If anyone else hits this problem you can either turn of quota management or increase the quota limit. If you do the latter make sure you don't just increase the disk space  limit on the quota page (I though this was a system wide setting but I think it only applies to new users). You need to click on Quota entries (which shows you how much space each user is using) and set the limits individually - select one or more user & right click to select properties & adjust limits or select to not limit disk usage.
    LVL 95

    Expert Comment

    by:Lee W, MVP
    Again, quotas are applied per logical disk on the server.  If the server has two disks, you can apply them on one and not on the other, or apply them on both with radically different settings.

    The amount of quota used is determined by file ownership.  I'm not sure about autocad, but some apps, when a user opens and saves a file, change the ownership of the file because the original is technically deleted and the new one is saved as them, making them the owner.  If Autocad behaves similarly, then a few people could be reviewing, editing, or making minor changes to already created files that end up making them the owner of a lot more files and in turn using up their quota space.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Scale it in WD Gold

    With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

    A bootable USB key can be very handy now-a-days. My favorite USB key consists of our Windows 7 image, network card drivers (to connect up to a Ghost server), the latest BIOS updates for all of our PCs and CopyWipe (to erase a retired PC) Creating…
    Hi, I've made you some graphics for a better understanding how RAID works. First of all, there are two ways a raid can be generated: - By hardware - By software What does that mean? This means: If you have a hardware RAID controller, there…
    This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
    This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now