gedit is in read only mode

I try to use gedit, but it is always in read only mode.
It is not possible to save the text.
How can I change that.
fredhartAsked:
Who is Participating?
 
slow1000Connect With a Mentor Commented:
Since the problem doesn't seem to be from any system-wide changes you could have made when your original keyboard problem occurred, perhaps the program itself is damaged.  You could try removing it, then reinstalling it.
0
 
slow1000Commented:
Probably an oversimplistic solution, but are you sure you have read/write permissions on the files.  If you try to edit config files from /etc or other read only locations, gedit will only be able to write if you are running it from the root account.

Otherwise, see if there is a .gedit file in your home directory or in /etc that has a setting to limit gedit to read-only.
0
 
fredhartAuthor Commented:

I have tried to find a .gedit file but there is none.
I suppose there must be somewhere a config file for gedit

The moment I open gedit and I type in one character , gedit switches to read only.

Maybe it helps if I give some history:
It all started when suddenly the keyboard was complete disabled for a certain user, the mouse worked normal.
For other users there was no problem.
I created a new user and  I copied all files to a new user, I removed the old user and his directory.
I created again that user and copied back all the files. From that moment I couldn't use gedit anymore.


0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
fredhartAuthor Commented:
I have to add that the user directory has permission 750
0
 
slow1000Commented:
Is the problem unique to that user, or is it systemwide?
0
 
fredhartAuthor Commented:
It is system wide, even when logging in as root.
0
 
idmiskCommented:
gedit is a X application, or? i hope you are starting it as some user or as root?
after you are in some window manager (KDE, Gnome, whatever) you start gedit. how do you do it? click on icon or open a terminal, enter gedit an press enter?

-michael
0
 
fredhartAuthor Commented:
slow1000 thanks, I removed it and reinstalled it.
The problem is gone.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.