Outside users getting message saying that my users have exceeded mailbox storage limit

Posted on 2005-05-05
Last Modified: 2008-01-09
Some senders are getting errors like this:

Your message did not reach some or all of the intended recipients.

      Subject:      xxxxxxxxxx
      Sent:      5/5/2005 10:48 AM

The following recipient(s) could not be reached: on 5/5/2005 11:12 AM
            This message is larger than the current system limit or the recipient's mailbox is full.  Create a shorter message body or remove attachments and try sending it again.
            < #5.2.3 smtp;450 5.2.3 Msg Size greater than allowed by Remote Host>

However I do not have any limit on these users. We are restricted by our ISP to 30MB file attachments but a sender could send 30mb attachments to any user all day long. Also the person sending to us is only sending a 6MB file. I have a watchguard firewall and mcafee webshield in between the internet and the email server. This seems to be happening randomly. I have checked with mcafee and they are saying it does not seem to be anything on the webshield side. I have not called watchguard since everything seemed to be working fine when we had 5.5 last year. Any ideas?
Question by:msidnam
    LVL 2

    Expert Comment

    In Exchange System manager go to Global Settings-> Message Delivery -> properties

    On the default tab increase the receving limit. You can choose no limit but be aware if you change it to no limit, people will start attaching 700 MB iso files and your server will just receive, this will cause 100's of log files to be created and also impact the size of your store.

    Next, in Exchagne system manager under Admin Groups->Admin Group name->Servers->protocols->smtp pull properties on the default smtp virtual server.

    Click the messages tab and verify that size limit restictions are to your likings.
    Remember these settings are for outbound mailflow.

    LVL 2

    Author Comment

    Thank you for the info but for the Message Delivery we have it already set to No Limit

    As for the default smtp server properties i do not have the limit message size checked off
    LVL 25

    Expert Comment

    the 2 places that exch_admin told you to look only check for the message size being larger than the allowed size, but your problem could be that some of your users have gone over the limit on their individual mailboxes.  IE the size of their whole mailbox is over their allowed limit, not just one incomming message is over the incomming message max size.  To check the size limits set for the entire store open up exchange system manager and  go to servers>yourservername>your storage group>mailbox store (rightclick and choose properties), then look at the limit tab, it will tell you what limits are set for the entire mailbox store.  This will be how big each users' mailbox can be.  

    to look at a users' inividual setting (which overrides what is set at the store level) you have to open active directory users and computers> open the users properties, click the exchange geneal tab, and click storage limits.  this will tell you the individual user's limits.
    LVL 2

    Author Comment

    We have no indivudual limts and no limits on the store. Personally I think it is either our firewall or web shield that is either manipulating the data and then once it gets to the exchange server it sees this corruption and says "no way" and send it back with whatever error comes close. in this case, the mailbox limit has been reached. Are there any in depth diags i can put on the exchange server? Unfortunately this happens so random that i would need to keep the logs on for several days. But i am worried about hd space. we do have several gigs available.
    LVL 2

    Accepted Solution

    If you want to determine if its the firewall or the Exchange server there are several ways to accomplish this task.

    Method 1.

    1. Send a message from outside, (hotmail) with an attachment large enough for it to bouce back.
    2. When the NDR is received by hotmail, go to options and turn on advanced headers.
    3. Take a look at the header to see if the exchange server name or ip or the firewall is listed as the originator.

    Method 2.

    1. Turn up SMTP logging in NCSA format. In ESM, Properties of default smtp virtual server under protocols, smtp
    2. Send a test message.
    3. Monitor the smtp log to see if the Exchange server logged reciving the message and then issuing NDR.

    Hope this helps

    LVL 2

    Author Comment

    Exch Admin,
    I will try these out and post back. thanks.
    LVL 2

    Author Comment

    I turned on logging, i had WC3, but i like the NCSA better. It looks as though the email is being rjected by the firewall. When a message is rejected in the email logs it does not have the usual command like ehlo, rcpt, data, etc. it only has the from and to email address. I turned on logging inside watchguard and when an email is sent it rejects it with: client sent oversized data line -- terminating session.

    I have only tested it with an email i know is not working and the email is only 18k. the wird thing is that if i send it with another email program, in my case gmail, it works fine. But with hotmail or yahoo it comes back with the above error. On to see watchguard i guess. Thanks again.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Easy CSR creation in Exchange 2007,2010 and 2013
    Use these top 10 tips to master the art of email signature design. Create an email signature design that will easily wow recipients, promote your brand and highlight your professionalism.
    In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
    In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    12 Experts available now in Live!

    Get 1:1 Help Now