• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1487
  • Last Modified:

Mandrake 10.1 - ProFTPd - Permissions

I've just installed ProFTPd to my Mandrake Linux 10.1 server.  I've been running the Mandrake server for a while, but recently I needed an associate to edit / replace / add files on the server so installed the ftp.

My problem is that when I log in with his username and password, I can't do anything without getting a "550 Permission Denied" error.

All of the files in the directory are owned by either Root or Apache.  What do I need to do in order to allow my associate to make changes to the files within this directory?

500 points to whomever can explain this to me in clear and concise terms as my skill levels are only average within Linux; i.e. please don't respond with "oh, just change the permissions"

Here's a copy of my /etc/proftpd.conf file...

-------------------------------------------------
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName                  "FTP Server"
ServerType                  standalone
DefaultServer                  on

# Allow FTP resuming.
# Remember to set to off if you have an incoming ftp for upload.
AllowStoreRestart            on

# Port 21 is the standard FTP port.
Port                        21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                        022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances                  5

# Set the user and group under which the server will run.
User                   ftp
Group                  ftp

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
DefaultRoot ~

# Normally, we want files to be overwriteable.
AllowOverwrite            on

# Bar use of SITE CHMOD by default
<Limit SITE_CHMOD>
  AllowAll
</Limit>

# Needed for NIS.

PersistentPasswd              off

# Default root can be used to put users in a chroot environment.
# As an example if you have a user foo and you want to put foo in /home/foo
# chroot environment you would do this:
#
# DefaultRoot /home/foo foo
0
ezSoftware
Asked:
ezSoftware
1 Solution
 
jlevieCommented:
Make each login account be a member of the same group that the web server rus as, typically apache. Then set group ownership to apache for all of the web site files and give that group write permissions.
0
 
ezSoftwareAuthor Commented:
I was afraid to do that and wanted confirmation.  That worked, thanks much.

For others who may experience this problem here's what I did...

Within the Mandrake GUI (X) I went to the properties of the home directory of the site, clicked the Permissions tab, set the Group setting to "Can View and Modify Content", then set the User & Group to Apache.  Also checked the "Apply changes to all subfolders and there contents" box and then clicked OK.

Added my user to the Apache group and everything worked like a champ.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now