P-to-P T1: Should I Route or Bridge?

Posted on 2005-05-06
Last Modified: 2010-05-18
As stated in a couple of previous questions, I'm learning about Cisco routers by pulling two old routers, a 1720 and a 2610, out of storage and preparing them to be put back into service. The two routers will connect two small offices across a Point-to-point T1. The T1 will carry VoIP between IP VoIP gear, and file sharing and MAPI between XP clients and W2K3 servers. Both offices have their own DSL routers for accessing the Internet.

I've gone through the routers' configuration and have tried to learn what each line does. I see that they were setup as a bridge IRB with the offices on the same subnet.

I've also learned how to use the ConfigMaker. It sets up the the configs with a routing setup on different subnets.

I can find very little on bridge IRB. The most detailed explanation I've found is in the Cisco IOS in a Nutshell. It explains that bridging doesn't scale well and that it requires more CPU from the router. But I don't see the WAN getting anymore complex and if the routers were powerful enough before, they should be fine now...

But then, I do need to implement QOS for VoIP, which was not used previously. And the offices have their own DSL, where before they shared just one. And the ConfigMaker has done the work for me in setting up the routing...

What would be best: bridge or route?

(I've set the point value to a higher level as I'm sure that I'll be asking other related questions and that I'll spread points among those who assist in helping me.)
Question by:TerrellITC
    LVL 19

    Accepted Solution

    As you stated yourself, the main disadvantage with bridging is that it does not scale well.  It also does not perform well over a large network or a slow link - but a T1 between sites will not be a problem in this regard.
    If you bridge, you are essentially "joining up" the 2 networks as one so windows browsing will work (network neighbourhood) which will make for tidy file sharing.  These broadcasts are not passed across routers by default so you may need to use lmhosts entries to browse machines on the opposite site.

    Thinking ahead, if you really do not see your environment scaling much, then the bridge solution would suffice.  The only variable I see is Voip - how many units will you be using as it is important that Qos be deployed to allow each voip device a good connection.  File transfer can suffer spikes in activity but voip by its nature is time sensitive and needs priority over all other traffic.
    It is also woth noting that Qos does have an effect on your cpu also.

    Pls port further queries

    LVL 79

    Assisted Solution

    >I do need to implement QOS for VoIP
    My advice - bridge only if you absolutely MUST. If there is some application that will only work with some odd non-routable protocol.
    ALWAYS route when you can. Windows browsing works just fine over a routed network as long as you include "ip helper-address", use WINS or DNS properly.
    It is very difficult to impossible to properly implement QoS over a bridged link.

    LVL 27

    Assisted Solution

    As has been said, and I feel the need to reiterate redundantly, ;) ... bridging was usually done for special circumstances when there were layer 2 protocols that could not be routed at layer 3 - before it was common to "tunnel" these inside IP.  We used to have some remote offices with a hospital terminal based IT system - they had to be bridged because the hospital system couldn't route.  Bridging is "old school" and hardly ever used any more, except with Wireless.

    Author Comment

    The key is a "smooth" VoIP, so it sounds like routing will give more CPU time to the QOS.

    With the XP clients and W2K3 servers, I don't have a need for WINS or NetBUEI. I'm the only one who "browses" the network, and I rarely do that...

    The VoIP vendor recommends Low Latency Queuing, and gives the following configuration, which I was going to integrate with the ConfigMaker settings:

    class-map voice
      match access-group 101
    class-map v-control
      match access-group 102
    policy-map voice-policy
      class voice
        priority 12              
    class v-control
        priority 12              
    class class-default
    interface Serial 0/0
      service-policy output voice-policy
    access-list 101 permit udp any eq 2698 any
    access-list 101 permit udp any range 12288 12544 any
    access-list 102 permit tcp any eq 2698 any
    access-list 102 permit tcp any any eq 2698
    LVL 13

    Assisted Solution

    I highly advise you not to try bridging, if it was just a few hosts and a little computer data going back and forth it might be ok, but throw VOIP in the mix a forget about it even in a small environment, as that is an invitation to problems.

    Also even if it did work, it would severally limit your ability for expansion. Throw in another office, or expand what you have and you will have to start all over again and change all the address in one office. Better off do it right the first time, and be done with it once and for all.  

    Author Comment

    Thanks all for your advice. I gave the accepted answer to nodisco because he was first, but I learned from all your comments, so I spread the points among all the answers.

    Since QoS is the primary reason for going with a PtoP T1, it looks like I'll be learning routing. Which leads me to a question about ConfigMaker and routing, which I will post shortly. :-)
    LVL 19

    Expert Comment

    hi TerrellITC

    Whilst i appreciate the accepted answer - I don't think it is the best solution for your issue - routing is.  We all learn from expert input on questions and the points that the others have made showed me that their practical experience on this specific issue is superior.  I advise you to post on community support to have the question unaccepted and re-assign the points accordingly.

    I am not being ungrateful - but the bottom line is credit where credit is due.



    Author Comment

    Hi nodisco,
    I took your answer to recommend routing in my case, as you brought up the issue of VoIP. You explained why the previous setup was a bridge and why I might consider switching over to routing. The other answers, all of which I learned from, strengthened this answer.
    But if any of the experts feel I awarded the question or points wrongly, I will follow through with a correction.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
    I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now