• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1553
  • Last Modified:

What does "Access can't find the field "|" referred to in your expression..." mean???

I'm getting this error message whne i try to run a filter and I can't for the life of my figure out what it means.  There is no "|" referred to in any of my tables or expressions.  Any ideas?

Mitchell
0
MitchellVII
Asked:
MitchellVII
1 Solution
 
stevbeCommented:
Sounds like the field name you are using in your Filter property is not part of the form.

Steve
0
 
puppydogbuddyCommented:
Stevbe is correct...most of the time it is due to a mispelled name reference or incorrect case used when referring to a control or field.
0
 
MitchellVIIAuthor Commented:
Ok, I found the problem.  Weird Access-related thing I think.  I was creating a Query Object using some complex code.  That query was then being used as a filter for my form and i was getting this error message, but only on forms where the underlying tables were over 10,000 records.  I think Access was getting bogged down on the timing of when it was performing things.

Anyway, instead of creating the query and using that as the basis for the filter, I just created a table and appended the records generated by my query to that.  I then used the table as the basis for the filter.

Worked perfectly.

Mitchell
0
 
LunchyCommented:
Closed, 125 points refunded.
Lunchy
Friendly Neighbourhood Community Support Admin
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Tackle projects and never again get stuck behind a technical roadblock.
Join Now