?
Solved

530 PORT error message accessing FTP site thru' Internet Explorer

Posted on 2005-05-07
14
Medium Priority
?
537 Views
Last Modified: 2013-12-11
Hi, I'm trying to access my company FTP site from my home computer. Normally it works absolutely fine. But now I get the error message: "200 Typeset to A" followed by "530 PORT Command only accepts client IP folder address". If I go upstairs to my kids computer (on our home network) everything is fine. Only difference is that I'm on ME and she's on XP. I've run numerous anti-virus progs. - but nothing odd comes up. And I've restored factory settings on IE - but still no joy. Thanks in advance. Jake.
 
0
Comment
Question by:jake_bernard
  • 7
  • 5
  • 2
14 Comments
 
LVL 27

Assisted Solution

by:Jonvee
Jonvee earned 800 total points
ID: 13950313
If you scroll approximately half way down this article you'll see a reference to the "530 PORT Command" 'error', it may help.  
Have deliberately left the highlights on so that you can quickly home in on the comments:

http://64.233.183.104/search?q=cache:1jHH2eNL4kIJ:www.gamingforce.com/forums/archive/index.php/t-12137.html+530+PORT+Command+only+accepts+client+IP+folder+address+windows+me&hl=en
Jonvee
0
 

Author Comment

by:jake_bernard
ID: 13950634
Thanks for your reply ......I note "Tell him he needs to either use passive mode or to configure his client to send his WAN IP when using PORT mode. It's not on your end, it's on his." However, I can't find the option to enable passive mode in IE properties under the advanced tab. I know it should be there, but there's nothing remotely like it - and nothing that refers to FTP......any suggestions? Am I looking in the wrong place? As an alternative how would I send my WAN IP?  

 Thanks in advance!  Jake.
0
 
LVL 27

Assisted Solution

by:Jonvee
Jonvee earned 800 total points
ID: 13950764
Jake,
Internet Explorer 6.0 has under 'Properties' a check (tick) box marked "Use passive FTP (for firewall and DSL Modem compatibility).   There appears to be no such option within IE 5.5.  
Can only assume therefore that you are running the latter.
Meanwhile this article may contain useful information.   Am continuing to investigate:

http://homepage.ntlworld.com/robin.d.h.walker/cmtips/ipaddr.html
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 20

Accepted Solution

by:
nedvis earned 800 total points
ID: 13950788
If you have Internet Explorer 6 installed there should be two lines and checkboxes in Advaced configuration tab ( under "Browsing" subcategory)  that read:
Enable Folder View for FTP Sites
and
Use Passive FTP mode ( for firewall and DSL compatibility )
----------------------
     If , for some reason, WIndows Registry entries are missing or corrupt you may try to reinstall Internet Explorer ( do the Repair IE )
Or you can import default registry values for Internet Explorer 6 pertaining to the two.
USING NOTEPAD COPY AND PASTE following lines ( do not copy lines ) and save them in two separate files FTPPASV.REG  and  FTPUI.REG
with file extension *.REG and then rightclick and MERGE their contents to your registry so you can enable folder view and passive FTP mode through Inetner Explorer Advanced tab options.
--------------------------------------------
for FTP passive mode:
--------------------------------------------

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\AdvancedOptions\BROWSE\FTPPASV]
"PlugUIText"="@inetcplc.dll,-4743"
"RegPath"="Software\\Microsoft\\Ftp"
"Text"="Use Passive FTP for compatibility with some firewalls and DSL modems"
"Type"="checkbox"
"CheckedValue"="yes"
"UncheckedValue"="no"
"ValueName"="Use PASV"
"DefaultValue"="no"
"HKeyRoot"=dword:80000001
"HelpID"="iexplore.hlp#50588"

_______________________________________________________________________
for FTPUI :
________________________________________________________________________

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\AdvancedOptions\BROWSE\FTPUI]
"RegPath"="Software\\Microsoft\\Ftp"
"Text"="Enable folder view for FTP sites"
"Type"="checkbox"
"CheckedValue"="no"
"UncheckedValue"="yes"
"ValueName"="Use Web Based FTP"
"DefaultValue"="no"
"HKeyRoot"=dword:80000001
"HelpID"="iexplore.hlp#50560"
"PlugUIText"="@inetcplc.dll,-4737"

-------------------------------------------------------------------------------------------------------------

hopefully this will help

good lcuk
nedvis
0
 
LVL 27

Expert Comment

by:Jonvee
ID: 13952290
Jake,
If you're running IE5.5, perhaps you could take another look at IE properties > Advanced (tab).  
See if you can locate >>   "Use passive FTP for compatibility with some firewalls and DSL Modems".  It IS present.

Still assuming that you are running IE5.x, have you been able to acquire the most recent critical updates for it?  
If no, this link could be helpful.  See under 'Previous Versions':
http://www.microsoft.com/windows/ie/downloads/default.mspx

Still assuming IE5.x (and if you still have a problem), one option would be to upgrade to IE6.  
Should you decide on this action then the following download facility may be useful.  

http://www.broomeman.com/support/wsiedown.html
0
 

Author Comment

by:jake_bernard
ID: 13953104
Thank you both for your comments. I sense you're in the right area, and I have tried the following;

I'm fairly certain I'm running Internet Explorer 6.0 because when I go into the Internet Explorer folder in "Program Files" and right click on the IEXPLORE icon and select properties it does say, under the version tab, "File Version 6.0.2800.1106". However, when I right click on the IE icon on the desktop and select properties and go to the advanced tab, there is no option under the browsing subcatagory for "Enable Folder View for FTP sites" or "Use Passive FTP mode (for firewall and DSL compatibility)". I know they should be there - and on my son's machine (also ME), I can see them - and connect to the FTP site.

I have done a Repair IE and I have also "reinstall the previous Windows configuration" which takes me back to IE 5.5 - and then reinstalled IE 6.0. But still no joy - and the properties options under the advanced tab do not change.

I'm not that familiar with changing values in the registry, but if you think that really is the problem, I'll have a go.

Thanks again

Jake

ps points increased to 400




0
 
LVL 27

Expert Comment

by:Jonvee
ID: 13953122

You could uninstall and reinstall Internet Explorer6 yet again, but this time following the recommendations here.  
This may well be the most efficient method.  It's a good article:

http://www.btinternet.com/~winnoel/ReInIE.htm

Jonvee
0
 
LVL 27

Expert Comment

by:Jonvee
ID: 13953128
An alternative you may wish to try is to remove IE6 as follows.  
Instead of using IERadicator, 'remove' IE6 from DOS:            
                                     
Download a Startup Disk, if required, from:  
              www.bootdisk.com

Bootup with the Startup disk and at the A:> prompt type (note the spaces):

REN C:\PROGRA~1\INTERN~1 OLDINT
Press enter.

Then try the IE6 reinstall.(Make sure you previously download a copy of IE6!).

If it doesn't work you can still revert to the complete "winnoel" method, and repair your 'System Restore' as appropriate.
0
 
LVL 27

Expert Comment

by:Jonvee
ID: 13953131
How to create a Startup Disk(floppy) in Win Me:
                            http://support.microsoft.com/default.aspx?scid=kb;EN-US;267287
Click Start > Settings > Control Panel > Add/Remove Programs > Properties > Startup Disk tab > Create Disk.
Good luck.
0
 

Author Comment

by:jake_bernard
ID: 13953454
Dear jonvee,
Thanks for your suggestion.... I'll try it this afternoon -  have to go and get some flopppies! However, curiously, I tried to access the FTP site thru' a  Firefox browser (just installed) - and got no joy..... error message "530 login or password incorrect". Could this mean it's not a problem with IE? Thanks as always. Jake
0
 

Author Comment

by:jake_bernard
ID: 13953597
I take that last comment back .... connected using Firefox browser, so, you're right, it does look like an IE problem. Will be in touch when I've I've created the startup disk. Jake.
0
 

Author Comment

by:jake_bernard
ID: 13955684
Thank you both so much .......I've split the points 200 each. I hope that's OK. The problem was all to do with enabling PASSV mode - as Jonvee first suggested. However the box for doing this in IE properties under the  advanced tab was missing and there was no Windows registry entry. Accordingly I did what nedvis suggested and imported the default registry values for Internet Explorer 6 - cutting and pasting as he suggested. After restarting, the boxes appeared - and checking on "Use Passive FTP" fixed the problem.
Thanks again. Jake.
0
 
LVL 20

Expert Comment

by:nedvis
ID: 13956388
Great, thank you
nedvis
0
 
LVL 27

Expert Comment

by:Jonvee
ID: 13957289
Jake
Yes that's fine, and thanks for the extensive feedback.  Installing & testing Firefox was a good move!
Jonvee.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
Most folks would know the basics of how Dropbox works, so that’s not the purpose of this article. Security is what it’s all about, so here I’ll share how I choose to secure my Dropbox Account and the Data it contains.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question